summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-06-17 04:05:39 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-06-17 04:05:39 +0000
commit880a8154e08b62f82b37627c41f3bd3366c9e330 (patch)
treee1844bcedbbd05bb2ac9686c2e38c1732efc23d7 /dev-db/postgresql/postgresql-7.2.1.ebuild
parentturning off sandbox in gcc3 profile (diff)
downloadgentoo-2-880a8154e08b62f82b37627c41f3bd3366c9e330.tar.gz
gentoo-2-880a8154e08b62f82b37627c41f3bd3366c9e330.tar.bz2
gentoo-2-880a8154e08b62f82b37627c41f3bd3366c9e330.zip
java USE variable fix
Diffstat (limited to 'dev-db/postgresql/postgresql-7.2.1.ebuild')
-rw-r--r--dev-db/postgresql/postgresql-7.2.1.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-db/postgresql/postgresql-7.2.1.ebuild b/dev-db/postgresql/postgresql-7.2.1.ebuild
index c2a6206f71d8..595158ffc721 100644
--- a/dev-db/postgresql/postgresql-7.2.1.ebuild
+++ b/dev-db/postgresql/postgresql-7.2.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Geert Bevin <gbevin@theleaf.be>
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.2.1.ebuild,v 1.1 2002/06/14 20:13:23 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.2.1.ebuild,v 1.2 2002/06/17 04:05:39 rphillips Exp $
S=${WORKDIR}/${P}
DESCRIPTION="PostgreSQL is a sophisticated Object-Relational DBMS"
@@ -32,10 +32,12 @@ SLOT="0"
pkg_setup() {
local foo
- foo=`java-config --java-version 2>&1 | grep "1.4.0"`
- if [ ! -z "$foo" ] ; then
- einfo "Cannot build with Sun JDK 1.4.0, use an 1.3.x JDK instead."
- exit 1
+ if [ "`use java`" ] ; then
+ foo=`java-config --java-version 2>&1 | grep "1.4.0"`
+ if [ ! -z "$foo" ] ; then
+ einfo "Cannot build with Sun JDK 1.4.0, use an 1.3.x JDK instead."
+ exit 1
+ fi
fi
}
src_unpack() {