summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2011-12-09 15:25:21 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2011-12-09 15:25:21 +0000
commite7e0c9310caebef8a1aa8c4d58aeeefe1ad2a333 (patch)
tree6db48702ad8b9f01a87867716ac63d334d949fa7 /dev-db/pgadmin3
parentadd patch from upstream to fix build on *BSD (diff)
downloadgentoo-2-e7e0c9310caebef8a1aa8c4d58aeeefe1ad2a333.tar.gz
gentoo-2-e7e0c9310caebef8a1aa8c4d58aeeefe1ad2a333.tar.bz2
gentoo-2-e7e0c9310caebef8a1aa8c4d58aeeefe1ad2a333.zip
Version Bump
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'dev-db/pgadmin3')
-rw-r--r--dev-db/pgadmin3/ChangeLog8
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.14.1.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/dev-db/pgadmin3/ChangeLog b/dev-db/pgadmin3/ChangeLog
index 38a81b531f44..dab22ca19cd5 100644
--- a/dev-db/pgadmin3/ChangeLog
+++ b/dev-db/pgadmin3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/pgadmin3
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.67 2011/11/12 15:41:00 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.68 2011/12/09 15:25:21 titanofold Exp $
+
+*pgadmin3-1.14.1 (09 Dec 2011)
+
+ 09 Dec 2011; Aaron W. Swenson <titanofold@gentoo.org>
+ +pgadmin3-1.14.1.ebuild:
+ Version Bump
12 Nov 2011; Aaron W. Swenson <titanofold@gentoo.org>
-pgadmin3-1.14.0_beta1.ebuild:
diff --git a/dev-db/pgadmin3/pgadmin3-1.14.1.ebuild b/dev-db/pgadmin3/pgadmin3-1.14.1.ebuild
new file mode 100644
index 000000000000..beab70e1639a
--- /dev/null
+++ b/dev-db/pgadmin3/pgadmin3-1.14.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/pgadmin3-1.14.1.ebuild,v 1.1 2011/12/09 15:25:21 titanofold Exp $
+
+EAPI="4"
+
+WX_GTK_VER="2.8"
+
+inherit autotools multilib versionator wxwidgets
+
+DESCRIPTION="wxWidgets GUI for PostgreSQL."
+HOMEPAGE="http://www.pgadmin.org/"
+SRC_URI="mirror://postgresql/${PN}/release/v${PV}/src/${P}.tar.gz"
+
+LICENSE="Artistic"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="x11-libs/wxGTK:2.8[X]
+ >=dev-db/postgresql-base-8.4.0
+ >=dev-libs/libxml2-2.6.18
+ >=dev-libs/libxslt-1.1"
+RDEPEND="${DEPEND}"
+
+pkg_pretend() {
+ local pgslot=$(postgresql-config show)
+
+ if [[ ${pgslot//.} < 84 ]] ; then
+ eerror "PostgreSQL slot must be set to 8.4 or higher."
+ eerror " postgresql-config set 8.4"
+ die "PostgreSQL slot is not set to 8.4 or higher."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/ssl-detect-r1.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-wx-version=2.8 \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newicon "${S}/pgadmin/include/images/pgAdmin3.png" ${PN}.png
+
+ # icon location for the desktop file provided in pkg folder
+ insinto /usr/share/pgadmin3
+ doins "${S}/pgadmin/include/images/pgAdmin3.png"
+
+ domenu "${S}/pkg/pgadmin3.desktop"
+
+ # Fixing world-writable files
+ fperms -R go-w /usr/share
+}