summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-07-29 17:44:24 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-07-29 17:44:24 +0000
commit203776058cd94f27769e598b29e843558177da6d (patch)
treed436ef57cc72c9ee84c022f2d5aa3627d611429d /dev-db/opendbx
parentRemove support for Ruby 1.9 (patch left undefined symbols), simplify ebuild. (diff)
downloadgentoo-2-203776058cd94f27769e598b29e843558177da6d.tar.gz
gentoo-2-203776058cd94f27769e598b29e843558177da6d.tar.bz2
gentoo-2-203776058cd94f27769e598b29e843558177da6d.zip
Use -j1 for build/install (bug #322221).
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/opendbx')
-rw-r--r--dev-db/opendbx/ChangeLog6
-rw-r--r--dev-db/opendbx/opendbx-1.4.5.ebuild9
2 files changed, 12 insertions, 3 deletions
diff --git a/dev-db/opendbx/ChangeLog b/dev-db/opendbx/ChangeLog
index 83c5f67a9203..cc5124dfd9e3 100644
--- a/dev-db/opendbx/ChangeLog
+++ b/dev-db/opendbx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/opendbx
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/ChangeLog,v 1.31 2010/07/18 16:34:08 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/ChangeLog,v 1.32 2010/07/29 17:44:24 flameeyes Exp $
+
+ 29 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ opendbx-1.4.5.ebuild:
+ Use -j1 for build/install (bug #322221).
18 Jul 2010; Markos Chandras <hwoarang@gentoo.org> opendbx-1.4.5.ebuild:
Stable on amd64 wrt bug #317981
diff --git a/dev-db/opendbx/opendbx-1.4.5.ebuild b/dev-db/opendbx/opendbx-1.4.5.ebuild
index 8a9ad60e4bb8..8440e2295e78 100644
--- a/dev-db/opendbx/opendbx-1.4.5.ebuild
+++ b/dev-db/opendbx/opendbx-1.4.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/opendbx-1.4.5.ebuild,v 1.4 2010/07/18 16:34:08 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/opendbx-1.4.5.ebuild,v 1.5 2010/07/29 17:44:24 flameeyes Exp $
EAPI="2"
@@ -53,7 +53,12 @@ src_configure() {
econf --with-backends="${backends}" || die "econf failed"
}
+src_compile() {
+ # bug #322221
+ emake -j1 || die "emake failed"
+}
+
src_install() {
- make install DESTDIR="${D}" || die "make install failed"
+ emake -j1 install DESTDIR="${D}" || die "make install failed"
dodoc AUTHORS ChangeLog README
}