summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-05-05 01:52:47 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-05-05 01:52:47 +0000
commitde5c63c0e545f7b093f04f018cf553700b26e920 (patch)
tree0d42cd9f3ee495df2a013e8cb70b1efdc29e5925 /dev-db/mysqltool
parentfixed minor glitch (diff)
downloadgentoo-2-de5c63c0e545f7b093f04f018cf553700b26e920.tar.gz
gentoo-2-de5c63c0e545f7b093f04f018cf553700b26e920.tar.bz2
gentoo-2-de5c63c0e545f7b093f04f018cf553700b26e920.zip
fixed minor glitch
Diffstat (limited to 'dev-db/mysqltool')
-rw-r--r--dev-db/mysqltool/ChangeLog4
-rw-r--r--dev-db/mysqltool/Manifest4
-rw-r--r--dev-db/mysqltool/files/90_mysqltool.conf.m42
-rw-r--r--dev-db/mysqltool/mysqltool-0.95-r2.ebuild33
4 files changed, 26 insertions, 17 deletions
diff --git a/dev-db/mysqltool/ChangeLog b/dev-db/mysqltool/ChangeLog
index 2a6f8daac6a7..932f0c4fa7d5 100644
--- a/dev-db/mysqltool/ChangeLog
+++ b/dev-db/mysqltool/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for dev-db/mysqltool
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysqltool/ChangeLog,v 1.10 2003/05/04 11:38:50 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysqltool/ChangeLog,v 1.11 2003/05/05 01:52:45 robbat2 Exp $
*mysqltool-0.95-r2 (04 May 2003)
@@ -8,7 +8,7 @@
files/90_mysqltool.conf.m4:
Rewrote the install/postinst sections to support apache2+mod_perl better, as
well as fixing bug #20119 at the same time. Also made it easier for the user
- ;-).
+ ;-). Fixed some more bugs in my ebuilds now.
*mysqltool-0.95-r1 (03 May 2002)
diff --git a/dev-db/mysqltool/Manifest b/dev-db/mysqltool/Manifest
index d38cc3a410c2..4714c21fb765 100644
--- a/dev-db/mysqltool/Manifest
+++ b/dev-db/mysqltool/Manifest
@@ -1,6 +1,6 @@
-MD5 e48cb784e0d7df4bbe1f1ddac4a94b2e mysqltool-0.95-r2.ebuild 3237
+MD5 75971f08114d6985906b60bae8509369 mysqltool-0.95-r2.ebuild 3237
MD5 3c384ea592e925a5ef7264c5699fbd73 mysqltool-0.95-r1.ebuild 2286
-MD5 13afdeed30480a8be5bec830150885d3 ChangeLog 1477
+MD5 0d3cff422dda506e444409a622a1ebca ChangeLog 1477
MD5 4ad40419a26d5f580b3f2958e5188dc2 files/90_mysqltool.conf.m4 339
MD5 f19ea0fa37a19ab341ca96aacd0418c9 files/digest-mysqltool-0.95-r1 65
MD5 f19ea0fa37a19ab341ca96aacd0418c9 files/digest-mysqltool-0.95-r2 65
diff --git a/dev-db/mysqltool/files/90_mysqltool.conf.m4 b/dev-db/mysqltool/files/90_mysqltool.conf.m4
index 6c84b34ec809..46b34a863f83 100644
--- a/dev-db/mysqltool/files/90_mysqltool.conf.m4
+++ b/dev-db/mysqltool/files/90_mysqltool.conf.m4
@@ -1,6 +1,6 @@
<IfDefine MYSQLTOOL>
<IfDefine PERL>
- PerlRequire __APACHE_SERVER_ROOT__/__APACHE_MODULES_CONF_DIR__/mysqltool.pl
+ PerlRequire __APACHE_MODULES_CONF_DIR__/mysqltool.pl
</IfDefine>
<Directory __APACHE_DOCUMENT_ROOT__/htdocs/mysqltool>
Options ExecCGI
diff --git a/dev-db/mysqltool/mysqltool-0.95-r2.ebuild b/dev-db/mysqltool/mysqltool-0.95-r2.ebuild
index d6589376249e..db03e41ec023 100644
--- a/dev-db/mysqltool/mysqltool-0.95-r2.ebuild
+++ b/dev-db/mysqltool/mysqltool-0.95-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysqltool/mysqltool-0.95-r2.ebuild,v 1.1 2003/05/04 11:38:50 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysqltool/mysqltool-0.95-r2.ebuild,v 1.2 2003/05/05 01:52:45 robbat2 Exp $
inherit perl-module
@@ -37,16 +37,23 @@ src_install() {
make install || die
dodoc COPYING Changes MANIFEST README Upgrade
+
+
local __apache_server_root__
- __apache_server_root__=`grep "^ServerRoot" /etc/apache2/conf/*.conf -h | cut -d' ' -f2`
+ if [ "`use apache2`" ]; then
+ __apache_server_root__="/etc/apache2"
+ else
+ __apache_server_root__="/etc/apache"
+ fi;
+ __apache_conf_dir__=${__apache_server_root__}/conf
local __apache_document_root__
- __apache_document_root__=`grep "^DocumentRoot" /etc/apache2/conf/*.conf -h | cut -d' ' -f2`
+ __apache_document_root__=`grep "^DocumentRoot" ${__apache_conf_dir__}/*.conf -h | cut -d' ' -f2`
local __apache_modules_conf_dir__
if [ "`use apache2`" ]; then
- __apache_modules_conf_dir__="conf/modules.d"
+ __apache_modules_conf_dir__="${__apache_conf_dir__}/modules.d"
else
- __apache_modules_conf_dir__="conf/addon-modules"
+ __apache_modules_conf_dir__="${__apache_conf_dir__}/addon-modules"
fi;
# the cgi and images..
@@ -57,17 +64,17 @@ src_install() {
# the config file..
local apacheconfbase
apacheconfbase=${FILESDIR}/90_mysqltool.conf.m4
- insinto ${__apache_server_root__}/${__apache_modules_conf_dir__}
+ insinto ${__apache_modules_conf_dir__}
cp ${S}/htdocs/mysqltool.conf ${S}/htdocs/mysqltool.pl
doins htdocs/mysqltool.pl
- fowners apache.apache ${__apache_server_root__}/${__apache_modules_conf_dir__}/mysqltool.pl
- fperms 0600 ${__apache_server_root__}/${__apache_modules_conf_dir__}/mysqltool.pl
- m4 -D__APACHE_SERVER_ROOT__=${__apache_server_root__} -D__APACHE_DOCUMENT_ROOT__=${__apache_document_root__} -D__APACHE_MODULES_CONF_DIR__=${__apache_modules_conf_dir__} ${apacheconfbase} >${D}/${__apache_server_root__}/${__apache_modules_conf_dir__}/`basename ${apacheconfbase} .m4`
+ fowners apache.apache ${__apache_modules_conf_dir__}/mysqltool.pl
+ fperms 0600 ${__apache_modules_conf_dir__}/mysqltool.pl
+ m4 -D__APACHE_SERVER_ROOT__=${__apache_server_root__} -D__APACHE_DOCUMENT_ROOT__=${__apache_document_root__} -D__APACHE_MODULES_CONF_DIR__=${__apache_modules_conf_dir__} ${apacheconfbase} >${D}/${__apache_modules_conf_dir__}/`basename ${apacheconfbase} .m4`
# now fix its location in the main cgi..
cp ${D}/${__apache_document_root__}/mysqltool/index.cgi \
${D}/${__apache_document_root__}/mysqltool/index.cgi.orig
- sed -e "s:^\(require\).*:\1 '${__apache_server_root__}/${__apache_modules_conf_dir__}/mysqltool.pl';:" \
+ sed -e "s:^\(require\).*:\1 '${__apache_modules_conf_dir__}/mysqltool.pl';:" \
${D}/${__apache_document_root__}/mysqltool/index.cgi.orig > \
${D}/${__apache_document_root__}/mysqltool/index.cgi
rm ${D}/${__apache_document_root__}/mysqltool/index.cgi.orig
@@ -75,9 +82,11 @@ src_install() {
pkg_postinst() {
einfo "To have Apache support MySQLTool, please do the following:"
+ local f
if [ "`use apache2`" ] ; then
- einfo "Edit /etc/conf.d/apache2 and add \"-D MYSQLTOOL\""
+ f='2'
else
- einfo "Edit /etc/conf.d/apache and add \"-D MYSQLTOOL\""
+ f=''
fi
+ einfo "Edit /etc/conf.d/apache${f} and add \"-D MYSQLTOOL\" to APACHE${f}_OPTS"
}