summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMalcolm Lashley <malc@gentoo.org>2006-08-15 21:34:13 +0000
committerMalcolm Lashley <malc@gentoo.org>2006-08-15 21:34:13 +0000
commit82590c17842ece2fa0e092606a2c4e63f5aac59e (patch)
tree0e62910d5879a18b148a18e93597f67d461f517f /dev-db/mysql-super-smack
parentmark ~ppc (Bug #143609) (diff)
downloadgentoo-2-82590c17842ece2fa0e092606a2c4e63f5aac59e.tar.gz
gentoo-2-82590c17842ece2fa0e092606a2c4e63f5aac59e.tar.bz2
gentoo-2-82590c17842ece2fa0e092606a2c4e63f5aac59e.zip
Little patch of pointer->int casting which makes gcc4.x barf on 64bit systems and voila ~amd64 - bug #141984
(Portage version: 2.1.1_pre5-r1)
Diffstat (limited to 'dev-db/mysql-super-smack')
-rw-r--r--dev-db/mysql-super-smack/ChangeLog7
-rw-r--r--dev-db/mysql-super-smack/files/digest-mysql-super-smack-1.32
-rw-r--r--dev-db/mysql-super-smack/files/mysql-super-smack-1.3.amd64.patch20
-rw-r--r--dev-db/mysql-super-smack/mysql-super-smack-1.3.ebuild5
4 files changed, 31 insertions, 3 deletions
diff --git a/dev-db/mysql-super-smack/ChangeLog b/dev-db/mysql-super-smack/ChangeLog
index 5c49debba32c..8f0ee1b8a63d 100644
--- a/dev-db/mysql-super-smack/ChangeLog
+++ b/dev-db/mysql-super-smack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/mysql-super-smack
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-super-smack/ChangeLog,v 1.6 2006/01/15 15:11:59 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-super-smack/ChangeLog,v 1.7 2006/08/15 21:34:13 malc Exp $
+
+ 15 Aug 2006; <malc@gentoo.org> +files/mysql-super-smack-1.3.amd64.patch,
+ mysql-super-smack-1.3.ebuild:
+ Little patch of pointer->int casting which makes gcc4.x barf on 64bit
+ systems and voila ~amd64 - bug #141984
15 Jan 2006; Tobias Scherbaum <dertobi123@gentoo.org>
mysql-super-smack-1.3.ebuild:
diff --git a/dev-db/mysql-super-smack/files/digest-mysql-super-smack-1.3 b/dev-db/mysql-super-smack/files/digest-mysql-super-smack-1.3
index 34d56709de45..b57c328c2e28 100644
--- a/dev-db/mysql-super-smack/files/digest-mysql-super-smack-1.3
+++ b/dev-db/mysql-super-smack/files/digest-mysql-super-smack-1.3
@@ -1 +1,3 @@
MD5 1884be74822d1fa3bcd7f997935a13db super-smack-1.3.tar.gz 155375
+RMD160 bea82e7b26070f0e6ba0ea2ffb187cc374f6204e super-smack-1.3.tar.gz 155375
+SHA256 969d40e772faa8580f8e8f2dfa2a381fbadbd79fc0c94304347d594dba2a9bd9 super-smack-1.3.tar.gz 155375
diff --git a/dev-db/mysql-super-smack/files/mysql-super-smack-1.3.amd64.patch b/dev-db/mysql-super-smack/files/mysql-super-smack-1.3.amd64.patch
new file mode 100644
index 000000000000..c2c5db0c56f0
--- /dev/null
+++ b/dev-db/mysql-super-smack/files/mysql-super-smack-1.3.amd64.patch
@@ -0,0 +1,20 @@
+--- supesmack-1.3/src/query.cc.orig 2005-04-30 14:51:29.000000000 +0100
++++ supesmack-1.3/src/query.cc 2006-08-15 22:06:06.000000000 +0100
+@@ -197,7 +197,7 @@
+ {
+ string s((*i).first);
+ int str_len = (*i).first.length();
+- if((unsigned)p + str_len + 3 *sizeof(int) < (unsigned)p_end )
++ if((unsigned long)p + str_len + 3 *sizeof(int) < (unsigned long)p_end )
+ {
+ *p++ = (char) str_len;
+ const char* q_type_name = s.c_str();
+@@ -216,7 +216,7 @@
+ die(0, "report buffer overflow -- too many query types");
+ }
+
+- len = (unsigned)p - (unsigned)buf;
++ len = (unsigned long)p - (unsigned long)buf;
+ *(buf) = num_recs;
+
+ if(write(fd, buf, len) != len)
diff --git a/dev-db/mysql-super-smack/mysql-super-smack-1.3.ebuild b/dev-db/mysql-super-smack/mysql-super-smack-1.3.ebuild
index 4d7b3ad67889..9af197490f44 100644
--- a/dev-db/mysql-super-smack/mysql-super-smack-1.3.ebuild
+++ b/dev-db/mysql-super-smack/mysql-super-smack-1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-super-smack/mysql-super-smack-1.3.ebuild,v 1.2 2006/01/15 15:11:59 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-super-smack/mysql-super-smack-1.3.ebuild,v 1.3 2006/08/15 21:34:13 malc Exp $
inherit eutils
@@ -12,7 +12,7 @@ SRC_URI="http://vegan.net/tony/supersmack/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~ppc ~x86"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE="mysql postgres"
DEPEND="mysql? ( dev-db/mysql )
@@ -28,6 +28,7 @@ src_unpack() {
unpack ${A}
EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-1.2.destdir.patch
cd ${S}
+ epatch ${FILESDIR}/${PN}-1.3.amd64.patch
automake
}