summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-08-31 09:49:25 +0000
committerPeter Volkov <pva@gentoo.org>2007-08-31 09:49:25 +0000
commit2f21971cd5cec4deb5e92309594a404e9cb064fc (patch)
tree4d3beb11e80575c121d0af72bf63586812c737c9 /dev-db/gigabase
parentPort from project overlay (diff)
downloadgentoo-2-2f21971cd5cec4deb5e92309594a404e9cb064fc.tar.gz
gentoo-2-2f21971cd5cec4deb5e92309594a404e9cb064fc.tar.bz2
gentoo-2-2f21971cd5cec4deb5e92309594a404e9cb064fc.zip
Version bump.
(Portage version: 2.1.3.7)
Diffstat (limited to 'dev-db/gigabase')
-rw-r--r--dev-db/gigabase/ChangeLog7
-rw-r--r--dev-db/gigabase/files/digest-gigabase-3.593
-rw-r--r--dev-db/gigabase/gigabase-3.59.ebuild44
3 files changed, 53 insertions, 1 deletions
diff --git a/dev-db/gigabase/ChangeLog b/dev-db/gigabase/ChangeLog
index ce82a2f1a1de..fa108d8a6062 100644
--- a/dev-db/gigabase/ChangeLog
+++ b/dev-db/gigabase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/gigabase
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/ChangeLog,v 1.25 2007/05/05 15:30:51 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/ChangeLog,v 1.26 2007/08/31 09:49:25 pva Exp $
+
+*gigabase-3.59 (31 Aug 2007)
+
+ 31 Aug 2007; <pva@gentoo.org> +gigabase-3.59.ebuild:
+ Version bump.
*gigabase-3.58 (05 May 2007)
diff --git a/dev-db/gigabase/files/digest-gigabase-3.59 b/dev-db/gigabase/files/digest-gigabase-3.59
new file mode 100644
index 000000000000..2d6b4eedbc03
--- /dev/null
+++ b/dev-db/gigabase/files/digest-gigabase-3.59
@@ -0,0 +1,3 @@
+MD5 69bd7376c3d647dee9ac746d20c6d2c8 gigabase-3.59.tar.gz 1431791
+RMD160 ab5afa613f22b1f7e53a51115f1af06462f32211 gigabase-3.59.tar.gz 1431791
+SHA256 73f9ab8a2e7f5db9ba75b7db08efd911a68bdfed1babc65af8253828f0240688 gigabase-3.59.tar.gz 1431791
diff --git a/dev-db/gigabase/gigabase-3.59.ebuild b/dev-db/gigabase/gigabase-3.59.ebuild
new file mode 100644
index 000000000000..03d887e68a0b
--- /dev/null
+++ b/dev-db/gigabase/gigabase-3.59.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/gigabase-3.59.ebuild,v 1.1 2007/08/31 09:49:25 pva Exp $
+
+inherit eutils libtool multilib
+
+DESCRIPTION="OO-DBMS with interfaces for C/C++/Java/PHP/Perl"
+HOMEPAGE="http://www.garret.ru/~knizhnik/gigabase.html"
+SRC_URI="mirror://sourceforge/gigabase/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~s390 ~x86"
+IUSE="doc"
+DEPEND=""
+
+S="${WORKDIR}"/gigabase
+
+src_compile() {
+ mf="${S}/Makefile"
+
+ econf || die "econf failed"
+
+ sed -r -i -e 's/subsql([^\.]|$)/subsql-gdb\1/' ${mf}
+
+ emake || die "compilation failed"
+}
+
+src_install() {
+ einstall || die "make install failed"
+
+ dodoc CHANGES
+ use doc && dohtml GigaBASE.htm
+ use doc && dohtml -r docs/html/*
+}
+
+pkg_postinst() {
+ elog "The subsql binary has been renamed to subsql-gdb,"
+ elog "to avoid a name clash with the FastDB version of subsql"
+ echo
+ ewarn "Content of indices created by old (<=3.42) version of GigaBASE with"
+ ewarn "USE_LOCALE_SETTINGS enabled and using non-standard locale will be"
+ ewarn "different with format used by version 3.43 and higher. So you will"
+ ewarn "have to recreate indices in this case."
+}