summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2010-02-23 09:53:07 +0000
committerChristian Ruppert <idl0r@gentoo.org>2010-02-23 09:53:07 +0000
commitbbe05c20356cd9d5fd6db4c14693ba4682e52549 (patch)
tree71af2e501fbdd9e6b778ca77e0f13e243bb7ef8e /dev-cpp
parentAdding masked samba4 alpha. Thanks to ewoud and the other people in #195703 (diff)
downloadgentoo-2-bbe05c20356cd9d5fd6db4c14693ba4682e52549.tar.gz
gentoo-2-bbe05c20356cd9d5fd6db4c14693ba4682e52549.tar.bz2
gentoo-2-bbe05c20356cd9d5fd6db4c14693ba4682e52549.zip
Add -j1 due to parallel compilation issues. Add doc useflag for html docs.
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/ctemplate/ChangeLog7
-rw-r--r--dev-cpp/ctemplate/ctemplate-0.95.ebuild10
2 files changed, 10 insertions, 7 deletions
diff --git a/dev-cpp/ctemplate/ChangeLog b/dev-cpp/ctemplate/ChangeLog
index f7482d93bd25..34c3e5488032 100644
--- a/dev-cpp/ctemplate/ChangeLog
+++ b/dev-cpp/ctemplate/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-cpp/ctemplate
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ChangeLog,v 1.4 2009/07/22 14:16:47 dev-zero Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ChangeLog,v 1.5 2010/02/23 09:53:07 idl0r Exp $
+
+ 23 Feb 2010; Christian Ruppert <idl0r@gentoo.org> ctemplate-0.95.ebuild:
+ Add -j1 due to parallel compilation issues. Add doc useflag for html docs.
*ctemplate-0.95 (22 Jul 2009)
diff --git a/dev-cpp/ctemplate/ctemplate-0.95.ebuild b/dev-cpp/ctemplate/ctemplate-0.95.ebuild
index a65533940da0..4d4a7a65f79b 100644
--- a/dev-cpp/ctemplate/ctemplate-0.95.ebuild
+++ b/dev-cpp/ctemplate/ctemplate-0.95.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ctemplate-0.95.ebuild,v 1.1 2009/07/22 14:16:47 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ctemplate-0.95.ebuild,v 1.2 2010/02/23 09:53:07 idl0r Exp $
EAPI="2"
@@ -12,7 +12,7 @@ SRC_URI="http://google-ctemplate.googlecode.com/files/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="emacs vim-syntax"
+IUSE="doc emacs vim-syntax"
DEPEND=""
RDEPEND="vim-syntax? ( >=app-editors/vim-core-7 )
@@ -21,7 +21,7 @@ RDEPEND="vim-syntax? ( >=app-editors/vim-core-7 )
SITEFILE="70ctemplate-gentoo.el"
src_compile() {
- emake || die "emake failed"
+ emake -j1 || die "emake failed"
if use emacs ; then
elisp-compile contrib/tpl-mode.el || die "elisp-compile failed"
@@ -35,7 +35,7 @@ src_install() {
rm -rf "${D}/usr/share/doc"
dodoc AUTHORS ChangeLog NEWS README
- dohtml doc/*
+ use doc && dohtml doc/*
if use vim-syntax ; then
cd "${S}/contrib"