summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2008-05-26 02:37:35 +0000
committerMark Loeser <halcy0n@gentoo.org>2008-05-26 02:37:35 +0000
commitb2eee1a797341d2a02efa4e60b76bb446d0ef13b (patch)
tree762b161a783ea13978675885217815cd43aa0b72 /dev-cpp
parentFix RDEPEND on cmake; bug #220453 (diff)
downloadgentoo-2-b2eee1a797341d2a02efa4e60b76bb446d0ef13b.tar.gz
gentoo-2-b2eee1a797341d2a02efa4e60b76bb446d0ef13b.tar.bz2
gentoo-2-b2eee1a797341d2a02efa4e60b76bb446d0ef13b.zip
Fix RDEPEND on doxygen and cmake; bug #220453
(Portage version: 2.1.5.2)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/sptk/ChangeLog7
-rw-r--r--dev-cpp/sptk/sptk-3.0.6.ebuild8
-rw-r--r--dev-cpp/sptk/sptk-3.2.6.ebuild8
-rw-r--r--dev-cpp/sptk/sptk-3.5.6.ebuild10
-rw-r--r--dev-cpp/sptk/sptk-3.5.7.05.ebuild10
-rw-r--r--dev-cpp/sptk/sptk-3.5.7.10.ebuild10
6 files changed, 34 insertions, 19 deletions
diff --git a/dev-cpp/sptk/ChangeLog b/dev-cpp/sptk/ChangeLog
index 1bd71cee59a2..b28a078623e0 100644
--- a/dev-cpp/sptk/ChangeLog
+++ b/dev-cpp/sptk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/sptk
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.32 2008/05/19 18:08:30 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.33 2008/05/26 02:37:35 halcy0n Exp $
+
+ 26 May 2008; Mark Loeser <halcy0n@gentoo.org> sptk-3.0.6.ebuild,
+ sptk-3.2.6.ebuild, sptk-3.5.6.ebuild, sptk-3.5.7.05.ebuild,
+ sptk-3.5.7.10.ebuild:
+ Fix RDEPEND on doxygen and cmake; bug #220453
19 May 2008; Tiziano Müller <dev-zero@gentoo.org> sptk-3.5.6.ebuild,
sptk-3.5.7.05.ebuild, sptk-3.5.7.10.ebuild:
diff --git a/dev-cpp/sptk/sptk-3.0.6.ebuild b/dev-cpp/sptk/sptk-3.0.6.ebuild
index 5de939b316ef..80d9d5f7828b 100644
--- a/dev-cpp/sptk/sptk-3.0.6.ebuild
+++ b/dev-cpp/sptk/sptk-3.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.0.6.ebuild,v 1.3 2008/02/26 13:09:58 iluxa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.0.6.ebuild,v 1.4 2008/05/26 02:37:35 halcy0n Exp $
inherit autotools
@@ -14,8 +14,10 @@ SLOT="3"
LICENSE="|| ( FLTK GPL-2 )"
KEYWORDS="~amd64 ~mips ~ppc ~sparc x86"
-DEPEND="fltk? ( x11-libs/fltk )
- odbc? ( >=dev-db/unixODBC-2.2.6 )
+RDEPEND="fltk? ( x11-libs/fltk )
+ odbc? ( >=dev-db/unixODBC-2.2.6 )"
+
+DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
src_unpack() {
diff --git a/dev-cpp/sptk/sptk-3.2.6.ebuild b/dev-cpp/sptk/sptk-3.2.6.ebuild
index de4f467de544..e8d5fa1aa17d 100644
--- a/dev-cpp/sptk/sptk-3.2.6.ebuild
+++ b/dev-cpp/sptk/sptk-3.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 2006-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.2.6.ebuild,v 1.6 2008/03/17 05:13:39 ricmm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.2.6.ebuild,v 1.7 2008/05/26 02:37:35 halcy0n Exp $
inherit autotools
@@ -14,9 +14,11 @@ SLOT="3"
LICENSE="|| ( FLTK GPL-2 )"
KEYWORDS="alpha ~amd64 ~mips ~ppc ~sparc x86"
-DEPEND="fltk? ( x11-libs/fltk )
+RDEPEND="fltk? ( x11-libs/fltk )
odbc? ( >=dev-db/unixODBC-2.2.6 )
- sqlite3? ( >=dev-db/sqlite-3 )
+ sqlite3? ( >=dev-db/sqlite-3 )"
+
+DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
src_unpack() {
diff --git a/dev-cpp/sptk/sptk-3.5.6.ebuild b/dev-cpp/sptk/sptk-3.5.6.ebuild
index 7a052dec5974..05fe7cd6444f 100644
--- a/dev-cpp/sptk/sptk-3.5.6.ebuild
+++ b/dev-cpp/sptk/sptk-3.5.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 2006-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.6.ebuild,v 1.4 2008/05/19 18:08:30 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.6.ebuild,v 1.5 2008/05/26 02:37:35 halcy0n Exp $
inherit eutils flag-o-matic autotools
@@ -14,12 +14,14 @@ SLOT="3"
LICENSE="|| ( BSD )"
KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
-DEPEND="dev-util/cmake
- fltk? ( >=x11-libs/fltk-1.1.6 )
+RDEPEND="fltk? ( >=x11-libs/fltk-1.1.6 )
odbc? ( >=dev-db/unixODBC-2.2.6 )
sqlite3? ( >=dev-db/sqlite-3 )
postgres? ( >=virtual/postgresql-base-8.0 )
- aspell? ( >=app-text/aspell-0.50 )
+ aspell? ( >=app-text/aspell-0.50 )"
+
+DEPEND="${RDEPEND}
+ dev-util/cmake
doc? ( app-doc/doxygen )"
check_use() {
diff --git a/dev-cpp/sptk/sptk-3.5.7.05.ebuild b/dev-cpp/sptk/sptk-3.5.7.05.ebuild
index 8dcc079e2f65..8449e3f1cebe 100644
--- a/dev-cpp/sptk/sptk-3.5.7.05.ebuild
+++ b/dev-cpp/sptk/sptk-3.5.7.05.ebuild
@@ -1,6 +1,6 @@
# Copyright 2006-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.7.05.ebuild,v 1.3 2008/05/19 18:08:30 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.7.05.ebuild,v 1.4 2008/05/26 02:37:35 halcy0n Exp $
inherit eutils flag-o-matic autotools
@@ -14,12 +14,14 @@ SLOT="3"
LICENSE="|| ( BSD )"
KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
-DEPEND="dev-util/cmake
- fltk? ( >=x11-libs/fltk-1.1.6 )
+RDEPEND="fltk? ( >=x11-libs/fltk-1.1.6 )
odbc? ( >=dev-db/unixODBC-2.2.6 )
sqlite3? ( >=dev-db/sqlite-3 )
postgres? ( >=virtual/postgresql-base-8.0 )
- aspell? ( >=app-text/aspell-0.50 )
+ aspell? ( >=app-text/aspell-0.50 )"
+
+DEPEND="${RDEPEND}
+ dev-util/cmake
doc? ( app-doc/doxygen )"
check_use() {
diff --git a/dev-cpp/sptk/sptk-3.5.7.10.ebuild b/dev-cpp/sptk/sptk-3.5.7.10.ebuild
index c7251b23c770..96bb899f2b2d 100644
--- a/dev-cpp/sptk/sptk-3.5.7.10.ebuild
+++ b/dev-cpp/sptk/sptk-3.5.7.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 2006-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.7.10.ebuild,v 1.2 2008/05/19 18:08:30 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.7.10.ebuild,v 1.3 2008/05/26 02:37:35 halcy0n Exp $
inherit eutils flag-o-matic autotools
@@ -14,12 +14,14 @@ SLOT="3"
LICENSE="|| ( BSD )"
KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
-DEPEND="dev-util/cmake
- fltk? ( >=x11-libs/fltk-1.1.6 )
+RDEPEND="fltk? ( >=x11-libs/fltk-1.1.6 )
odbc? ( >=dev-db/unixODBC-2.2.6 )
sqlite3? ( >=dev-db/sqlite-3 )
postgres? ( >=virtual/postgresql-base-8.0 )
- aspell? ( >=app-text/aspell-0.50 )
+ aspell? ( >=app-text/aspell-0.50 )"
+
+DEPEND="${RDEPEND}
+ dev-util/cmake
doc? ( app-doc/doxygen )"
check_use() {