summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-09-03 04:21:59 +0000
committerTim Harder <radhermit@gentoo.org>2011-09-03 04:21:59 +0000
commit898853f1cee565e7ed80cd5b680e109b881813f0 (patch)
tree56a291ecab1b4fe9bd04f22a1081e45d686889c0 /dev-cpp
parentVersion bump. TODO: review init scripts and logrotate compatibility. (diff)
downloadgentoo-2-898853f1cee565e7ed80cd5b680e109b881813f0.tar.gz
gentoo-2-898853f1cee565e7ed80cd5b680e109b881813f0.tar.bz2
gentoo-2-898853f1cee565e7ed80cd5b680e109b881813f0.zip
Version bump.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/ctemplate/ChangeLog7
-rw-r--r--dev-cpp/ctemplate/ctemplate-1.0.ebuild77
2 files changed, 83 insertions, 1 deletions
diff --git a/dev-cpp/ctemplate/ChangeLog b/dev-cpp/ctemplate/ChangeLog
index 1e39cc238010..78cd8d32d7e1 100644
--- a/dev-cpp/ctemplate/ChangeLog
+++ b/dev-cpp/ctemplate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/ctemplate
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ChangeLog,v 1.12 2011/04/29 09:55:13 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ChangeLog,v 1.13 2011/09/03 04:21:59 radhermit Exp $
+
+*ctemplate-1.0 (03 Sep 2011)
+
+ 03 Sep 2011; Tim Harder <radhermit@gentoo.org> +ctemplate-1.0.ebuild:
+ Version bump.
29 Apr 2011; Tim Harder <radhermit@gentoo.org> -ctemplate-0.98.ebuild:
Remove old.
diff --git a/dev-cpp/ctemplate/ctemplate-1.0.ebuild b/dev-cpp/ctemplate/ctemplate-1.0.ebuild
new file mode 100644
index 000000000000..c300e4151438
--- /dev/null
+++ b/dev-cpp/ctemplate/ctemplate-1.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ctemplate-1.0.ebuild,v 1.1 2011/09/03 04:21:59 radhermit Exp $
+
+EAPI="3"
+
+inherit elisp-common python
+
+DESCRIPTION="A simple but powerful template language for C++"
+HOMEPAGE="http://code.google.com/p/google-ctemplate/"
+SRC_URI="http://google-ctemplate.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc emacs vim-syntax static-libs test"
+
+DEPEND="test? ( =dev-lang/python-2* )"
+RDEPEND="vim-syntax? ( >=app-editors/vim-core-7 )
+ emacs? ( virtual/emacs )"
+
+SITEFILE="70ctemplate-gentoo.el"
+
+pkg_setup() {
+ if use test ; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ if use emacs ; then
+ elisp-compile contrib/tpl-mode.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # Installs just every piece
+ rm -rf "${ED}/usr/share/doc"
+
+ dodoc AUTHORS ChangeLog NEWS README
+ use doc && dohtml doc/*
+
+ if use vim-syntax ; then
+ cd "${S}/contrib"
+ sh highlighting.vim || die "unpacking vim scripts failed"
+ insinto /usr/share/vim/vimfiles
+ doins -r .vim/*
+ fi
+
+ if use emacs ; then
+ cd "${S}/contrib"
+ elisp-install ${PN} tpl-mode.el tpl-mode.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}