summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-11-26 09:48:53 +0000
committerTim Harder <radhermit@gentoo.org>2011-11-26 09:48:53 +0000
commit80f73324b863042f540a554b30f4bc2f0ab05570 (patch)
tree1ea9f00f824c540b135cf3444f1d1e11f9fffc81 /dev-cpp
parentStable on amd64 wrt bug #391479 (diff)
downloadgentoo-2-80f73324b863042f540a554b30f4bc2f0ab05570.tar.gz
gentoo-2-80f73324b863042f540a554b30f4bc2f0ab05570.tar.bz2
gentoo-2-80f73324b863042f540a554b30f4bc2f0ab05570.zip
Version bump.
(Portage version: 2.2.0_alpha77/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/asio/ChangeLog9
-rw-r--r--dev-cpp/asio/asio-1.4.8.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/dev-cpp/asio/ChangeLog b/dev-cpp/asio/ChangeLog
index d5e5b5c43b23..c710afe88277 100644
--- a/dev-cpp/asio/ChangeLog
+++ b/dev-cpp/asio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/asio
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/asio/ChangeLog,v 1.30 2010/09/13 07:11:10 josejx Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/asio/ChangeLog,v 1.31 2011/11/26 09:48:53 radhermit Exp $
+
+*asio-1.4.8 (26 Nov 2011)
+
+ 26 Nov 2011; Tim Harder <radhermit@gentoo.org> +asio-1.4.8.ebuild:
+ Version bump.
13 Sep 2010; Joseph Jezak <josejx@gentoo.org> asio-1.4.5.ebuild:
Marked ppc stable.
diff --git a/dev-cpp/asio/asio-1.4.8.ebuild b/dev-cpp/asio/asio-1.4.8.ebuild
new file mode 100644
index 000000000000..7a7e0f443fdc
--- /dev/null
+++ b/dev-cpp/asio/asio-1.4.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/asio/asio-1.4.8.ebuild,v 1.1 2011/11/26 09:48:53 radhermit Exp $
+
+EAPI=4
+
+DESCRIPTION="Asynchronous Network Library"
+HOMEPAGE="http://asio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc examples ssl test"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ >=dev-libs/boost-1.35.0"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ if ! use test; then
+ # Don't build nor install any examples or unittests
+ # since we don't have a script to run them
+ cat > src/Makefile.in <<-EOF
+all:
+
+install:
+ EOF
+ fi
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ dohtml -r doc/*
+ fi
+
+ if use examples; then
+ if use test; then
+ # Get rid of the object files
+ emake clean
+ fi
+ dodoc -r src/examples
+ fi
+}