summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-04-25 19:42:56 +0000
committerPacho Ramos <pacho@gentoo.org>2013-04-25 19:42:56 +0000
commit985917af820e50a911b02d1770af5b27f2067403 (patch)
treeab1c8905de9f44d49244ecba7d8bde5d27b87a72 /dev-cpp/libgdamm
parentDrop old versions (diff)
downloadgentoo-2-985917af820e50a911b02d1770af5b27f2067403.tar.gz
gentoo-2-985917af820e50a911b02d1770af5b27f2067403.tar.bz2
gentoo-2-985917af820e50a911b02d1770af5b27f2067403.zip
Version bump
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-cpp/libgdamm')
-rw-r--r--dev-cpp/libgdamm/ChangeLog10
-rw-r--r--dev-cpp/libgdamm/libgdamm-4.99.7.ebuild30
2 files changed, 37 insertions, 3 deletions
diff --git a/dev-cpp/libgdamm/ChangeLog b/dev-cpp/libgdamm/ChangeLog
index ed7c62c7f622..4ab891be0a21 100644
--- a/dev-cpp/libgdamm/ChangeLog
+++ b/dev-cpp/libgdamm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/libgdamm
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libgdamm/ChangeLog,v 1.32 2012/05/04 03:44:59 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libgdamm/ChangeLog,v 1.33 2013/04/25 19:42:56 pacho Exp $
+
+*libgdamm-4.99.7 (25 Apr 2013)
+
+ 25 Apr 2013; Pacho Ramos <pacho@gentoo.org> +libgdamm-4.99.7.ebuild:
+ Version bump
04 May 2012; Jeff Horelick <jdhore@gentoo.org> libgdamm-4.1.3.ebuild,
libgdamm-4.99.6.ebuild:
@@ -122,4 +127,3 @@
21 Jul 2005; Aaron Walker <ka0ttic@gentoo.org> +metadata.xml,
+libgdamm-1.3.6.ebuild:
Initial commit for bug 63819.
-
diff --git a/dev-cpp/libgdamm/libgdamm-4.99.7.ebuild b/dev-cpp/libgdamm/libgdamm-4.99.7.ebuild
new file mode 100644
index 000000000000..793902f20dd4
--- /dev/null
+++ b/dev-cpp/libgdamm/libgdamm-4.99.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libgdamm/libgdamm-4.99.7.ebuild,v 1.1 2013/04/25 19:42:56 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="C++ bindings for libgda"
+HOMEPAGE="http://www.gtkmm.org"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="berkdb doc"
+
+RDEPEND="
+ >=dev-cpp/glibmm-2.27.93:2
+ >=gnome-extra/libgda-5.0.2:5[berkdb=]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ # Automagic libgda-berkdb support
+ gnome2_src_configure $(use_enable doc documentation)
+}