summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-09-29 11:12:48 +0000
committerPacho Ramos <pacho@gentoo.org>2013-09-29 11:12:48 +0000
commitd021647b146245c73a5cb574835a9b898b2d85aa (patch)
treea49a95f047c07a15e45a113b2c4f521cfe24fe3e /dev-cpp/gnome-vfsmm
parentStable for amd64, wrt bug #475480 (diff)
downloadgentoo-2-d021647b146245c73a5cb574835a9b898b2d85aa.tar.gz
gentoo-2-d021647b146245c73a5cb574835a9b898b2d85aa.tar.bz2
gentoo-2-d021647b146245c73a5cb574835a9b898b2d85aa.zip
Fix docs installation (#454658)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-cpp/gnome-vfsmm')
-rw-r--r--dev-cpp/gnome-vfsmm/ChangeLog8
-rw-r--r--dev-cpp/gnome-vfsmm/gnome-vfsmm-2.26.0.ebuild31
2 files changed, 23 insertions, 16 deletions
diff --git a/dev-cpp/gnome-vfsmm/ChangeLog b/dev-cpp/gnome-vfsmm/ChangeLog
index 6389b9ee77f1..20d83b5ad0c1 100644
--- a/dev-cpp/gnome-vfsmm/ChangeLog
+++ b/dev-cpp/gnome-vfsmm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-cpp/gnome-vfsmm
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gnome-vfsmm/ChangeLog,v 1.73 2012/05/04 03:44:56 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gnome-vfsmm/ChangeLog,v 1.74 2013/09/29 11:12:48 pacho Exp $
+
+ 29 Sep 2013; Pacho Ramos <pacho@gentoo.org> gnome-vfsmm-2.26.0.ebuild:
+ Fix docs installation (#454658)
04 May 2012; Jeff Horelick <jdhore@gentoo.org> gnome-vfsmm-2.26.0.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
@@ -262,4 +265,3 @@
25 Jan 2004; Markus Nigbur <pyrania@gentoo.org> gnome-vfsmm-1.3.5.ebuild:
Initial import.
-
diff --git a/dev-cpp/gnome-vfsmm/gnome-vfsmm-2.26.0.ebuild b/dev-cpp/gnome-vfsmm/gnome-vfsmm-2.26.0.ebuild
index f90a22b6abdb..9635b3e79ac2 100644
--- a/dev-cpp/gnome-vfsmm/gnome-vfsmm-2.26.0.ebuild
+++ b/dev-cpp/gnome-vfsmm/gnome-vfsmm-2.26.0.ebuild
@@ -1,6 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gnome-vfsmm/gnome-vfsmm-2.26.0.ebuild,v 1.8 2012/05/04 03:44:56 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gnome-vfsmm/gnome-vfsmm-2.26.0.ebuild,v 1.9 2013/09/29 11:12:48 pacho Exp $
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME_TARBALL_SUFFIX="bz2"
inherit gnome2
@@ -13,17 +17,16 @@ KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
IUSE="doc examples"
# glibmm dep is because build fails with older versions...
-RDEPEND=">=gnome-base/gnome-vfs-2.8.1
- >=dev-cpp/glibmm-2.12"
-DEPEND="virtual/pkgconfig
+RDEPEND="
+ >=gnome-base/gnome-vfs-2.8.1
+ >=dev-cpp/glibmm-2.12
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
doc? ( app-doc/doxygen )
- ${RDEPEND}"
-
-DOCS="AUTHORS ChangeLog NEWS README INSTALL"
-
-src_unpack() {
- gnome2_src_unpack
+"
+src_prepare() {
if ! use doc; then
# documentation requires Doxygen and takes time
sed -i 's/^\(SUBDIRS =.*\)docs\(.*\)$/\1\2/' Makefile.in || \
@@ -35,17 +38,19 @@ src_unpack() {
sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || \
die "sed Makefile.in failed"
fi
+
+ gnome2_src_prepare
}
src_install() {
gnome2_src_install
if use doc ; then
- dohtml -r docs/reference/html/* docs/images/*
+ dohtml -r docs/reference/html/*
fi
if use examples; then
find examples -type d -name '.deps' -exec rm -fr {} \; 2>/dev/null
- cp -R examples "${D}"/usr/share/doc/${PF}
+ cp -R examples "${ED}"/usr/share/doc/${PF}
fi
}