summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-05-04 12:34:39 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-05-04 12:34:39 +0000
commit6109e41087917ccb2bc9e4266ab9f7f7b5de19e8 (patch)
tree61475ab307b53352c578de4b8dbe7680bbc811c9 /dev-cpp/glibmm/glibmm-2.6.1.ebuild
parentLink against -lgdbm_compat now that it has been broken out. Thanks to Ryan F... (diff)
downloadgentoo-2-6109e41087917ccb2bc9e4266ab9f7f7b5de19e8.tar.gz
gentoo-2-6109e41087917ccb2bc9e4266ab9f7f7b5de19e8.tar.bz2
gentoo-2-6109e41087917ccb2bc9e4266ab9f7f7b5de19e8.zip
Fix html image sed.
(Portage version: 2.0.51.21)
Diffstat (limited to 'dev-cpp/glibmm/glibmm-2.6.1.ebuild')
-rw-r--r--dev-cpp/glibmm/glibmm-2.6.1.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-cpp/glibmm/glibmm-2.6.1.ebuild b/dev-cpp/glibmm/glibmm-2.6.1.ebuild
index 0fb7b7c111f1..cd5fc0d1140e 100644
--- a/dev-cpp/glibmm/glibmm-2.6.1.ebuild
+++ b/dev-cpp/glibmm/glibmm-2.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/glibmm/glibmm-2.6.1.ebuild,v 1.3 2005/05/03 11:56:50 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/glibmm/glibmm-2.6.1.ebuild,v 1.4 2005/05/04 12:34:39 ka0ttic Exp $
inherit gnome2
@@ -27,15 +27,19 @@ src_unpack() {
# don't waste time building the examples
sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || \
die "sed Makefile.in failed"
+
+ if use doc ; then
+ sed -i 's|../../images/||g' docs/reference/html/*.html || \
+ die "sed failed"
+ fi
}
src_install() {
gnome2_src_install
- rm -fr ${D}/usr/share/doc/${P%.*}
+ rm -fr ${D}/usr/share/doc/${PN}*
if use doc ; then
# API Reference
dohtml -r docs/reference/html/* docs/images/*
- dosed -i 's?../../images/??g' /usr/share/doc/${PF}/html/*.html
# examples
cp -R examples ${D}/usr/share/doc/${PF}
fi