summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-24 19:27:18 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-24 19:27:18 +0000
commite67b5ab3419982fa9882c51f6d6d42a994fe3a64 (patch)
treee8fe29cc03263373c8f984a314fa2a5d0e51344e /dev-cpp/ctemplate
parentStable on alpha, bug 384483. (diff)
downloadgentoo-2-e67b5ab3419982fa9882c51f6d6d42a994fe3a64.tar.gz
gentoo-2-e67b5ab3419982fa9882c51f6d6d42a994fe3a64.tar.bz2
gentoo-2-e67b5ab3419982fa9882c51f6d6d42a994fe3a64.zip
Use `default` in src_install, and add patch for building with gcc-4.7.
(Portage version: 2.2.0_alpha107_p3/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/ctemplate')
-rw-r--r--dev-cpp/ctemplate/ChangeLog6
-rw-r--r--dev-cpp/ctemplate/ctemplate-1.0.ebuild12
-rw-r--r--dev-cpp/ctemplate/files/ctemplate-1.0-gcc-4.7.patch29
3 files changed, 42 insertions, 5 deletions
diff --git a/dev-cpp/ctemplate/ChangeLog b/dev-cpp/ctemplate/ChangeLog
index f89a14bb94d6..77d0d7fd6a23 100644
--- a/dev-cpp/ctemplate/ChangeLog
+++ b/dev-cpp/ctemplate/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-cpp/ctemplate
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ChangeLog,v 1.22 2012/04/20 17:55:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ChangeLog,v 1.23 2012/05/24 19:27:18 vapier Exp $
+
+ 24 May 2012; Mike Frysinger <vapier@gentoo.org>
+ +files/ctemplate-1.0-gcc-4.7.patch, ctemplate-1.0.ebuild:
+ Use `default` in src_install, and add patch for building with gcc-4.7.
*ctemplate-2.2 (20 Apr 2012)
diff --git a/dev-cpp/ctemplate/ctemplate-1.0.ebuild b/dev-cpp/ctemplate/ctemplate-1.0.ebuild
index 70540264a04d..f6c2b810e14c 100644
--- a/dev-cpp/ctemplate/ctemplate-1.0.ebuild
+++ b/dev-cpp/ctemplate/ctemplate-1.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ctemplate-1.0.ebuild,v 1.6 2012/02/13 16:29:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ctemplate-1.0.ebuild,v 1.7 2012/05/24 19:27:18 vapier Exp $
EAPI="4"
-inherit elisp-common python
+inherit elisp-common python eutils
DESCRIPTION="A simple but powerful template language for C++"
HOMEPAGE="http://code.google.com/p/google-ctemplate/"
@@ -28,6 +28,10 @@ pkg_setup() {
fi
}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc-4.7.patch
+}
+
src_configure() {
econf \
--enable-shared \
@@ -43,7 +47,7 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install
+ default
# Installs just every piece
rm -rf "${ED}/usr/share/doc"
@@ -64,7 +68,7 @@ src_install() {
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
fi
- find "${ED}" -name '*.la' -exec rm -f {} +
+ find "${ED}"/usr -name '*.la' -delete
}
pkg_postinst() {
diff --git a/dev-cpp/ctemplate/files/ctemplate-1.0-gcc-4.7.patch b/dev-cpp/ctemplate/files/ctemplate-1.0-gcc-4.7.patch
new file mode 100644
index 000000000000..a8eaaa6fa13e
--- /dev/null
+++ b/dev-cpp/ctemplate/files/ctemplate-1.0-gcc-4.7.patch
@@ -0,0 +1,29 @@
+backported fix from ctemplate-2.2 for building with gcc-4.7+
+
+--- ctemplate-1.0/src/base/small_map.h
++++ ctemplate-1.0/src/base/small_map.h
+@@ -360,20 +360,20 @@ class small_map {
+ if (size_ >= 0) {
+ for (int i = 0; i < size_; i++) {
+ if (compare(array_[i]->first, x.first)) {
+- return make_pair(iterator(array_ + i), false);
++ return std::make_pair(iterator(array_ + i), false);
+ }
+ }
+ if (size_ == kArraySize) {
+ ConvertToRealMap(); // Invalidates all iterators!
+ std::pair<typename NormalMap::iterator, bool> ret = map_->insert(x);
+- return make_pair(iterator(ret.first), ret.second);
++ return std::make_pair(iterator(ret.first), ret.second);
+ } else {
+ array_[size_].Init(x);
+- return make_pair(iterator(array_ + size_++), true);
++ return std::make_pair(iterator(array_ + size_++), true);
+ }
+ } else {
+ std::pair<typename NormalMap::iterator, bool> ret = map_->insert(x);
+- return make_pair(iterator(ret.first), ret.second);
++ return std::make_pair(iterator(ret.first), ret.second);
+ }
+ }
+