summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-02-18 12:11:33 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-02-18 12:11:33 +0000
commit8fb8d9436897097f3ac7cdc9dfef5190a58069b0 (patch)
treeb28e3c75e422172e9167e364ab1675eb8dc58c4e /dev-cpp/ctemplate
parentFixed messed up ChangeLog file (diff)
downloadgentoo-2-8fb8d9436897097f3ac7cdc9dfef5190a58069b0.tar.gz
gentoo-2-8fb8d9436897097f3ac7cdc9dfef5190a58069b0.tar.bz2
gentoo-2-8fb8d9436897097f3ac7cdc9dfef5190a58069b0.zip
Drop old versions
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'dev-cpp/ctemplate')
-rw-r--r--dev-cpp/ctemplate/ChangeLog8
-rw-r--r--dev-cpp/ctemplate/ctemplate-1.0.ebuild80
-rw-r--r--dev-cpp/ctemplate/ctemplate-2.0.ebuild76
-rw-r--r--dev-cpp/ctemplate/files/ctemplate-1.0-gcc-4.7.patch29
4 files changed, 6 insertions, 187 deletions
diff --git a/dev-cpp/ctemplate/ChangeLog b/dev-cpp/ctemplate/ChangeLog
index ec560f048de8..f6516f8b7cdb 100644
--- a/dev-cpp/ctemplate/ChangeLog
+++ b/dev-cpp/ctemplate/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-cpp/ctemplate
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ChangeLog,v 1.27 2012/08/04 14:12:19 blueness Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ChangeLog,v 1.28 2014/02/18 12:11:32 pinkbyte Exp $
+
+ 18 Feb 2014; Sergey Popov <pinkbyte@gentoo.org> -ctemplate-1.0.ebuild,
+ -files/ctemplate-1.0-gcc-4.7.patch, -ctemplate-2.0.ebuild:
+ Drop old versions
04 Aug 2012; Anthony G. Basile <blueness@gentoo.org> ctemplate-2.2.ebuild:
Stable arm, bug #418665
diff --git a/dev-cpp/ctemplate/ctemplate-1.0.ebuild b/dev-cpp/ctemplate/ctemplate-1.0.ebuild
deleted file mode 100644
index f6c2b810e14c..000000000000
--- a/dev-cpp/ctemplate/ctemplate-1.0.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ctemplate-1.0.ebuild,v 1.7 2012/05/24 19:27:18 vapier Exp $
-
-EAPI="4"
-
-inherit elisp-common python eutils
-
-DESCRIPTION="A simple but powerful template language for C++"
-HOMEPAGE="http://code.google.com/p/google-ctemplate/"
-SRC_URI="http://google-ctemplate.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm ~ppc x86 ~amd64-linux ~x86-linux"
-IUSE="doc emacs vim-syntax static-libs test"
-
-DEPEND="test? ( =dev-lang/python-2* )"
-RDEPEND="vim-syntax? ( >=app-editors/vim-core-7 )
- emacs? ( virtual/emacs )"
-
-SITEFILE="70ctemplate-gentoo.el"
-
-pkg_setup() {
- if use test ; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc-4.7.patch
-}
-
-src_configure() {
- econf \
- --enable-shared \
- $(use_enable static-libs static)
-}
-
-src_compile() {
- default
-
- if use emacs ; then
- elisp-compile contrib/tpl-mode.el || die "elisp-compile failed"
- fi
-}
-
-src_install() {
- default
-
- # Installs just every piece
- rm -rf "${ED}/usr/share/doc"
-
- dodoc AUTHORS ChangeLog NEWS README
- use doc && dohtml doc/*
-
- if use vim-syntax ; then
- cd "${S}/contrib"
- sh highlighting.vim || die "unpacking vim scripts failed"
- insinto /usr/share/vim/vimfiles
- doins -r .vim/*
- fi
-
- if use emacs ; then
- cd "${S}/contrib"
- elisp-install ${PN} tpl-mode.el tpl-mode.elc || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- find "${ED}"/usr -name '*.la' -delete
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-cpp/ctemplate/ctemplate-2.0.ebuild b/dev-cpp/ctemplate/ctemplate-2.0.ebuild
deleted file mode 100644
index 1f4f0c2b2cde..000000000000
--- a/dev-cpp/ctemplate/ctemplate-2.0.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ctemplate-2.0.ebuild,v 1.2 2012/03/07 19:07:34 ranger Exp $
-
-EAPI="4"
-
-inherit elisp-common python
-
-DESCRIPTION="A simple but powerful template language for C++"
-HOMEPAGE="http://code.google.com/p/ctemplate/"
-SRC_URI="http://ctemplate.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc emacs vim-syntax static-libs test"
-
-DEPEND="test? ( =dev-lang/python-2* )"
-RDEPEND="vim-syntax? ( >=app-editors/vim-core-7 )
- emacs? ( virtual/emacs )"
-
-SITEFILE="70ctemplate-gentoo.el"
-
-pkg_setup() {
- if use test ; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_configure() {
- econf \
- --enable-shared \
- $(use_enable static-libs static)
-}
-
-src_compile() {
- default
-
- if use emacs ; then
- elisp-compile contrib/tpl-mode.el || die "elisp-compile failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- # Installs just every piece
- rm -rf "${ED}/usr/share/doc"
-
- dodoc AUTHORS ChangeLog NEWS README
- use doc && dohtml doc/*
-
- if use vim-syntax ; then
- cd "${S}/contrib"
- sh highlighting.vim || die "unpacking vim scripts failed"
- insinto /usr/share/vim/vimfiles
- doins -r .vim/*
- fi
-
- if use emacs ; then
- cd "${S}/contrib"
- elisp-install ${PN} tpl-mode.el tpl-mode.elc || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- find "${ED}" -name '*.la' -exec rm -f {} +
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-cpp/ctemplate/files/ctemplate-1.0-gcc-4.7.patch b/dev-cpp/ctemplate/files/ctemplate-1.0-gcc-4.7.patch
deleted file mode 100644
index a8eaaa6fa13e..000000000000
--- a/dev-cpp/ctemplate/files/ctemplate-1.0-gcc-4.7.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-backported fix from ctemplate-2.2 for building with gcc-4.7+
-
---- ctemplate-1.0/src/base/small_map.h
-+++ ctemplate-1.0/src/base/small_map.h
-@@ -360,20 +360,20 @@ class small_map {
- if (size_ >= 0) {
- for (int i = 0; i < size_; i++) {
- if (compare(array_[i]->first, x.first)) {
-- return make_pair(iterator(array_ + i), false);
-+ return std::make_pair(iterator(array_ + i), false);
- }
- }
- if (size_ == kArraySize) {
- ConvertToRealMap(); // Invalidates all iterators!
- std::pair<typename NormalMap::iterator, bool> ret = map_->insert(x);
-- return make_pair(iterator(ret.first), ret.second);
-+ return std::make_pair(iterator(ret.first), ret.second);
- } else {
- array_[size_].Init(x);
-- return make_pair(iterator(array_ + size_++), true);
-+ return std::make_pair(iterator(array_ + size_++), true);
- }
- } else {
- std::pair<typename NormalMap::iterator, bool> ret = map_->insert(x);
-- return make_pair(iterator(ret.first), ret.second);
-+ return std::make_pair(iterator(ret.first), ret.second);
- }
- }
-