summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-03-11 03:39:34 +0000
committerTim Harder <radhermit@gentoo.org>2014-03-11 03:39:34 +0000
commitaeca262329054d0b0a80b240d5e3e45b67c9b3af (patch)
treeb806f2e498189c8e9f7994f6d0053a256a36c0d5 /app-vim
parentVersion bump. (diff)
downloadgentoo-2-aeca262329054d0b0a80b240d5e3e45b67c9b3af.tar.gz
gentoo-2-aeca262329054d0b0a80b240d5e3e45b67c9b3af.tar.bz2
gentoo-2-aeca262329054d0b0a80b240d5e3e45b67c9b3af.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/command-t/ChangeLog9
-rw-r--r--app-vim/command-t/command-t-1.7.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/app-vim/command-t/ChangeLog b/app-vim/command-t/ChangeLog
index 4a292cbffccf..bb1dde4c87a7 100644
--- a/app-vim/command-t/ChangeLog
+++ b/app-vim/command-t/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/command-t
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/command-t/ChangeLog,v 1.14 2013/12/23 07:04:38 radhermit Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/command-t/ChangeLog,v 1.15 2014/03/11 03:39:34 radhermit Exp $
+
+*command-t-1.7 (11 Mar 2014)
+
+ 11 Mar 2014; Tim Harder <radhermit@gentoo.org> +command-t-1.7.ebuild:
+ Version bump.
23 Dec 2013; Tim Harder <radhermit@gentoo.org> -command-t-1.3.1.ebuild,
-command-t-1.4.ebuild, -command-t-1.5.ebuild:
diff --git a/app-vim/command-t/command-t-1.7.ebuild b/app-vim/command-t/command-t-1.7.ebuild
new file mode 100644
index 000000000000..04987ff78e6f
--- /dev/null
+++ b/app-vim/command-t/command-t-1.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/command-t/command-t-1.7.ebuild,v 1.1 2014/03/11 03:39:34 radhermit Exp $
+
+EAPI="5"
+USE_RUBY="ruby18 ruby19 ruby20"
+
+inherit vim-plugin ruby-ng
+
+DESCRIPTION="vim plugin: fast file navigation for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3025
+ https://wincent.com/products/command-t"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="|| ( app-editors/vim[ruby] app-editors/gvim[ruby] )"
+
+each_ruby_configure() {
+ cd ruby/${PN}
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ cd ruby/${PN}
+ emake V=1
+ rm *.o *.c *.h *.log extconf.rb depend Makefile || die
+}
+
+each_ruby_install() {
+ local sitelibdir=$(ruby_rbconfig_value "sitelibdir")
+ insinto ${sitelibdir}/${PN}
+ doins -r ruby/${PN}/*
+}
+
+all_ruby_install() {
+ rm -r ruby || die
+ vim-plugin_src_install
+}