summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-02-28 03:57:11 +0000
committerTim Harder <radhermit@gentoo.org>2012-02-28 03:57:11 +0000
commit3faae21afb76ca0f67e18b1699266ef484197170 (patch)
tree3b03055d7fe8a0f45c5e5f6397eb7fe04d9e404c /app-vim
parentUse aurora branding when bindist enabledbug #404999 (diff)
downloadgentoo-2-3faae21afb76ca0f67e18b1699266ef484197170.tar.gz
gentoo-2-3faae21afb76ca0f67e18b1699266ef484197170.tar.bz2
gentoo-2-3faae21afb76ca0f67e18b1699266ef484197170.zip
Version bump.
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/command-t/ChangeLog9
-rw-r--r--app-vim/command-t/command-t-1.3.1.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/app-vim/command-t/ChangeLog b/app-vim/command-t/ChangeLog
index 736404822126..a3944ece317b 100644
--- a/app-vim/command-t/ChangeLog
+++ b/app-vim/command-t/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/command-t
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/command-t/ChangeLog,v 1.4 2011/09/13 08:06:29 radhermit Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/command-t/ChangeLog,v 1.5 2012/02/28 03:57:11 radhermit Exp $
+
+*command-t-1.3.1 (28 Feb 2012)
+
+ 28 Feb 2012; Tim Harder <radhermit@gentoo.org> +command-t-1.3.1.ebuild:
+ Version bump.
13 Sep 2011; Tim Harder <radhermit@gentoo.org> command-t-1.2.1-r1.ebuild:
Remove unnecessary permission setting and die on file removal failures.
diff --git a/app-vim/command-t/command-t-1.3.1.ebuild b/app-vim/command-t/command-t-1.3.1.ebuild
new file mode 100644
index 000000000000..92d80e41fc03
--- /dev/null
+++ b/app-vim/command-t/command-t-1.3.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/command-t/command-t-1.3.1.ebuild,v 1.1 2012/02/28 03:57:11 radhermit Exp $
+
+EAPI="4"
+USE_RUBY="ruby18 ruby19"
+
+inherit vim-plugin ruby-ng
+
+DESCRIPTION="vim plugin: fast file navigation for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3025
+ https://wincent.com/products/command-t"
+SRC_URI="http://dev.gentoo.org/~radhermit/distfiles/${P}.tar.bz2"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="|| ( app-editors/vim[ruby] app-editors/gvim[ruby] )"
+
+each_ruby_configure() {
+ cd ruby/${PN}
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ cd ruby/${PN}
+ emake
+ rm *.o *.c *.h *.log extconf.rb depend Makefile || die
+}
+
+each_ruby_install() {
+ local sitelibdir=$(ruby_rbconfig_value "sitelibdir")
+ insinto ${sitelibdir}/${PN}
+ doins -r ruby/${PN}/*
+}
+
+all_ruby_install() {
+ rm -rf ruby
+ vim-plugin_src_install
+}