summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-08-08 22:10:50 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-08-08 22:10:50 +0000
commitf934e8134d951796d9f35f3502ea858e1aea0624 (patch)
tree577937e69677faea684edb7635a20f1bc8dd4a61 /app-vim/help-extra-syntax
parent~alpha keyword. (diff)
downloadgentoo-2-f934e8134d951796d9f35f3502ea858e1aea0624.tar.gz
gentoo-2-f934e8134d951796d9f35f3502ea858e1aea0624.tar.bz2
gentoo-2-f934e8134d951796d9f35f3502ea858e1aea0624.zip
Use hi def link rather than hi link. Bug #101797, bug #101804.
(Portage version: 2.0.51.22-r2 flaming goat edition)
Diffstat (limited to 'app-vim/help-extra-syntax')
-rw-r--r--app-vim/help-extra-syntax/ChangeLog8
-rw-r--r--app-vim/help-extra-syntax/Manifest4
-rw-r--r--app-vim/help-extra-syntax/files/digest-help-extra-syntax-20050106-r11
-rw-r--r--app-vim/help-extra-syntax/help-extra-syntax-20050106-r1.ebuild23
4 files changed, 34 insertions, 2 deletions
diff --git a/app-vim/help-extra-syntax/ChangeLog b/app-vim/help-extra-syntax/ChangeLog
index 1137d7e22773..5663049b5c2b 100644
--- a/app-vim/help-extra-syntax/ChangeLog
+++ b/app-vim/help-extra-syntax/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-vim/help-extra-syntax
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/help-extra-syntax/ChangeLog,v 1.6 2005/06/12 11:26:09 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/help-extra-syntax/ChangeLog,v 1.7 2005/08/08 22:10:50 ciaranm Exp $
+
+*help-extra-syntax-20050106-r1 (08 Aug 2005)
+
+ 08 Aug 2005; Ciaran McCreesh <ciaranm@gentoo.org>
+ +help-extra-syntax-20050106-r1.ebuild:
+ Use hi def link rather than hi link. Bug #101797, bug #101804.
12 Jun 2005; David Holm <dholm@gentoo.org>
help-extra-syntax-20050106.ebuild:
diff --git a/app-vim/help-extra-syntax/Manifest b/app-vim/help-extra-syntax/Manifest
index 6a562d948457..4065805ec3c7 100644
--- a/app-vim/help-extra-syntax/Manifest
+++ b/app-vim/help-extra-syntax/Manifest
@@ -1,4 +1,6 @@
+MD5 ec383e49c15331ef92288a69ba36c243 help-extra-syntax-20050106-r1.ebuild 761
+MD5 d0eb2058f77d01492f62b14ad7b76759 metadata.xml 379
MD5 2c0fb059776438c86ada6d099f5aa50b ChangeLog 935
MD5 985d404139d7f7086ef000dde818a888 help-extra-syntax-20050106.ebuild 562
-MD5 d0eb2058f77d01492f62b14ad7b76759 metadata.xml 379
MD5 4ef9160eb80a2282eb54f3bf47c4d816 files/digest-help-extra-syntax-20050106 76
+MD5 4ef9160eb80a2282eb54f3bf47c4d816 files/digest-help-extra-syntax-20050106-r1 76
diff --git a/app-vim/help-extra-syntax/files/digest-help-extra-syntax-20050106-r1 b/app-vim/help-extra-syntax/files/digest-help-extra-syntax-20050106-r1
new file mode 100644
index 000000000000..ee2f758a6fc8
--- /dev/null
+++ b/app-vim/help-extra-syntax/files/digest-help-extra-syntax-20050106-r1
@@ -0,0 +1 @@
+MD5 0d2e61cf18dfcab3fee59a4fe8fd09b9 help-extra-syntax-20050106.tar.bz2 633
diff --git a/app-vim/help-extra-syntax/help-extra-syntax-20050106-r1.ebuild b/app-vim/help-extra-syntax/help-extra-syntax-20050106-r1.ebuild
new file mode 100644
index 000000000000..ec4662df0bc6
--- /dev/null
+++ b/app-vim/help-extra-syntax/help-extra-syntax-20050106-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/help-extra-syntax/help-extra-syntax-20050106-r1.ebuild,v 1.1 2005/08/08 22:10:50 ciaranm Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: extra syntax highlighting for help files"
+HOMEPAGE="http://mysite.verizon.net/astronaut/vim/"
+LICENSE="as-is"
+KEYWORDS="alpha ~amd64 arm hppa ia64 mips ~ppc ppc64 sparc x86"
+IUSE=""
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides additional syntax highlighting for help files."
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ # use hi def link, bug #101797 / bug #101804
+ sed -i -e 's,^hi link,hi def link,' \
+ "after/syntax/help.vim.d/extra-help-syntax.vim" || die "sed failed"
+}
+