summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-08-10 21:14:17 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-08-10 21:14:17 +0000
commitf6d5f2579c09af760777eb5b39a5ba7ef0c05d54 (patch)
tree42c2ee7b83162f7fc6452854ef12e8fe1b9f3dc6 /app-vim/bnf-syntax/bnf-syntax-1.2-r1.ebuild
parentAdded German longdescription. (diff)
downloadgentoo-2-f6d5f2579c09af760777eb5b39a5ba7ef0c05d54.tar.gz
gentoo-2-f6d5f2579c09af760777eb5b39a5ba7ef0c05d54.tar.bz2
gentoo-2-f6d5f2579c09af760777eb5b39a5ba7ef0c05d54.zip
Don't use hi link, bug #101790
(Portage version: 2.0.51.22-r2 flaming goat edition)
Diffstat (limited to 'app-vim/bnf-syntax/bnf-syntax-1.2-r1.ebuild')
-rw-r--r--app-vim/bnf-syntax/bnf-syntax-1.2-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-vim/bnf-syntax/bnf-syntax-1.2-r1.ebuild b/app-vim/bnf-syntax/bnf-syntax-1.2-r1.ebuild
new file mode 100644
index 000000000000..908e71801411
--- /dev/null
+++ b/app-vim/bnf-syntax/bnf-syntax-1.2-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/bnf-syntax/bnf-syntax-1.2-r1.ebuild,v 1.1 2005/08/10 21:14:17 ciaranm Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: BNF file syntax highlighting"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=250"
+LICENSE="as-is"
+KEYWORDS="~alpha ~amd64 ia64 mips ~ppc ppc64 sparc x86"
+IUSE=""
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting for BNF files."
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ # fix hi link to use def, bug #101790.
+ sed -i -e 's,hi link,hi def link,g' syntax/bnf.vim || die "sed failed"
+}
+