summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-03 04:13:59 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-03 04:13:59 +0000
commit3bb61e77f82256af6f20456506a47584bc608360 (patch)
tree03f460c412f173da6c8f41553f689299b0362aee /app-vim/automatictexplugin/automatictexplugin-12.3.ebuild
parentrespect AR - bug #466600 - patch by Ted Tanberry. removed old. (diff)
downloadgentoo-2-3bb61e77f82256af6f20456506a47584bc608360.tar.gz
gentoo-2-3bb61e77f82256af6f20456506a47584bc608360.tar.bz2
gentoo-2-3bb61e77f82256af6f20456506a47584bc608360.zip
Version bump.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-vim/automatictexplugin/automatictexplugin-12.3.ebuild')
-rw-r--r--app-vim/automatictexplugin/automatictexplugin-12.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-vim/automatictexplugin/automatictexplugin-12.3.ebuild b/app-vim/automatictexplugin/automatictexplugin-12.3.ebuild
new file mode 100644
index 000000000000..2ec0b7677fac
--- /dev/null
+++ b/app-vim/automatictexplugin/automatictexplugin-12.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/automatictexplugin/automatictexplugin-12.3.ebuild,v 1.1 2013/05/03 04:13:59 radhermit Exp $
+
+EAPI=5
+
+inherit vim-plugin
+
+MY_P="AutomaticTexPlugin_${PV}"
+DESCRIPTION="vim plugin: a comprehensive plugin for editing LaTeX files"
+HOMEPAGE="http://atp-vim.sourceforge.net/"
+SRC_URI="mirror://sourceforge/atp-vim/releases/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+
+S=${WORKDIR}
+
+VIM_PLUGIN_HELPFILES="automatic-tex-plugin.txt"
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )
+ !app-vim/vim-latex
+ app-vim/align
+ app-text/wdiff
+ >=dev-lang/python-2.7
+ dev-python/psutil
+ dev-tex/latexmk
+ dev-tex/detex
+ virtual/tex-base"