summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2006-07-26 16:38:37 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2006-07-26 16:38:37 +0000
commitfbff46bf70ecee092c730eda213ce4207306233f (patch)
tree1a137825f2fb8ce619043a5fe5219f0c5452acf4 /app-text
parentbump to patch 11. bump VDA patch to 2.2.10, bug #140099 reported by Alan Mosc... (diff)
downloadgentoo-2-fbff46bf70ecee092c730eda213ce4207306233f.tar.gz
gentoo-2-fbff46bf70ecee092c730eda213ce4207306233f.tar.bz2
gentoo-2-fbff46bf70ecee092c730eda213ce4207306233f.zip
adding 64-Bit patch, solving bug #136319.
(Portage version: 2.1.1_pre3-r4)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/mbtpdfasm/ChangeLog8
-rw-r--r--app-text/mbtpdfasm/files/digest-mbtpdfasm-1.0.26-r23
-rw-r--r--app-text/mbtpdfasm/files/mbtpdfasm-1.0.26-64bit.patch44
-rw-r--r--app-text/mbtpdfasm/mbtpdfasm-1.0.26-r2.ebuild52
4 files changed, 106 insertions, 1 deletions
diff --git a/app-text/mbtpdfasm/ChangeLog b/app-text/mbtpdfasm/ChangeLog
index 332e5bd9b0ef..3d2fb4892fe8 100644
--- a/app-text/mbtpdfasm/ChangeLog
+++ b/app-text/mbtpdfasm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/mbtpdfasm
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mbtpdfasm/ChangeLog,v 1.2 2006/04/08 10:56:34 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mbtpdfasm/ChangeLog,v 1.3 2006/07/26 16:38:37 sbriesen Exp $
+
+*mbtpdfasm-1.0.26-r2 (26 Jul 2006)
+
+ 26 Jul 2006; Stefan Briesenick <sbriesen@gentoo.org>
+ +files/mbtpdfasm-1.0.26-64bit.patch, +mbtpdfasm-1.0.26-r2.ebuild:
+ adding 64-Bit patch, solving bug #136319.
*mbtpdfasm-1.0.26-r1 (08 Apr 2006)
diff --git a/app-text/mbtpdfasm/files/digest-mbtpdfasm-1.0.26-r2 b/app-text/mbtpdfasm/files/digest-mbtpdfasm-1.0.26-r2
new file mode 100644
index 000000000000..e201c5fc8de5
--- /dev/null
+++ b/app-text/mbtpdfasm/files/digest-mbtpdfasm-1.0.26-r2
@@ -0,0 +1,3 @@
+MD5 15434f0098d992d3e7424cb39e9f1f13 mbtPdfAsm-1.0.26.tar.gz 258630
+RMD160 014fb4ee022561a02b286ffc5b8c1a10c3c8418c mbtPdfAsm-1.0.26.tar.gz 258630
+SHA256 13b5e44f245941da701da86e51ebbbd0b0b0632021360df4dd296b73d2b6085a mbtPdfAsm-1.0.26.tar.gz 258630
diff --git a/app-text/mbtpdfasm/files/mbtpdfasm-1.0.26-64bit.patch b/app-text/mbtpdfasm/files/mbtpdfasm-1.0.26-64bit.patch
new file mode 100644
index 000000000000..25573466f0b9
--- /dev/null
+++ b/app-text/mbtpdfasm/files/mbtpdfasm-1.0.26-64bit.patch
@@ -0,0 +1,44 @@
+--- pdfFile.hpp.orig 2006-06-12 00:01:12.000000000 +0200
++++ pdfFile.hpp 2006-06-12 00:09:46.000000000 +0200
+@@ -158,7 +158,7 @@
+
+ //int findInheritRes(C_pdfFile *org, char *fBuf, int lg, char **pcRes);
+ int makeRes(C_pdfFile *org, char *fBuf, int lg, char **pcRes);
+- int makeAttrib(C_pdfFile *org, char *fBuf, int lgOrgBuf, char **pcRes, char *add, int lgAdd);
++ int makeAttrib(C_pdfFile *org, char *fBuf, int lgOrgBuf, char **pcRes, int add, int lgAdd);
+
+ bool fast; // version rapide, on ne gère pas les options
+ bool closed; //protection plus rien n'est possible aprés l'appel à la fonction close
+--- pdfFile.cpp.orig 2006-06-12 00:01:23.000000000 +0200
++++ pdfFile.cpp 2006-06-12 00:11:49.000000000 +0200
+@@ -906,7 +906,7 @@
+ /* ********************************************** */
+ #pragma warning(disable : 4100)
+
+-int C_pdfFile::makeAttrib(C_pdfFile *org, char *buf, int lgOrgBuf, char **pcRes, char *add, int lgAdd) {
++int C_pdfFile::makeAttrib(C_pdfFile *org, char *buf, int lgOrgBuf, char **pcRes, int add, int lgAdd) {
+ char *pc;
+ int lgRes, lgBuf, j, nObj, r;
+
+@@ -945,12 +945,12 @@
+ }
+
+ if ( (lgAdd != 0) && (add != 0) ) {
+- switch ( (int)add ) {
++ switch ( add ) {
+ case _Resources:
+
+ break;
+ default:
+- memcpy(pc + lgRes, add + sizeof(int), lgAdd);
++ memcpy(pc + lgRes, (char *)add + sizeof(int), lgAdd);
+ lgRes += lgAdd;
+ }
+ }
+@@ -2663,4 +2663,4 @@
+ delete p;
+
+ return destBuf;
+-}
+\ Kein Zeilenumbruch am Dateiende.
++}
diff --git a/app-text/mbtpdfasm/mbtpdfasm-1.0.26-r2.ebuild b/app-text/mbtpdfasm/mbtpdfasm-1.0.26-r2.ebuild
new file mode 100644
index 000000000000..b263de28d5ca
--- /dev/null
+++ b/app-text/mbtpdfasm/mbtpdfasm-1.0.26-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mbtpdfasm/mbtpdfasm-1.0.26-r2.ebuild,v 1.1 2006/07/26 16:38:37 sbriesen Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P="mbtPdfAsm-${PV}"
+
+DESCRIPTION="mbtPdfAsm can assemble/merge PDF files, extract information from PDF files, and update the metadata in PDF files."
+HOMEPAGE="http://thierry.schmit.free.fr/dev/mbtPdfAsm/enMbtPdfAsm2.html"
+SRC_URI="http://thierry.schmit.free.fr/dev/mbtPdfAsm/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="unicode"
+
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ edos2unix *.txt
+ epatch "${FILESDIR}/${P}-gcc4.patch"
+ epatch "${FILESDIR}/${P}-64bit.patch"
+
+ # patch location of help files
+ sed -i -e "s:\(aide.txt\):/usr/share/doc/${PF}/\1:g" \
+ -e "s:\(help.txt\):/usr/share/doc/${PF}/\1:g" string.cpp
+
+ # convert to UTF-8
+ if use unicode; then
+ for i in aide.txt; do
+ einfo "Converting ${i} to UTF-8"
+ iconv -f latin1 -t utf8 -o "${i}~" "${i}" && mv -f "${i}~" "${i}" || rm -f "${i}~"
+ done
+ fi
+}
+
+src_compile() {
+ # FIXME: ugly, but this way we don't need to patch anything
+ emake CC="$(tc-getCXX) ${CXXFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin mbtPdfAsm || die "install failed"
+ insinto /usr/share/doc/${PF}
+ doins *.txt # do not gzip!
+}