summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-08-28 13:15:15 +0000
committerFabian Groffen <grobian@gentoo.org>2011-08-28 13:15:15 +0000
commita5b4f67b6c68c23140f3384c8312c42a358ecf69 (patch)
treec374e14229eafae9e974ba7b8135964ef9c50aff /app-text
parentChange version scheme (diff)
downloadgentoo-2-a5b4f67b6c68c23140f3384c8312c42a358ecf69.tar.gz
gentoo-2-a5b4f67b6c68c23140f3384c8312c42a358ecf69.tar.bz2
gentoo-2-a5b4f67b6c68c23140f3384c8312c42a358ecf69.zip
Add patch by MATSUI Tetsushi to fix compilation on Darwin, bug #369363
(Portage version: 2.2.01.19074-prefix/cvs/Darwin i386)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/dvipng/ChangeLog6
-rw-r--r--app-text/dvipng/dvipng-1.14.ebuild6
-rw-r--r--app-text/dvipng/files/dvipng-1.14-wait.patch18
3 files changed, 28 insertions, 2 deletions
diff --git a/app-text/dvipng/ChangeLog b/app-text/dvipng/ChangeLog
index d5f125272a5f..583ead147f8b 100644
--- a/app-text/dvipng/ChangeLog
+++ b/app-text/dvipng/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/dvipng
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dvipng/ChangeLog,v 1.76 2011/06/14 03:29:05 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dvipng/ChangeLog,v 1.77 2011/08/28 13:15:15 grobian Exp $
+
+ 28 Aug 2011; Fabian Groffen <grobian@gentoo.org> dvipng-1.14.ebuild,
+ +files/dvipng-1.14-wait.patch:
+ Add patch by MATSUI Tetsushi to fix compilation on Darwin, bug #369363
14 Jun 2011; Matt Turner <mattst88@gentoo.org> dvipng-1.14.ebuild:
Added ~mips, bug 342513
diff --git a/app-text/dvipng/dvipng-1.14.ebuild b/app-text/dvipng/dvipng-1.14.ebuild
index 65cc89591655..2974acd0804c 100644
--- a/app-text/dvipng/dvipng-1.14.ebuild
+++ b/app-text/dvipng/dvipng-1.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dvipng/dvipng-1.14.ebuild,v 1.2 2011/06/14 03:29:05 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dvipng/dvipng-1.14.ebuild,v 1.3 2011/08/28 13:15:15 grobian Exp $
EAPI="2"
inherit eutils
@@ -24,6 +24,10 @@ DEPEND="${RDEPEND}
virtual/texi2dvi
test? ( || ( dev-texlive/texlive-fontsrecommended app-text/ptex ) )"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-wait.patch
+}
+
src_configure() {
if ! use t1lib; then
# The build system autodetects libt1. We don't want that if the
diff --git a/app-text/dvipng/files/dvipng-1.14-wait.patch b/app-text/dvipng/files/dvipng-1.14-wait.patch
new file mode 100644
index 000000000000..d7f629fb372b
--- /dev/null
+++ b/app-text/dvipng/files/dvipng-1.14-wait.patch
@@ -0,0 +1,18 @@
+Patch by MATSUI Tetsushi to fix compilation issue on OSX
+
+sys/wait.h seems to be the man-page include for waitpid on Linux,
+Solaris and OSX
+
+https://bugs.gentoo.org/show_bug.cgi?id=369363
+
+--- special.c
++++ special.c
+@@ -26,7 +26,7 @@
+
+ #ifndef MIKTEX
+ #ifndef WIN32
+-#include <wait.h>
++#include <sys/wait.h>
+ #else /* WIN32 */
+ #include <fcntl.h>
+ #include <io.h>