summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-12-14 03:56:06 +0000
committerTim Harder <radhermit@gentoo.org>2011-12-14 03:56:06 +0000
commit93c4f7aef33450d9804e9802f2c9991492882760 (patch)
tree86eacbe356736e6942cd7dcce8ff1fea8c5d621c /app-text
parentVersion bump. (diff)
downloadgentoo-2-93c4f7aef33450d9804e9802f2c9991492882760.tar.gz
gentoo-2-93c4f7aef33450d9804e9802f2c9991492882760.tar.bz2
gentoo-2-93c4f7aef33450d9804e9802f2c9991492882760.zip
Version bump.
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/csvfix/ChangeLog8
-rw-r--r--app-text/csvfix/csvfix-1.20.ebuild46
-rw-r--r--app-text/csvfix/files/csvfix-1.20-make.patch91
3 files changed, 144 insertions, 1 deletions
diff --git a/app-text/csvfix/ChangeLog b/app-text/csvfix/ChangeLog
index 43d384b567ad..6356cd602dc3 100644
--- a/app-text/csvfix/ChangeLog
+++ b/app-text/csvfix/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/csvfix
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/csvfix/ChangeLog,v 1.4 2011/09/11 23:53:41 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/csvfix/ChangeLog,v 1.5 2011/12/14 03:56:06 radhermit Exp $
+
+*csvfix-1.20 (14 Dec 2011)
+
+ 14 Dec 2011; Tim Harder <radhermit@gentoo.org> +csvfix-1.20.ebuild,
+ +files/csvfix-1.20-make.patch:
+ Version bump.
11 Sep 2011; Tim Harder <radhermit@gentoo.org> -csvfix-1.00c.ebuild,
-files/csvfix-1.00c-tests.patch:
diff --git a/app-text/csvfix/csvfix-1.20.ebuild b/app-text/csvfix/csvfix-1.20.ebuild
new file mode 100644
index 000000000000..5cf1034c6ea8
--- /dev/null
+++ b/app-text/csvfix/csvfix-1.20.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/csvfix/csvfix-1.20.ebuild,v 1.1 2011/12/14 03:56:06 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs versionator
+
+MY_PV="$(delete_all_version_separators)"
+DESCRIPTION="A stream editor for manipulating CSV files"
+HOMEPAGE="http://code.google.com/p/csvfix/"
+SRC_URI="http://csvfix.googlecode.com/files/${PN}_src_${MY_PV}.zip
+ doc? ( http://csvfix.googlecode.com/files/${PN}_man_html_${MY_PV}.zip )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-libs/expat"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${PN}-build"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-make.patch
+ epatch "${FILESDIR}"/${PN}-1.10a-tests.patch
+
+ edos2unix $(find csvfix/tests -type f)
+}
+
+src_compile() {
+ emake CC="$(tc-getCXX)" AR="$(tc-getAR)" lin
+}
+
+src_test() {
+ cd ${PN}/tests
+ chmod +x run1 runtests
+ ./runtests || die "tests failed"
+}
+
+src_install() {
+ dobin csvfix/bin/csvfix
+ use doc && dohtml -r "${WORKDIR}"/${PN}${MY_PV}-html/*
+}
diff --git a/app-text/csvfix/files/csvfix-1.20-make.patch b/app-text/csvfix/files/csvfix-1.20-make.patch
new file mode 100644
index 000000000000..7610bf8919fd
--- /dev/null
+++ b/app-text/csvfix/files/csvfix-1.20-make.patch
@@ -0,0 +1,91 @@
+--- csvfix-build.orig/alib/Makefile
++++ csvfix-build/alib/Makefile
+@@ -5,9 +5,8 @@
+ CC = g++
+ IDIR = inc
+ ODIR = obj
+-XDIR = expat
+ SDIR = src
+-INC = -Iinc -Iexpat
++INC = -Iinc
+
+ _OBJS = a_chsrc.o a_csv.o a_enc.o a_env.o a_except.o \
+ a_expr.o a_myth.o a_inifile.o a_exec.o \
+@@ -21,9 +20,6 @@
+ _WINOBJS = a_db.o a_dir.o a_opsys.o a_winerr.o
+ WINOBJS = $(patsubst %,$(ODIR)/%,$(_WINOBJS))
+
+-_EXPAT = xmlparse.o xmlrole.o xmltok.o xmltok_impl.o xmltok_ns.o
+-EXPAT = $(patsubst %,$(ODIR)/%,$(_EXPAT))
+-
+ $(ODIR)/%.o: $(SDIR)/%.cpp $(IDIR)/%.h
+ $(CC) -c $(INC) $(CFLAGS) -o $@ $<
+
+@@ -31,10 +27,10 @@
+ $(CC) -c $(INC) $(CFLAGS) -o $@ $<
+
+ win: $(OBJS) $(EXPAT) $(WINOBJS)
+- ar rvs $(OUT) $^
++ $(AR) rvs $(OUT) $^
+
+-lin: $(OBJS) $(EXPAT)
+- ar rvs $(OUT) $^
++lin: $(OBJS)
++ $(AR) rvs $(OUT) $^
+
+ .PHONY: clean
+
+--- csvfix-build.orig/csvfix/Makefile
++++ csvfix-build/csvfix/Makefile
+@@ -17,7 +17,7 @@
+ INC = -Iinc -I../alib/inc
+
+ WINLIBS = ../alib/lib/alib.a -lodbc32
+-LINLIBS = ../alib/lib/alib.a
++LINLIBS = ../alib/lib/alib.a -lexpat
+
+ _OBJS = csved_atable.o \
+ csved_case.o \
+@@ -86,16 +86,15 @@
+ strip $(WINOUT)
+
+ $(LINOUT): $(OBJS)
+- $(CC) -o $@ $^ $(LINLIBS)
+- strip $(LINOUT)
++ $(CC) $(LDFLAGS) -o $@ $^ $(LINLIBS)
+
+ .PHONY: win
+ win:
+- make $(WINOUT)
++ $(MAKE) $(WINOUT)
+
+ .PHONY: lin
+ lin:
+- make $(LINOUT)
++ $(MAKE) $(LINOUT)
+
+ .PHONY: clean
+ clean:
+--- csvfix-build.orig/Makefile
++++ csvfix-build/Makefile
+@@ -3,14 +3,14 @@
+
+ win:
+ mkdir -p alib/obj alib/lib csvfix/obj csvfix/bin
+- cd alib; make win
+- cd csvfix; make win
++ cd alib; $(MAKE) win
++ cd csvfix; $(MAKE) win
+
+ lin:
+ mkdir -p alib/obj alib/lib csvfix/obj csvfix/bin
+- cd alib; make lin
+- cd csvfix; make lin
++ cd alib; $(MAKE) lin
++ cd csvfix; $(MAKE) lin
+
+ clean:
+- cd alib; make clean
+- cd csvfix; make clean
++ cd alib; $(MAKE) clean
++ cd csvfix; $(MAKE) clean