summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-01-21 20:23:46 +0000
committerChris Reffett <creffett@gentoo.org>2013-01-21 20:23:46 +0000
commit92bfbcdbf8e4c81d5d2f0943bcfde29f0bda9d3f (patch)
tree91b498fac63cb4bd5640cffb2169060e80fd86be /app-text
parentmeh, typing error (diff)
downloadgentoo-2-92bfbcdbf8e4c81d5d2f0943bcfde29f0bda9d3f.tar.gz
gentoo-2-92bfbcdbf8e4c81d5d2f0943bcfde29f0bda9d3f.tar.bz2
gentoo-2-92bfbcdbf8e4c81d5d2f0943bcfde29f0bda9d3f.zip
Version bump. Add patch to fix build with modern glib, ship a .desktop file due to non-UTF-8 validation errors in the built in .desktop file. Fix dependencies.
(Portage version: 2.2.0_alpha155/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/glosung/ChangeLog14
-rw-r--r--app-text/glosung/files/glosung-3.6.2-glib-includes.patch11
-rw-r--r--app-text/glosung/files/glosung.desktop12
-rw-r--r--app-text/glosung/glosung-3.6.2.ebuild45
4 files changed, 79 insertions, 3 deletions
diff --git a/app-text/glosung/ChangeLog b/app-text/glosung/ChangeLog
index 3c40e47b94c7..06a7b29cad2f 100644
--- a/app-text/glosung/ChangeLog
+++ b/app-text/glosung/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-text/glosung
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/glosung/ChangeLog,v 1.12 2012/05/04 03:33:17 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/glosung/ChangeLog,v 1.13 2013/01/21 20:23:46 creffett Exp $
+
+*glosung-3.6.2 (21 Jan 2013)
+
+ 21 Jan 2013; Chris Reffett <creffett@gentoo.org>
+ +files/glosung-3.6.2-glib-includes.patch, +files/glosung.desktop,
+ +glosung-3.6.2.ebuild:
+ Version bump. Add patch to fix build with modern glib, ship a .desktop file
+ due to non-UTF-8 validation errors in the built in .desktop file. Fix
+ dependencies.
04 May 2012; Jeff Horelick <jdhore@gentoo.org> glosung-2.1.3.ebuild,
glosung-3.2.2.ebuild, glosung-3.4.2.ebuild, glosung-3.5.2.ebuild:
@@ -56,4 +65,3 @@
Initial commit. This is a gnome2 program for displaying words from the
Bible, different random ones every day. Thanks to Eicke Godehardt
<eicke_godehardt@web.de> for this package.
-
diff --git a/app-text/glosung/files/glosung-3.6.2-glib-includes.patch b/app-text/glosung/files/glosung-3.6.2-glib-includes.patch
new file mode 100644
index 000000000000..715b201ca64f
--- /dev/null
+++ b/app-text/glosung/files/glosung-3.6.2-glib-includes.patch
@@ -0,0 +1,11 @@
+diff -ruN glosung-3.6.2/src/losung.c glosung-3.6.2-patched/src/losung.c
+--- glosung-3.6.2/src/losung.c 2010-01-04 15:28:38.000000000 -0500
++++ glosung-3.6.2-patched/src/losung.c 2013-01-21 14:34:14.318711560 -0500
+@@ -31,7 +31,6 @@
+ #endif /* WIN32 */
+
+ #include <glib/gi18n.h>
+-#include <glib/goption.h>
+
+ #include "util.h"
+
diff --git a/app-text/glosung/files/glosung.desktop b/app-text/glosung/files/glosung.desktop
new file mode 100644
index 000000000000..7372b0f47123
--- /dev/null
+++ b/app-text/glosung/files/glosung.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=GLosung - Herrnhut's Watchwords
+Name[de]=GLosung - Herrnhuter Losungen
+Name[hu]=GLosung - Herrnhuter-i Útmutató
+Comment=Gods Word for every day
+Comment[de]=Gottes Wort für jeden Tag
+Comment[hu]=Isten igéje minden napra
+Exec=glosung
+Icon=/usr/share/glosung/glosung.png
+Terminal=false
+Type=Application
+Categories=Utility;X-Red-Hat-Extra;Spirituality;
diff --git a/app-text/glosung/glosung-3.6.2.ebuild b/app-text/glosung/glosung-3.6.2.ebuild
new file mode 100644
index 000000000000..873937dfee6b
--- /dev/null
+++ b/app-text/glosung/glosung-3.6.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/glosung/glosung-3.6.2.ebuild,v 1.1 2013/01/21 20:23:46 creffett Exp $
+
+EAPI=5
+
+inherit eutils
+DESCRIPTION="Watch word program for the GNOME2 desktop (watch word (german): losung)"
+HOMEPAGE="http://www.godehardt.org/losung.html"
+SRC_URI="mirror://sourceforge/glosung/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libxml2
+ >=gnome-base/gconf-2.0:2
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ net-misc/curl
+ >=x11-libs/gtk+-2.10:2
+"
+
+DEPEND="${RDEPEND}
+ >=dev-util/scons-0.93
+ >=dev-util/intltool-0.22
+ >=sys-devel/gettext-0.10
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-3.6.2-glib-includes.patch"
+}
+
+src_compile() {
+ scons ${MAKEOPTS} || die "scons make died"
+}
+
+src_install() {
+ scons install DESTDIR="${D}" || die "scons install died"
+ #Ships with an ISO-8859 encoded .desktop file, which causes validation to fail, so ship a UTF-8 version
+ cp "${FILESDIR}/glosung.desktop" "${D}/usr/share/applications"
+}