summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2006-11-02 17:52:04 +0000
committerMamoru Komachi <usata@gentoo.org>2006-11-02 17:52:04 +0000
commit75ab83eec9140316cc7ba707e4b20ec150194056 (patch)
tree87b4432d02540a53e594b067d983826b144d111c /app-text
parentAdded a patch to fix compilation problem in perl module for the first time. R... (diff)
downloadgentoo-2-75ab83eec9140316cc7ba707e4b20ec150194056.tar.gz
gentoo-2-75ab83eec9140316cc7ba707e4b20ec150194056.tar.bz2
gentoo-2-75ab83eec9140316cc7ba707e4b20ec150194056.zip
Added a patch to fix compilation problem in perl module for the first time. Removed old ebuild and stabilized -r1. Added ~amd64 keyword.
(Portage version: 2.1.1-r1)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/yamcha/ChangeLog8
-rw-r--r--app-text/yamcha/files/yamcha-0.33-pm.patch26
-rw-r--r--app-text/yamcha/yamcha-0.33-r1.ebuild12
3 files changed, 42 insertions, 4 deletions
diff --git a/app-text/yamcha/ChangeLog b/app-text/yamcha/ChangeLog
index 2f863304397c..27bc37bdb8a5 100644
--- a/app-text/yamcha/ChangeLog
+++ b/app-text/yamcha/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/yamcha
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/yamcha/ChangeLog,v 1.3 2006/06/29 19:38:31 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/yamcha/ChangeLog,v 1.4 2006/11/02 17:52:04 usata Exp $
+
+ 02 Nov 2006; Mamoru KOMACHI <usata@gentoo.org>
+ +files/yamcha-0.33-pm.patch, -yamcha-0.32.ebuild, -yamcha-0.33.ebuild,
+ yamcha-0.33-r1.ebuild:
+ Added a patch to fix compilation problem in perl module for the first time.
+ Removed old ebuild and stabilized -r1. Added ~amd64 keyword.
*yamcha-0.33-r1 (29 Jun 2006)
diff --git a/app-text/yamcha/files/yamcha-0.33-pm.patch b/app-text/yamcha/files/yamcha-0.33-pm.patch
new file mode 100644
index 000000000000..e52f80f07137
--- /dev/null
+++ b/app-text/yamcha/files/yamcha-0.33-pm.patch
@@ -0,0 +1,26 @@
+diff -urN perl.orig/Makefile.PL perl/Makefile.PL
+--- perl.orig/Makefile.PL 2005-09-06 00:09:48.000000000 +0900
++++ perl/Makefile.PL 2006-11-03 02:36:37.000000000 +0900
+@@ -6,7 +6,7 @@
+ 'LD' => 'g++',
+ 'NAME' => 'YamCha',
+ 'VERSION_FROM' => 'YamCha.pm', # finds $VERSION
+- 'INC' => '-I/usr/local/include',
+- 'LIBS' => '-L/usr/local/lib -lm -lstdc++ -lyamcha',
++ 'INC' => '-I../src -I/usr/local/include',
++ 'LIBS' => '-L../src -L/usr/local/lib -lm -lstdc++ -lyamcha',
+ 'OBJECT' => 'YamCha_wrap.o'
+ );
+diff -urN perl.orig/Makefile.PL.in perl/Makefile.PL.in
+--- perl.orig/Makefile.PL.in 2004-09-20 18:35:52.000000000 +0900
++++ perl/Makefile.PL.in 2006-11-03 02:36:23.000000000 +0900
+@@ -6,7 +6,7 @@
+ 'LD' => '@CXX@',
+ 'NAME' => 'YamCha',
+ 'VERSION_FROM' => 'YamCha.pm', # finds $VERSION
+- 'INC' => '-I@prefix@/include',
+- 'LIBS' => '-L@prefix@/lib @YAMCHA_LIBS@ -lyamcha',
++ 'INC' => '-I../src -I@prefix@/include',
++ 'LIBS' => '-L../src -L@prefix@/lib @YAMCHA_LIBS@ -lyamcha',
+ 'OBJECT' => 'YamCha_wrap.o'
+ );
diff --git a/app-text/yamcha/yamcha-0.33-r1.ebuild b/app-text/yamcha/yamcha-0.33-r1.ebuild
index f757a2788e71..659de49339ed 100644
--- a/app-text/yamcha/yamcha-0.33-r1.ebuild
+++ b/app-text/yamcha/yamcha-0.33-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/yamcha/yamcha-0.33-r1.ebuild,v 1.1 2006/06/29 19:38:31 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/yamcha/yamcha-0.33-r1.ebuild,v 1.2 2006/11/02 17:52:04 usata Exp $
-inherit perl-module
+inherit perl-module eutils
# inherit distutils
DESCRIPTION="Yet Another Multipurpose CHunk Annotator"
@@ -11,7 +11,7 @@ SRC_URI="http://chasen.org/~taku/software/yamcha/src/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86 ~amd64"
IUSE="perl"
#IUSE="python ruby"
@@ -20,6 +20,12 @@ DEPEND="sci-misc/tinysvm
dev-lang/perl"
#RDEPEND=""
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-pm.patch
+}
+
src_compile() {
econf || die
emake || die