summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-09-24 02:20:17 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-09-24 02:20:17 +0000
commit646bec3c624a11dd440648e3f5ec40f0e055ce52 (patch)
treecfd892a58ce92b767bc7607c72f3cd9498fe1fa3 /app-text
parentVersion bump. (diff)
downloadgentoo-2-646bec3c624a11dd440648e3f5ec40f0e055ce52.tar.gz
gentoo-2-646bec3c624a11dd440648e3f5ec40f0e055ce52.tar.bz2
gentoo-2-646bec3c624a11dd440648e3f5ec40f0e055ce52.zip
Version bumped.
(Portage version: 2.1.3.9)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/omegat/ChangeLog7
-rw-r--r--app-text/omegat/files/digest-omegat-1.7.23
-rw-r--r--app-text/omegat/omegat-1.7.2.ebuild39
3 files changed, 48 insertions, 1 deletions
diff --git a/app-text/omegat/ChangeLog b/app-text/omegat/ChangeLog
index d2830323bcb4..b8b62aa663aa 100644
--- a/app-text/omegat/ChangeLog
+++ b/app-text/omegat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/omegat
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/omegat/ChangeLog,v 1.4 2007/07/22 16:35:17 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/omegat/ChangeLog,v 1.5 2007/09/24 02:20:17 matsuu Exp $
+
+*omegat-1.7.2 (24 Sep 2007)
+
+ 24 Sep 2007; MATSUU Takuto <matsuu@gentoo.org> +omegat-1.7.2.ebuild:
+ Version bumped.
*omegat-1.7.1 (22 Jul 2007)
diff --git a/app-text/omegat/files/digest-omegat-1.7.2 b/app-text/omegat/files/digest-omegat-1.7.2
new file mode 100644
index 000000000000..7e3395ed2f6f
--- /dev/null
+++ b/app-text/omegat/files/digest-omegat-1.7.2
@@ -0,0 +1,3 @@
+MD5 b2ff863a829e9541f633276d0b661c16 OmegaT_1.7.2_Source.zip 3542267
+RMD160 3599733be06b2e08e4281e83f5b55b4c7ec84e3b OmegaT_1.7.2_Source.zip 3542267
+SHA256 d6192cbfa23c1082b835c829ce80dbf65e67eefbfb54f1838ce53c1179f1b33c OmegaT_1.7.2_Source.zip 3542267
diff --git a/app-text/omegat/omegat-1.7.2.ebuild b/app-text/omegat/omegat-1.7.2.ebuild
new file mode 100644
index 000000000000..04ff033c664a
--- /dev/null
+++ b/app-text/omegat/omegat-1.7.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/omegat/omegat-1.7.2.ebuild,v 1.1 2007/09/24 02:20:17 matsuu Exp $
+
+JAVA_PKG_BSFIX_NAME="build.xml build-impl.xml profiler-build-impl.xml"
+inherit eutils java-pkg-2 java-ant-2
+
+MY_PV=${PV/_p/_}
+DESCRIPTION="Open source computer assisted translation (CAT) tool written in Java."
+HOMEPAGE="http://www.omegat.org/"
+SRC_URI="mirror://sourceforge/omegat/OmegaT_${MY_PV}_Source.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}"
+
+src_install() {
+ java-pkg_dojar dist/*.jar
+ dosym /usr/share/doc/${PF}/html "${JAVA_PKG_JARDEST}"/docs
+
+ java-pkg_jarinto "${JAVA_PKG_JARDEST}"/lib
+ java-pkg_dojar dist/lib/*.jar
+
+ java-pkg_dolauncher ${PN} --jar OmegaT.jar
+
+ dodoc release/changes.txt release/readme*.txt
+ dohtml -A properties -r docs/*
+ docinto lib; dodoc lib/*.txt
+
+ doicon images/OmegaT.png
+ make_desktop_entry ${PN} "OmegaT" "OmegaT.png" "Application;Office"
+}