summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2008-01-21 16:01:43 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2008-01-21 16:01:43 +0000
commit4742d826c7e715b41cd112603b1843322af35d0b (patch)
treef698192caeb6f63c73a094706de997532db03d78 /app-text
parentbump to 0.6.3; bug #202507 (diff)
downloadgentoo-2-4742d826c7e715b41cd112603b1843322af35d0b.tar.gz
gentoo-2-4742d826c7e715b41cd112603b1843322af35d0b.tar.bz2
gentoo-2-4742d826c7e715b41cd112603b1843322af35d0b.zip
bump to 0.6.3; bug #202507
(Portage version: 2.1.4)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/poppler-bindings/ChangeLog18
-rw-r--r--app-text/poppler-bindings/files/digest-poppler-bindings-0.6.36
-rw-r--r--app-text/poppler-bindings/poppler-bindings-0.6.3.ebuild76
3 files changed, 98 insertions, 2 deletions
diff --git a/app-text/poppler-bindings/ChangeLog b/app-text/poppler-bindings/ChangeLog
index e7251314f5fe..388e11b5b000 100644
--- a/app-text/poppler-bindings/ChangeLog
+++ b/app-text/poppler-bindings/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for app-text/poppler-bindings
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/ChangeLog,v 1.80 2007/12/05 18:51:18 cardoe Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/ChangeLog,v 1.81 2008/01/21 16:01:42 dang Exp $
+
+*poppler-bindings-0.6.3 (21 Jan 2008)
+
+ 21 Jan 2008; Daniel Gryniewicz <dang@gentoo.org>
+ +poppler-bindings-0.6.3.ebuild:
+ Bump to 0.6.3
+ glib frontend:
+ * Make sure passwords are passed correctly to poppler core
+
+ Qt frontend:
+ * Fix crash on documents that specify an empty date
+
+ build system:
+ * Disable gtk tests if the user disabled glib frontend
05 Dec 2007; Doug Klima <cardoe@gentoo.org> poppler-bindings-0.6.1.ebuild,
poppler-bindings-0.6.2.ebuild:
diff --git a/app-text/poppler-bindings/files/digest-poppler-bindings-0.6.3 b/app-text/poppler-bindings/files/digest-poppler-bindings-0.6.3
new file mode 100644
index 000000000000..8142ce2b9c33
--- /dev/null
+++ b/app-text/poppler-bindings/files/digest-poppler-bindings-0.6.3
@@ -0,0 +1,6 @@
+MD5 a585677188cd56a090c4dc3357e03a95 poppler-0.6.3.tar.gz 1292971
+RMD160 f2971c6c5f717ec529b76e593f2c2a09ce81e53e poppler-0.6.3.tar.gz 1292971
+SHA256 32112064cb310933ea820b8ca3fd64bcfa951243901aca9b6a0a11994d19a66e poppler-0.6.3.tar.gz 1292971
+MD5 36786c8ea5204b19a5c6d97dd90889e9 poppler-test-0.6.1.tar.gz 1607711
+RMD160 611099f130ae9c00dead6c603dd224282109c2d9 poppler-test-0.6.1.tar.gz 1607711
+SHA256 d629504772b4df3bfa7e6ce149f901370135b2d27e32ca4961e4ab8fc7039f88 poppler-test-0.6.1.tar.gz 1607711
diff --git a/app-text/poppler-bindings/poppler-bindings-0.6.3.ebuild b/app-text/poppler-bindings/poppler-bindings-0.6.3.ebuild
new file mode 100644
index 000000000000..3c163ec305cd
--- /dev/null
+++ b/app-text/poppler-bindings/poppler-bindings-0.6.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.6.3.ebuild,v 1.1 2008/01/21 16:01:42 dang Exp $
+
+inherit autotools eutils multilib
+
+MY_P=${P/-bindings/}
+DESCRIPTION="rendering bindings for GUI toolkits for poppler"
+HOMEPAGE="http://poppler.freedesktop.org/"
+
+# Creating the testsuite tarball (must be done for every release)
+#
+# cvs -d :pserver:anoncvs@cvs.freedesktop.org:/cvs/poppler login
+# cvs -d :pserver:anoncvs@cvs.freedesktop.org:/cvs/poppler co test
+# tar czf poppler-test-${PV}.tar.gz
+# upload to d.g.o/space/distfiles-local
+
+SRC_URI="http://poppler.freedesktop.org/${MY_P}.tar.gz
+ test? ( mirror://gentoo/poppler-test-0.6.1.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk qt3 cairo qt4 test"
+
+RDEPEND="~app-text/poppler-${PV}
+ cairo? ( >=x11-libs/cairo-1.4 )
+ gtk? (
+ >=x11-libs/gtk+-2.8
+ >=gnome-base/libglade-2
+ )
+ qt3? ( =x11-libs/qt-3* )
+ qt4? ( =x11-libs/qt-4* )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack(){
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/poppler-0.6-bindings.patch
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ # Configure needs help finding qt libs on multilib systems
+ export QTLIB="${QTDIR}/$(get_libdir)"
+ echo $QTLIB
+
+ econf --enable-opi \
+ $(use_enable cairo cairo-output) \
+ $(use_enable gtk poppler-glib) \
+ $(use_enable qt3 poppler-qt) \
+ $(use_enable qt4 poppler-qt4) \
+ || die "configuration failed"
+ cd poppler
+ if use cairo; then
+ emake libpoppler-cairo.la || die "cairo failed"
+ fi
+ if use qt4; then
+ emake libpoppler-arthur.la || die "arthur failed"
+ fi
+ cd ..
+ emake || die "compilation failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ ewarn "You need to rebuild everything depending on poppler, use revdep-rebuild"
+}