summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-05-14 18:08:48 +0000
committerHans de Graaff <graaff@gentoo.org>2014-05-14 18:08:48 +0000
commit358b466b13ab732b9a3408cc511d38b00212ec93 (patch)
tree04a058ed6332c354c15b0ec083b4869197a6ea07 /app-text
parentRemove old (diff)
downloadgentoo-2-358b466b13ab732b9a3408cc511d38b00212ec93.tar.gz
gentoo-2-358b466b13ab732b9a3408cc511d38b00212ec93.tar.bz2
gentoo-2-358b466b13ab732b9a3408cc511d38b00212ec93.zip
Add ruby21 revision to create new stable candidate.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/ronn/ChangeLog8
-rw-r--r--app-text/ronn/ronn-0.7.3-r2.ebuild4
-rw-r--r--app-text/ronn/ronn-0.7.3-r3.ebuild46
3 files changed, 55 insertions, 3 deletions
diff --git a/app-text/ronn/ChangeLog b/app-text/ronn/ChangeLog
index 4a3ef37d3d84..4487bf8452f3 100644
--- a/app-text/ronn/ChangeLog
+++ b/app-text/ronn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/ronn
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ronn/ChangeLog,v 1.24 2014/04/20 07:03:33 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ronn/ChangeLog,v 1.25 2014/05/14 18:08:48 graaff Exp $
+
+*ronn-0.7.3-r3 (14 May 2014)
+
+ 14 May 2014; Hans de Graaff <graaff@gentoo.org> ronn-0.7.3-r2.ebuild,
+ +ronn-0.7.3-r3.ebuild:
+ Add ruby21 revision to create new stable candidate.
20 Apr 2014; Hans de Graaff <graaff@gentoo.org> ronn-0.7.3-r2.ebuild:
Add ruby21.
diff --git a/app-text/ronn/ronn-0.7.3-r2.ebuild b/app-text/ronn/ronn-0.7.3-r2.ebuild
index d033e23b589b..8e4b107f4007 100644
--- a/app-text/ronn/ronn-0.7.3-r2.ebuild
+++ b/app-text/ronn/ronn-0.7.3-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ronn/ronn-0.7.3-r2.ebuild,v 1.4 2014/04/20 07:03:33 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ronn/ronn-0.7.3-r2.ebuild,v 1.5 2014/05/14 18:08:48 graaff Exp $
EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21"
+USE_RUBY="ruby19 ruby20"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="AUTHORS CHANGES README.md"
diff --git a/app-text/ronn/ronn-0.7.3-r3.ebuild b/app-text/ronn/ronn-0.7.3-r3.ebuild
new file mode 100644
index 000000000000..725f2ff01f06
--- /dev/null
+++ b/app-text/ronn/ronn-0.7.3-r3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/ronn/ronn-0.7.3-r3.ebuild,v 1.1 2014/05/14 18:08:48 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="AUTHORS CHANGES README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ronn converts simple, human readable textfiles to roff for terminal display, and also to HTML."
+HOMEPAGE="http://github.com/rtomayko/ronn/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/hpricot-0.8.2
+ >=dev-ruby/mustache-0.7.0
+ >=dev-ruby/rdiscount-1.5.8"
+
+all_ruby_prepare() {
+ # Avoid test failing due to changes in hash handling in ruby 1.8.7:
+ # https://github.com/rtomayko/ronn/issues/56
+ sed -i -e '81 s:^:#:' test/test_ronn.rb || die
+}
+
+each_ruby_prepare() {
+ # Make sure that we always use the right interpreter during tests.
+ sed -i -e "/output/ s:ronn:${RUBY} bin/ronn:" test/test_ronn.rb
+}
+
+all_ruby_compile() {
+ PATH="${S}/bin:${PATH}" rake man || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/ronn.1 man/ronn-format.7
+}