summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-10-17 19:25:13 +0000
committerPacho Ramos <pacho@gentoo.org>2010-10-17 19:25:13 +0000
commit1fa0db1fffde4f6a6cbbe9097099b8fa75d70716 (patch)
tree11d288f46fc3ebaaed294cfba9dd65b9f1c0cd44 /app-text
parentchange allow_url_fopen back to Off (bug #332763) (diff)
downloadgentoo-2-1fa0db1fffde4f6a6cbbe9097099b8fa75d70716.tar.gz
gentoo-2-1fa0db1fffde4f6a6cbbe9097099b8fa75d70716.tar.bz2
gentoo-2-1fa0db1fffde4f6a6cbbe9097099b8fa75d70716.zip
Version bump for Gnome 2.32
(Portage version: 2.1.9.19/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/evince/ChangeLog13
-rw-r--r--app-text/evince/evince-2.32.0.ebuild103
-rw-r--r--app-text/evince/metadata.xml2
3 files changed, 117 insertions, 1 deletions
diff --git a/app-text/evince/ChangeLog b/app-text/evince/ChangeLog
index 97ccb14fbbc6..dd19e1b96c55 100644
--- a/app-text/evince/ChangeLog
+++ b/app-text/evince/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for app-text/evince
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/evince/ChangeLog,v 1.202 2010/10/17 15:28:24 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/ChangeLog,v 1.203 2010/10/17 19:25:13 pacho Exp $
+
+*evince-2.32.0 (17 Oct 2010)
+
+ 17 Oct 2010; Pacho Ramos <pacho@gentoo.org> +evince-2.32.0.ebuild:
+ Version bump for Gnome 2.32: Make Shrink to Printable Area default option
+ for Page Scaling, preliminary support for adding new annotations, add
+ confirmation dialog on closing window when document has been modified, add
+ an action to edit menu to save current settings as default, add a new
+ sidebar page to show the list of annotations, finish DBus API for synctex
+ support, use cairo to draw search results, other bugfixes and translation
+ updates.
17 Oct 2010; Raúl Porcel <armin76@gentoo.org> evince-2.30.3.ebuild:
alpha/ia64/sparc stable wrt #324077
diff --git a/app-text/evince/evince-2.32.0.ebuild b/app-text/evince/evince-2.32.0.ebuild
new file mode 100644
index 000000000000..24dc56923ab5
--- /dev/null
+++ b/app-text/evince/evince-2.32.0.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/evince-2.32.0.ebuild,v 1.1 2010/10/17 19:25:13 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="Simple document viewer for GNOME"
+HOMEPAGE="http://www.gnome.org/projects/evince/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris"
+
+IUSE="dbus debug djvu doc dvi gnome gnome-keyring +introspection nautilus t1lib tiff"
+
+# Since 2.26.2, can handle poppler without cairo support. Make it optional ?
+# not mature enough
+RDEPEND="
+ >=app-text/libspectre-0.2.0
+ >=dev-libs/glib-2.25.11:2
+ >=dev-libs/libxml2-2.5
+ >=x11-libs/gtk+-2.21.5:2[introspection?]
+ >=x11-libs/libSM-1
+ || (
+ >=x11-themes/gnome-icon-theme-2.17.1
+ >=x11-themes/hicolor-icon-theme-0.10 )
+ >=x11-libs/cairo-1.9.10
+ >=app-text/poppler-0.14[cairo]
+ djvu? ( >=app-text/djvu-3.5.17 )
+ dvi? (
+ virtual/tex-base
+ t1lib? ( >=media-libs/t1lib-5.0.0 ) )
+ gnome? ( >=gnome-base/gconf-2[introspection?] )
+ gnome-keyring? ( >=gnome-base/gnome-keyring-2.22.0 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6 )
+ nautilus? ( >=gnome-base/nautilus-2.10[introspection?] )
+ tiff? ( >=media-libs/tiff-3.6 )
+"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=app-text/gnome-doc-utils-0.3.2
+ ~app-text/docbook-xml-dtd-4.1.2
+ >=dev-util/pkgconfig-0.9
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=dev-util/gtk-doc-am-1.13
+ doc? ( >=dev-util/gtk-doc-1.13 )"
+
+ELTCONF="--portage"
+
+# Needs dogtail and pyspi from http://fedorahosted.org/dogtail/
+# Releases: http://people.redhat.com/zcerza/dogtail/releases/
+RESTRICT="test"
+
+pkg_setup() {
+ # Passing --disable-help would drop offline help, that would be inconsistent
+ # with helps of the most of Gnome apps that doesn't require network for that.
+ G2CONF="${G2CONF}
+ --disable-scrollkeeper
+ --disable-static
+ --disable-tests
+ --enable-pdf
+ --enable-comics
+ --enable-impress
+ --enable-thumbnailer
+ --with-smclient=xsmp
+ --with-platform=gnome
+ --with-gtk=2.0
+ --enable-help
+ --disable-maintainer-mode
+ $(use_enable dbus)
+ $(use_enable djvu)
+ $(use_enable dvi)
+ $(use_with gnome gconf)
+ $(use_with gnome-keyring keyring)
+ $(use_enable introspection)
+ $(use_enable nautilus)
+ $(use_enable t1lib)
+ $(use_enable tiff)"
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in \
+ || die "intltoolize sed failed"
+
+ # Do not depend on gnome-icon-theme, bug #326855
+ sed 's/gnome-icon-theme//' -i configure.ac configure || die "sed failed"
+
+ # Fix .desktop file so menu item shows up
+ epatch "${FILESDIR}"/${PN}-0.7.1-display-menu.patch
+}
+
+src_install() {
+ gnome2_src_install
+ find "${ED}" -name "*.la" -delete || die "remove of lafiles failed"
+}
diff --git a/app-text/evince/metadata.xml b/app-text/evince/metadata.xml
index f0dad078cf9b..624d962f12ef 100644
--- a/app-text/evince/metadata.xml
+++ b/app-text/evince/metadata.xml
@@ -9,6 +9,8 @@
<flag name='gnome'>Enable the use of <pkg>gnome-base/gconf</pkg> to honour
lockdown settings</flag>
<flag name='dvi'>Enable the built-in DVI viewer</flag>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
+ for introspection</flag>
<flag name='nautilus'>Enable property page extension in <pkg>gnome-base/nautilus</pkg></flag>
<flag name='t1lib'>Enable the Type-1 fonts for the built-in DVI viewer
(<pkg>media-libs/t1lib</pkg>)</flag>