summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-11-02 20:12:45 +0000
committerJeroen Roovers <jer@gentoo.org>2010-11-02 20:12:45 +0000
commit02529e025e7c2af4cade9ad4d48f0b800c1ed082 (patch)
tree236c0a92744c4c5f0cb751d5964e841b8b7b8972 /app-text
parentLastrite acer_acpi and acerhk. (diff)
downloadgentoo-2-02529e025e7c2af4cade9ad4d48f0b800c1ed082.tar.gz
gentoo-2-02529e025e7c2af4cade9ad4d48f0b800c1ed082.tar.bz2
gentoo-2-02529e025e7c2af4cade9ad4d48f0b800c1ed082.zip
Add patch by Ulrich Müller for bug #306445 by Hartmut Figge.
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/pinfo/ChangeLog8
-rw-r--r--app-text/pinfo/files/pinfo-0.6.10-info-suffix.patch28
-rw-r--r--app-text/pinfo/pinfo-0.6.10-r1.ebuild44
3 files changed, 79 insertions, 1 deletions
diff --git a/app-text/pinfo/ChangeLog b/app-text/pinfo/ChangeLog
index 2551c6f17269..1327a444468a 100644
--- a/app-text/pinfo/ChangeLog
+++ b/app-text/pinfo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/pinfo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pinfo/ChangeLog,v 1.48 2010/10/19 20:02:38 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pinfo/ChangeLog,v 1.49 2010/11/02 20:12:45 jer Exp $
+
+*pinfo-0.6.10-r1 (02 Nov 2010)
+
+ 02 Nov 2010; Jeroen Roovers <jer@gentoo.org> +pinfo-0.6.10-r1.ebuild,
+ +files/pinfo-0.6.10-info-suffix.patch:
+ Add patch by Ulrich Müller for bug #306445 by Hartmut Figge.
19 Oct 2010; Markos Chandras <hwoarang@gentoo.org> pinfo-0.6.9-r1.ebuild:
Stable on amd64 wrt bug #339957
diff --git a/app-text/pinfo/files/pinfo-0.6.10-info-suffix.patch b/app-text/pinfo/files/pinfo-0.6.10-info-suffix.patch
new file mode 100644
index 000000000000..45be53cd1bf6
--- /dev/null
+++ b/app-text/pinfo/files/pinfo-0.6.10-info-suffix.patch
@@ -0,0 +1,28 @@
+--- a/src/filehandling_functions.c
++++ b/src/filehandling_functions.c
+@@ -96,11 +96,14 @@ matchfile(char **buf, char *name)
+ {
+ /* use strcat rather than strdup, because xmalloc handles all
+ * malloc errors */
+- char *thisfile = xmalloc(strlen(dp->d_name)+1);
++ int len = strlen(dp->d_name)+1;
++ char *thisfile = xmalloc(len * 2);
++ char *thisfile_info = thisfile + len;
+ strcat(thisfile, dp->d_name);
+
+ /* strip suffixes (so "gcc.info.gz" -> "gcc") */
+ strip_compression_suffix(thisfile);
++ strcat(thisfile_info, thisfile);
+ strip_info_suffix(thisfile);
+
+ /* compare this file with the file we're looking for */
+@@ -109,8 +112,7 @@ matchfile(char **buf, char *name)
+ /* we found a match! */
+ matched++;
+ /* put it in the buffer */
+- strncat(Buf, thisfile, 1023-strlen(Buf));
+- strncat(Buf, ".info", 1023-strlen(Buf));
++ strncat(Buf, thisfile_info, 1023-strlen(Buf));
+
+ /* clean up, and exit the loop */
+ xfree(thisfile);
diff --git a/app-text/pinfo/pinfo-0.6.10-r1.ebuild b/app-text/pinfo/pinfo-0.6.10-r1.ebuild
new file mode 100644
index 000000000000..f94ebe4782e3
--- /dev/null
+++ b/app-text/pinfo/pinfo-0.6.10-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pinfo/pinfo-0.6.10-r1.ebuild,v 1.1 2010/11/02 20:12:45 jer Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Hypertext info and man viewer based on (n)curses"
+HOMEPAGE="http://pinfo.alioth.debian.org/"
+SRC_URI="https://alioth.debian.org/frs/download.php/3351/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="nls readline"
+
+RDEPEND="sys-libs/ncurses
+ nls? ( virtual/libintl )"
+
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.6.9-as-needed.patch \
+ "${FILESDIR}"/${PN}-0.6.9-GROFF_NO_SGR.patch \
+ "${FILESDIR}"/${PN}-0.6.9-lzma-xz.patch \
+ "${FILESDIR}"/${P}-version.patch \
+ "${FILESDIR}"/${P}-info-suffix.patch
+ ./autogen.sh || die "autogen"
+}
+
+src_configure() {
+ econf \
+ $(use_with readline) \
+ $(use_enable nls) \
+ || die "econf failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" sysconfdir=/etc install || die
+}