summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-03-26 12:48:13 +0000
committerFabian Groffen <grobian@gentoo.org>2011-03-26 12:48:13 +0000
commitbc373927322ff0fc8e8b6ae9f7d0b29b4f4a5f9d (patch)
treeb00166ba177ca1557303542543d1fdc66101cad6 /app-text/xmlstarlet
parentBump for #360525 (diff)
downloadgentoo-2-bc373927322ff0fc8e8b6ae9f7d0b29b4f4a5f9d.tar.gz
gentoo-2-bc373927322ff0fc8e8b6ae9f7d0b29b4f4a5f9d.tar.bz2
gentoo-2-bc373927322ff0fc8e8b6ae9f7d0b29b4f4a5f9d.zip
Add patch from upstream to fix compilation on Darwin, BSD and possibly Solaris systems
(Portage version: 2.2.01.18125-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'app-text/xmlstarlet')
-rw-r--r--app-text/xmlstarlet/ChangeLog7
-rw-r--r--app-text/xmlstarlet/files/xmlstarlet-1.0.6-setmode.patch50
-rw-r--r--app-text/xmlstarlet/xmlstarlet-1.0.6.ebuild9
3 files changed, 64 insertions, 2 deletions
diff --git a/app-text/xmlstarlet/ChangeLog b/app-text/xmlstarlet/ChangeLog
index 31df37c50058..9cd846ef3650 100644
--- a/app-text/xmlstarlet/ChangeLog
+++ b/app-text/xmlstarlet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/xmlstarlet
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xmlstarlet/ChangeLog,v 1.23 2011/03/15 17:31:27 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xmlstarlet/ChangeLog,v 1.24 2011/03/26 12:48:13 grobian Exp $
+
+ 26 Mar 2011; Fabian Groffen <grobian@gentoo.org> xmlstarlet-1.0.6.ebuild,
+ +files/xmlstarlet-1.0.6-setmode.patch:
+ Add patch from upstream to fix compilation on Darwin, BSD and possibly
+ Solaris systems
*xmlstarlet-1.0.6 (15 Mar 2011)
diff --git a/app-text/xmlstarlet/files/xmlstarlet-1.0.6-setmode.patch b/app-text/xmlstarlet/files/xmlstarlet-1.0.6-setmode.patch
new file mode 100644
index 000000000000..034b732dbd29
--- /dev/null
+++ b/app-text/xmlstarlet/files/xmlstarlet-1.0.6-setmode.patch
@@ -0,0 +1,50 @@
+http://sourceforge.net/tracker/?func=detail&aid=3211822&group_id=66612&atid=515106
+http://xmlstar.git.sourceforge.net/git/gitweb.cgi?p=xmlstar/xmlstar;a=patch;h=5f2445dac0e2a255d89240ec919ecd753045cce5;hp=d0f9902aedc75cef168aa1a34593bc5b74e9669c
+
+
+From 5f2445dac0e2a255d89240ec919ecd753045cce5 Mon Sep 17 00:00:00 2001
+From: Noam Postavsky <npostavs@users.sourceforge.net>
+Date: Mon, 14 Mar 2011 18:13:37 -0400
+Subject: [PATCH 1/1] check that O_BINARY is declared before #include'ing io.h
+
+---
+ configure.ac | 3 ++-
+ src/xml_C14N.c | 6 +++---
+ 2 files changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index b9eb53d..5b2d3bc 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -109,7 +109,8 @@ AS_IF([test "x$STATIC_LIBS" != xno],
+
+ AC_CHECK_FUNCS_ONCE([lstat stat])
+
+-AC_CHECK_DECL([O_BINARY], [], [], [[
++AC_CHECK_DECL([O_BINARY], [AC_DEFINE([HAVE_DECL_O_BINARY],1,[have O_BINARY])],
++[AC_DEFINE([HAVE_DECL_O_BINARY],0,[don't have O_BINARY])], [[
+ #include <io.h>
+ #include <fcntl.h>
+ ]])
+diff --git a/src/xml_C14N.c b/src/xml_C14N.c
+index 3ef1a7c..115e2ce 100644
+--- a/src/xml_C14N.c
++++ b/src/xml_C14N.c
+@@ -20,11 +20,11 @@
+ #include <stdlib.h>
+ #endif
+
+-#if !HAVE_SETMODE
+-# define setmode(fd, mode)
+-#else
++#if HAVE_SETMODE && HAVE_DECL_O_BINARY
+ # include <io.h>
+ # include <fcntl.h>
++#else
++# define setmode(fd, mode)
+ #endif
+
+ #include <libxml/xmlmemory.h>
+--
+1.7.0.1
+
diff --git a/app-text/xmlstarlet/xmlstarlet-1.0.6.ebuild b/app-text/xmlstarlet/xmlstarlet-1.0.6.ebuild
index d9ce7a8c58d9..91e6e0fb12f2 100644
--- a/app-text/xmlstarlet/xmlstarlet-1.0.6.ebuild
+++ b/app-text/xmlstarlet/xmlstarlet-1.0.6.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xmlstarlet/xmlstarlet-1.0.6.ebuild,v 1.1 2011/03/15 17:31:27 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xmlstarlet/xmlstarlet-1.0.6.ebuild,v 1.2 2011/03/26 12:48:13 grobian Exp $
EAPI="2"
+inherit eutils autotools
+
DESCRIPTION="A set of tools to transform, query, validate, and edit XML documents"
HOMEPAGE="http://xmlstar.sourceforge.net/"
SRC_URI="mirror://sourceforge/xmlstar/${P}.tar.gz"
@@ -22,6 +24,11 @@ DEPEND="${RDEPEND}
sys-apps/sed
dev-util/pkgconfig"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-setmode.patch
+ eautoreconf
+}
+
src_configure() {
econf --disable-static-libs
}