summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-07-17 07:24:13 +0000
committerHans de Graaff <graaff@gentoo.org>2010-07-17 07:24:13 +0000
commitb81d770ba29dbae7e38d9bb692c1d8645b6e5090 (patch)
treeedf068c12d63dd5059586f2b813949e22a0a0044 /app-text/webgen
parentstable on amd64 & x86 (diff)
downloadgentoo-2-b81d770ba29dbae7e38d9bb692c1d8645b6e5090.tar.gz
gentoo-2-b81d770ba29dbae7e38d9bb692c1d8645b6e5090.tar.bz2
gentoo-2-b81d770ba29dbae7e38d9bb692c1d8645b6e5090.zip
Version bump. This version is not a drop-in replacement for the 0.4.x series. Convert to ruby-fakegem.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-text/webgen')
-rw-r--r--app-text/webgen/ChangeLog10
-rw-r--r--app-text/webgen/webgen-0.5.13.ebuild41
2 files changed, 49 insertions, 2 deletions
diff --git a/app-text/webgen/ChangeLog b/app-text/webgen/ChangeLog
index 32f5964ee331..c6a0172b1431 100644
--- a/app-text/webgen/ChangeLog
+++ b/app-text/webgen/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/webgen
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/webgen/ChangeLog,v 1.9 2008/12/26 14:32:48 graaff Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/webgen/ChangeLog,v 1.10 2010/07/17 07:24:13 graaff Exp $
+
+*webgen-0.5.13 (17 Jul 2010)
+
+ 17 Jul 2010; Hans de Graaff <graaff@gentoo.org> +webgen-0.5.13.ebuild:
+ Version bump. This version is not a drop-in replacement for the 0.4.x
+ series. Convert to ruby-fakegem.
26 Dec 2008; Hans de Graaff <graaff@gentoo.org> -webgen-0.4.2.ebuild,
-webgen-0.4.6.ebuild:
diff --git a/app-text/webgen/webgen-0.5.13.ebuild b/app-text/webgen/webgen-0.5.13.ebuild
new file mode 100644
index 000000000000..137e2ad6d96d
--- /dev/null
+++ b/app-text/webgen/webgen-0.5.13.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/webgen/webgen-0.5.13.ebuild,v 1.1 2010/07/17 07:24:13 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_DOCDIR="htmldoc/rdoc"
+RUBY_FAKEGEM_EXTRADOC="AUTHORS ChangeLog THANKS"
+RUBY_FAKEGEM_EXTRAINSTALL="data misc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A template-based static website generator."
+HOMEPAGE="http://webgen.rubyforge.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="builder highlight markdown"
+
+# Some tests are broken now, partly due to missing dependencies that
+# are optional for the package as a whole. Other broken tests have
+# been reported upstream:
+# http://rubyforge.org/tracker/index.php?func=detail&aid=28392&group_id=296&atid=1207
+# http://rubyforge.org/tracker/index.php?func=detail&aid=28393&group_id=296&atid=1207
+RESTRICT="test"
+
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+ruby_add_rdepend ">=dev-ruby/cmdparse-2.0.0
+ >=dev-ruby/redcloth-4.1.9
+ builder? ( >=dev-ruby/builder-2.1.0 )
+ highlight? ( >=dev-ruby/coderay-0.8.312 )
+ markdown? ( dev-ruby/maruku )"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/man1/webgen.1 || die
+}