summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-04-19 03:32:27 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-04-19 03:32:27 +0000
commit24ca9a55d4332150c22e78133c1944f6006e29ae (patch)
tree4da20f22f6a443af47528b727215f583011d9513 /app-text/tofrodos/tofrodos-1.7.12a.ebuild
parentVersion bump. (diff)
downloadgentoo-2-24ca9a55d4332150c22e78133c1944f6006e29ae.tar.gz
gentoo-2-24ca9a55d4332150c22e78133c1944f6006e29ae.tar.bz2
gentoo-2-24ca9a55d4332150c22e78133c1944f6006e29ae.zip
Bump for #466400
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-text/tofrodos/tofrodos-1.7.12a.ebuild')
-rw-r--r--app-text/tofrodos/tofrodos-1.7.12a.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-text/tofrodos/tofrodos-1.7.12a.ebuild b/app-text/tofrodos/tofrodos-1.7.12a.ebuild
new file mode 100644
index 000000000000..336203c027f6
--- /dev/null
+++ b/app-text/tofrodos/tofrodos-1.7.12a.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/tofrodos/tofrodos-1.7.12a.ebuild,v 1.1 2013/04/19 03:32:27 patrick Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="text file conversion utility that converts ASCII files between the
+MSDOS format and the Unix format"
+HOMEPAGE="http://tofrodos.sourceforge.net/"
+SRC_URI="http://tofrodos.sourceforge.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}/src"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.7.8-CFLAGS.patch
+}
+
+src_compile() {
+ emake DEBUG=1 CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin fromdos
+ dosym fromdos /usr/bin/todos
+ doman fromdos.1
+}