summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-02-03 07:54:24 +0000
committerPeter Volkov <pva@gentoo.org>2010-02-03 07:54:24 +0000
commite762210aab7aa44d71f98a0b7c04a40286b59bcf (patch)
tree228e60e05f802072e6bcb4e71f533c45cf2f542a /app-text/stardict/files
parentAdded dep on dev-libs/libsigc++, bug 275122, thank Rafał Mużyło for report. (diff)
downloadgentoo-2-e762210aab7aa44d71f98a0b7c04a40286b59bcf.tar.gz
gentoo-2-e762210aab7aa44d71f98a0b7c04a40286b59bcf.tar.bz2
gentoo-2-e762210aab7aa44d71f98a0b7c04a40286b59bcf.zip
Moved from app-dicts/stardict, bug #289475, thank Ihar Hrachyshka for report.
(Portage version: 2.2_rc61/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'app-text/stardict/files')
-rw-r--r--app-text/stardict/files/stardict-2.4.8-ClipboardReceivedCallback.patch20
-rw-r--r--app-text/stardict/files/stardict-2.4.8-floatwin-disappear.patch13
-rw-r--r--app-text/stardict/files/stardict-3.0.1-changelog-minor-typo-fixes.patch63
-rw-r--r--app-text/stardict/files/stardict-3.0.1-configure.in-EST.diff11
-rw-r--r--app-text/stardict/files/stardict-3.0.1-gcc43.patch406
-rw-r--r--app-text/stardict/files/stardict-3.0.1-gcc44.patch22
-rw-r--r--app-text/stardict/files/stardict-3.0.1-gconf-m4.diff43
-rw-r--r--app-text/stardict/files/stardict-3.0.1-gucharmap2.patch46
-rw-r--r--app-text/stardict/files/stardict-3.0.1-transparent_trayicon.patch168
9 files changed, 792 insertions, 0 deletions
diff --git a/app-text/stardict/files/stardict-2.4.8-ClipboardReceivedCallback.patch b/app-text/stardict/files/stardict-2.4.8-ClipboardReceivedCallback.patch
new file mode 100644
index 000000000000..630da35e83ff
--- /dev/null
+++ b/app-text/stardict/files/stardict-2.4.8-ClipboardReceivedCallback.patch
@@ -0,0 +1,20 @@
+--- trunk/src/mainwin.h 2006/08/08 12:44:42 1
++++ trunk/src/mainwin.h 2006/08/09 19:00:35 2
+@@ -68,8 +68,6 @@
+ static void on_main_menu_about_activate(GtkMenuItem *menuitem, TopWin *oTopWin);
+ static void on_main_menu_quit_activate(GtkMenuItem *menuitem, TopWin *oTopWin);
+
+- static void ClipboardReceivedCallback(GtkClipboard *clipboard, const gchar *text, gpointer data);
+-
+ void LoadHistory(void);
+ void SaveHistory(void);
+ public:
+@@ -97,7 +95,7 @@
+ bool HasFocus() {
+ return GTK_WIDGET_HAS_FOCUS(GTK_COMBO(WordCombo)->entry);
+ }
+-
++ static void ClipboardReceivedCallback(GtkClipboard *clipboard, const gchar *text, gpointer data);
+ };
+
+ class ListWin
diff --git a/app-text/stardict/files/stardict-2.4.8-floatwin-disappear.patch b/app-text/stardict/files/stardict-2.4.8-floatwin-disappear.patch
new file mode 100644
index 000000000000..44f92ee9884a
--- /dev/null
+++ b/app-text/stardict/files/stardict-2.4.8-floatwin-disappear.patch
@@ -0,0 +1,13 @@
+Index: stardict-2.4.8/src/floatwin.cpp
+===================================================================
+--- stardict-2.4.8.orig/src/floatwin.cpp
++++ stardict-2.4.8/src/floatwin.cpp
+@@ -788,7 +788,7 @@ gboolean FloatWin::vButtonReleaseCallbac
+
+ gboolean FloatWin::vMotionNotifyCallback (GtkWidget * widget, GdkEventMotion * event , FloatWin *oFloatWin)
+ {
+- if (event->window == oFloatWin->FloatWindow->window || (event->state & GDK_BUTTON1_MASK))
++ if (event->state & GDK_BUTTON1_MASK)
+ {
+ gint x,y;
+ x = oFloatWin->press_window_x + (gint)(event->x_root) - oFloatWin->press_x_root;
diff --git a/app-text/stardict/files/stardict-3.0.1-changelog-minor-typo-fixes.patch b/app-text/stardict/files/stardict-3.0.1-changelog-minor-typo-fixes.patch
new file mode 100644
index 000000000000..bd7248a36c48
--- /dev/null
+++ b/app-text/stardict/files/stardict-3.0.1-changelog-minor-typo-fixes.patch
@@ -0,0 +1,63 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 04_changelog-minor-typo-fixes.dpatch by Anthony Fok <foka@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Minor typo fixes to upstream ChangeLog.
+
+@DPATCH@
+
+--- stardict-3.0.1.orig/ChangeLog
++++ stardict-3.0.1/ChangeLog
+@@ -12,7 +12,7 @@
+
+ 2007.8.13
+ StarDict-3.0.0 (RedHat) released.
+-http://www.StarDict.org on-line dictionries website is out in 2006.9.25. We have developed the stardictd dictionary server for it.
++http://www.StarDict.org on-line dictionaries website is out in 2006.9.25. We have developed the stardictd dictionary server for it.
+ StarDict's total download count reached two millions in 2007.3.8.
+ Network dictionaries support.
+ Plugin system.
+@@ -38,14 +38,14 @@
+ KingSoft PowerWord support. This added 158 dictionaries. The data is cracked by Dwing(http://free5.ys168.com/?dwing).
+ Synonym support.
+ Sort word list by collate function support.
+-XDXF project(http://xdxf.sourceforge.net) has port its dictionaries to StarDict format, some dictionries are come from Sdictionary. This added 615 dictionries.
++XDXF project (http://xdxf.sourceforge.net) has port its dictionaries to StarDict format, some dictionaries are come from Sdictionary. This added 615 dictionaries.
+ French translation, thanks Christophe Durville <cdurpp@ifrance.com>.
+ Brazilian Portuguese translation, thanks Ernesto <ernesto_mor@yahoo.com.ar>.
+ Add cfdict dictionary, thanks Gilles Vigner <xiaogil@yahoo.fr>.
+ Add English-Thai Lexitron Dictionary and Thai-English Lexitron Dictionary, thanks Suphanut Thanyaboon <suphanut@tcllab.org>.
+ Add many Japanese dictionaries.
+ Add some Chinese dictionaries, data comes from KDic.
+-Add two Germany dictionries: ldaf, xindehan.
++Add two Germany dictionaries: ldaf, xindehan.
+ Add duden Germany dictionary, thanks Liu Guizhu <zhuzi813@gmail.com> for providing data file.
+ Add fundset dictionary, thanks Lin Fanshun <fundset@hotmail.com> for providing data file.
+ Add DrEye4in1 dictionary, thanks Lilian <fairyland@gmail.com> for providing data file.
+@@ -54,7 +54,7 @@
+
+ 2006.4.18
+ StarDict-2.4.7 (complete) released.
+-Port to GPE(http://gpe.handhelds.org).
++Port to GPE (http://gpe.handhelds.org).
+ Full-text search.
+ Acrobat plug-in in Win32, thanks Dewolf Xue <dewolf_matri_x@msn.com>.
+ Evgeniy's patches for special character search and other changes.
+@@ -94,14 +94,14 @@
+
+ 2005.7.20
+ StarDict-2.4.5 (final) released.
+-Source code optimize and many changes, thanks Evgeney <dushistov@mail.ru>.
++Source code optimize and many changes, thanks Evgeniy <dushistov@mail.ru>.
+ Dutch translation and help document translation, thanks Ruud Slaats <ruudslaats@eurotechgroup.nl>.
+
+ 2004.11.28
+ StarDict-2.4.4 (fine) released.
+-sdcv-0.1(StarDict command line version) is out, developed by Evgeney <dushistov@mail.ru>.
++sdcv-0.1(StarDict command line version) is out, developed by Evgeniy <dushistov@mail.ru>.
+ Try to create .idx.oft file to speed up the interpretation of the .idx file. This feature is especially useful to sdcv.
+-Mueller7 optimized, thanks Evgeney.
++Mueller7 optimized, thanks Evgeniy.
+ quick_eng-gre, quick_gre-eng dictionary encoding fix, thanks Christophe Combelles <ccomb@free.fr> for bug reporting.
+ Add Hanzi Master dictionary, thanks Michael Robinson <robinson@netrinsics.com>.
+ zh_TW help document translation and a small bug fix, thanks Roy Chan <roy.chan@debian.org.hk>.
diff --git a/app-text/stardict/files/stardict-3.0.1-configure.in-EST.diff b/app-text/stardict/files/stardict-3.0.1-configure.in-EST.diff
new file mode 100644
index 000000000000..286da76daffd
--- /dev/null
+++ b/app-text/stardict/files/stardict-3.0.1-configure.in-EST.diff
@@ -0,0 +1,11 @@
+--- configure.in.orig 2007-08-13 20:44:31.000000000 +0800
++++ configure.in 2007-08-13 22:12:33.000000000 +0800
+@@ -131,7 +131,7 @@
+ else
+ AC_MSG_RESULT(yes)
+ FESTIVAL_LIBS="-lFestival -lestools -lestbase -leststring"
+- FESTIVAL_CFLAGS="-I/usr/include/speech-tools/EST -ffriend-injection -Wno-deprecated"
++ FESTIVAL_CFLAGS="-I/usr/include/speech-tools -ffriend-injection -Wno-deprecated"
+ FESTIVAL_PLUGIN_DIR="stardict-festival-tts-plugin"
+ fi
+ else
diff --git a/app-text/stardict/files/stardict-3.0.1-gcc43.patch b/app-text/stardict/files/stardict-3.0.1-gcc43.patch
new file mode 100644
index 000000000000..f90642b3fdb5
--- /dev/null
+++ b/app-text/stardict/files/stardict-3.0.1-gcc43.patch
@@ -0,0 +1,406 @@
+=== modified file 'src/config_file.hpp'
+--- src/config_file.hpp 2008-04-26 21:05:23 +0000
++++ src/config_file.hpp 2008-04-26 21:05:29 +0000
+@@ -5,7 +5,7 @@
+ #include <list>
+ #include <string>
+
+-#include "sigc++/sigc++.h"
++#include <sigc++/sigc++.h>
+
+ class config_file;
+
+
+=== modified file 'src/gconf_file.cpp'
+--- src/gconf_file.cpp 2008-04-26 21:05:23 +0000
++++ src/gconf_file.cpp 2008-04-26 21:05:29 +0000
+@@ -22,6 +22,7 @@
+ # include "config.h"
+ #endif
+
++#include <memory>
+ #include <glib/gi18n.h>
+
+ #include "gconf_file.hpp"
+
+=== modified file 'src/inifile.cpp'
+--- src/inifile.cpp 2008-04-26 21:05:23 +0000
++++ src/inifile.cpp 2008-04-26 21:05:29 +0000
+@@ -28,6 +28,7 @@
+ #include <cstdio>
+ #include <glib/gi18n.h>
+ #include <glib/gstdio.h>
++#include <stdlib.h>
+
+ #include "utils.h"
+
+
+=== modified file 'src/lib/common.cpp'
+--- src/lib/common.cpp 2008-04-26 21:05:23 +0000
++++ src/lib/common.cpp 2008-04-26 21:05:29 +0000
+@@ -24,6 +24,8 @@
+ # include "config.h"
+ #endif
+
++#include <cstring>
++#include <stdlib.h>
+ #include "common.hpp"
+
+ static void parse_description(const char *p, long len, std::string &description)
+
+=== modified file 'src/lib/data.cpp'
+--- src/lib/data.cpp 2008-04-26 21:05:23 +0000
++++ src/lib/data.cpp 2008-04-26 21:05:29 +0000
+@@ -26,6 +26,7 @@
+
+ #include "data.hpp"
+ #include "getuint32.h"
++#include <cstring>
+
+
+ DictBase::DictBase()
+
+=== modified file 'src/lib/http_client.cpp'
+--- src/lib/http_client.cpp 2008-04-26 21:05:23 +0000
++++ src/lib/http_client.cpp 2008-04-26 21:05:29 +0000
+@@ -4,6 +4,7 @@
+
+ #include "http_client.h"
+ #include "sockets.hpp"
++#include <cstring>
+
+ sigc::signal<void, HttpClient *, const char *> HttpClient::on_error_;
+ sigc::signal<void, HttpClient *> HttpClient::on_response_;
+
+=== modified file 'src/lib/pluginmanager.cpp'
+--- src/lib/pluginmanager.cpp 2008-04-26 21:05:23 +0000
++++ src/lib/pluginmanager.cpp 2008-04-26 21:05:29 +0000
+@@ -1,6 +1,7 @@
+ #include "pluginmanager.h"
+ #include "file.hpp"
+ #include <string>
++#include <cstring>
+
+ StarDictPluginBaseObject::StarDictPluginBaseObject(const char *filename, GModule *module_, plugin_configure_func_t configure_func_):
+ plugin_filename(filename), module(module_), configure_func(configure_func_)
+
+=== modified file 'src/lib/stardict_client.cpp'
+--- src/lib/stardict_client.cpp 2008-04-26 21:05:23 +0000
++++ src/lib/stardict_client.cpp 2008-04-26 21:05:29 +0000
+@@ -25,6 +25,8 @@
+ #include <glib.h>
+ #include <glib/gi18n.h>
+
++#include <cstring>
++#include <stdlib.h>
+ #include "sockets.hpp"
+ #include "md5.h"
+ #include "getuint32.h"
+
+=== modified file 'src/lib/stddict.cpp'
+--- src/lib/stddict.cpp 2008-04-26 21:05:23 +0000
++++ src/lib/stddict.cpp 2008-04-26 21:05:29 +0000
+@@ -28,6 +28,7 @@
+ # include "config.h"
+ #endif
+
++#include <cstring>
+ #include <glib/gi18n.h>
+ #include <glib/gstdio.h>
+
+
+=== modified file 'src/lib/treedict.cpp'
+--- src/lib/treedict.cpp 2008-04-26 21:05:23 +0000
++++ src/lib/treedict.cpp 2008-04-26 21:05:29 +0000
+@@ -25,6 +25,7 @@
+ # include "config.h"
+ #endif
+
++#include <cstring>
+ #include "file.hpp"
+ #include "getuint32.h"
+
+
+=== modified file 'src/pangoview.cpp'
+--- src/pangoview.cpp 2008-04-26 21:05:23 +0000
++++ src/pangoview.cpp 2008-04-26 21:05:29 +0000
+@@ -22,6 +22,7 @@
+ # include "config.h"
+ #endif
+
++#include <cstring>
+ #include "gtktextviewpango.h"
+ #include "utils.h"
+ #include "skin.h"//for SkinCursor definition
+
+=== modified file 'src/prefsdlg.cpp'
+--- src/prefsdlg.cpp 2008-04-26 21:05:23 +0000
++++ src/prefsdlg.cpp 2008-04-26 21:07:58 +0000
+@@ -34,6 +34,7 @@
+ #include "utils.h"
+ #include "iskeyspressed.hpp"
+ #include "lib/md5.h"
++#include <cstdlib>
+
+ #include "prefsdlg.h"
+
+
+=== modified file 'src/readword.cpp'
+--- src/readword.cpp 2008-04-26 21:05:23 +0000
++++ src/readword.cpp 2008-04-26 21:08:42 +0000
+@@ -4,6 +4,7 @@
+
+ #include <cstring>
+ #include <string>
++#include <cstdlib>
+
+ #include <glib/gi18n.h>
+
+
+=== modified file 'src/sigc++/signal.h'
+--- src/sigc++/signal.h 2008-04-26 21:05:23 +0000
++++ src/sigc++/signal.h 2008-04-26 21:06:11 +0000
+@@ -18,7 +18,7 @@
+ //Compilers, such as older versions of SUN Forte C++, that do not allow this also often
+ //do not allow a typedef to have the same name as a class in the typedef's definition.
+ //For Sun Forte CC 5.7 (SUN Workshop 10), comment this out to fix the build.
+- #define SIGC_TYPEDEF_REDEFINE_ALLOWED 1
++ //#define SIGC_TYPEDEF_REDEFINE_ALLOWED 1
+ #endif
+
+ namespace sigc {
+
+=== modified file 'src/utils.cpp'
+--- src/utils.cpp 2008-04-26 21:05:23 +0000
++++ src/utils.cpp 2008-04-26 21:05:29 +0000
+@@ -22,6 +22,7 @@
+ # include "config.h"
+ #endif
+
++#include <cstring>
+ #include <glib.h>
+ #include <glib/gi18n.h>
+ #include <cstdlib>
+
+=== modified file 'src/x11_iskeyspressed.hpp'
+--- src/x11_iskeyspressed.hpp 2008-04-26 21:05:23 +0000
++++ src/x11_iskeyspressed.hpp 2008-04-26 21:05:29 +0000
+@@ -5,6 +5,8 @@
+ #include <X11/keysym.h>
+ #include <gtk/gtk.h>
+
++#include <memory>
++
+ #include "iskeyspressed.hpp"
+
+ typedef enum { SYM, CODE, BUTTON } KeyType_t;
+
+=== modified file 'stardict-plugins/stardict-advertisement-plugin/advertisement.cpp'
+--- stardict-plugins/stardict-advertisement-plugin/advertisement.cpp 2008-04-26 21:05:23 +0000
++++ stardict-plugins/stardict-advertisement-plugin/advertisement.cpp 2008-04-26 21:05:29 +0000
+@@ -2,6 +2,7 @@
+ #include <glib.h>
+ #include <glib/gi18n.h>
+ #include <glib/gstdio.h>
++#include <cstring>
+ #include <string>
+ #include <map>
+ #include <list>
+
+=== modified file 'stardict-plugins/stardict-dictdotcn-plugin/stardict_dictdotcn.cpp'
+--- stardict-plugins/stardict-dictdotcn-plugin/stardict_dictdotcn.cpp 2008-04-26 21:05:23 +0000
++++ stardict-plugins/stardict-dictdotcn-plugin/stardict_dictdotcn.cpp 2008-04-26 21:05:29 +0000
+@@ -1,5 +1,6 @@
+ #include "stardict_dictdotcn.h"
+ #include <glib/gi18n.h>
++#include <cstring>
+ #include <string>
+ #include <list>
+
+
+=== modified file 'stardict-plugins/stardict-espeak-tts-plugin/stardict_espeak.cpp'
+--- stardict-plugins/stardict-espeak-tts-plugin/stardict_espeak.cpp 2008-04-26 21:05:23 +0000
++++ stardict-plugins/stardict-espeak-tts-plugin/stardict_espeak.cpp 2008-04-26 21:05:29 +0000
+@@ -1,6 +1,7 @@
+ #include "stardict_espeak.h"
+ #include <espeak/speak_lib.h>
+ #include <glib/gi18n.h>
++#include <cstring>
+
+ static const StarDictPluginSystemInfo *plugin_info = NULL;
+ static std::string voice_engine;
+
+=== modified file 'stardict-plugins/stardict-gucharmap-plugin/stardict_gucharmap.cpp'
+--- stardict-plugins/stardict-gucharmap-plugin/stardict_gucharmap.cpp 2008-04-26 21:05:23 +0000
++++ stardict-plugins/stardict-gucharmap-plugin/stardict_gucharmap.cpp 2008-04-26 21:05:29 +0000
+@@ -1,6 +1,8 @@
+ #include "stardict_gucharmap.h"
+ #include <glib/gi18n.h>
+ #include <gucharmap/gucharmap.h>
++#include <stdlib.h>
++#include <cstring>
+ #include <string>
+
+ static char *build_dictdata(char type, const char *definition)
+
+=== modified file 'stardict-plugins/stardict-html-parsedata-plugin/stardict_html_parsedata.cpp'
+--- stardict-plugins/stardict-html-parsedata-plugin/stardict_html_parsedata.cpp 2008-04-26 21:05:23 +0000
++++ stardict-plugins/stardict-html-parsedata-plugin/stardict_html_parsedata.cpp 2008-04-26 21:05:29 +0000
+@@ -1,5 +1,7 @@
+ #include "stardict_html_parsedata.h"
+ #include <glib/gi18n.h>
++#include <cstring>
++#include <stdlib.h>
+
+ #ifdef _WIN32
+ #include <windows.h>
+
+=== modified file 'stardict-plugins/stardict-man-plugin/stardict_man.cpp'
+--- stardict-plugins/stardict-man-plugin/stardict_man.cpp 2008-04-26 21:05:23 +0000
++++ stardict-plugins/stardict-man-plugin/stardict_man.cpp 2008-04-26 21:05:29 +0000
+@@ -1,5 +1,6 @@
+ #include "stardict_man.h"
+ #include <glib/gi18n.h>
++#include <cstring>
+ #include <string>
+
+ static const StarDictPluginSystemInfo *plugin_info = NULL;
+
+=== modified file 'stardict-plugins/stardict-powerword-parsedata-plugin/stardict_powerword_parsedata.cpp'
+--- stardict-plugins/stardict-powerword-parsedata-plugin/stardict_powerword_parsedata.cpp 2008-04-26 21:05:23 +0000
++++ stardict-plugins/stardict-powerword-parsedata-plugin/stardict_powerword_parsedata.cpp 2008-04-26 21:05:29 +0000
+@@ -1,4 +1,5 @@
+ #include "stardict_powerword_parsedata.h"
++#include <cstring>
+ #include <glib/gi18n.h>
+
+ #ifdef _WIN32
+
+=== modified file 'stardict-plugins/stardict-qqwry-plugin/stardict_qqwry.cpp'
+--- stardict-plugins/stardict-qqwry-plugin/stardict_qqwry.cpp 2008-04-26 21:05:23 +0000
++++ stardict-plugins/stardict-qqwry-plugin/stardict_qqwry.cpp 2008-04-26 21:05:29 +0000
+@@ -1,6 +1,8 @@
+ #include "stardict_qqwry.h"
+ #include <glib/gi18n.h>
+ #include <glib/gstdio.h>
++#include <cstring>
++#include <stdlib.h>
+ #include <string>
+
+ #ifdef _WIN32
+
+=== modified file 'stardict-plugins/stardict-spell-plugin/stardict_spell.cpp'
+--- stardict-plugins/stardict-spell-plugin/stardict_spell.cpp 2008-04-26 21:05:23 +0000
++++ stardict-plugins/stardict-spell-plugin/stardict_spell.cpp 2008-04-26 21:05:29 +0000
+@@ -3,6 +3,7 @@
+ #include <glib/gi18n.h>
+ #include <enchant.h>
+ #include <pango/pango.h>
++#include <cstring>
+ #include <string>
+ #include <vector>
+
+
+=== modified file 'stardict-plugins/stardict-update-info-plugin/stardict_update_info.cpp'
+--- stardict-plugins/stardict-update-info-plugin/stardict_update_info.cpp 2008-04-26 21:05:23 +0000
++++ stardict-plugins/stardict-update-info-plugin/stardict_update_info.cpp 2008-04-26 21:05:29 +0000
+@@ -1,5 +1,7 @@
+ #include "stardict_update_info.h"
+ #include <glib/gi18n.h>
++#include <cstring>
++#include <stdlib.h>
+
+ #ifdef _WIN32
+ #include <windows.h>
+
+=== modified file 'stardict-plugins/stardict-wiki-parsedata-plugin/stardict_wiki2xml.cpp'
+--- stardict-plugins/stardict-wiki-parsedata-plugin/stardict_wiki2xml.cpp 2008-04-26 21:05:23 +0000
++++ stardict-plugins/stardict-wiki-parsedata-plugin/stardict_wiki2xml.cpp 2008-04-26 21:05:29 +0000
+@@ -1,5 +1,6 @@
+ #include "stardict_wiki2xml.h"
+ #include "WIKI2XML.h"
++#include <cstring>
+ #include <glib.h>
+
+ std::string wiki2xml(std::string &str)
+
+=== modified file 'stardict-plugins/stardict-wiki-parsedata-plugin/stardict_wiki_parsedata.cpp'
+--- stardict-plugins/stardict-wiki-parsedata-plugin/stardict_wiki_parsedata.cpp 2008-04-26 21:05:23 +0000
++++ stardict-plugins/stardict-wiki-parsedata-plugin/stardict_wiki_parsedata.cpp 2008-04-26 21:05:29 +0000
+@@ -1,5 +1,6 @@
+ #include "stardict_wiki_parsedata.h"
+ #include "stardict_wiki2xml.h"
++#include <cstring>
+ #include <glib/gi18n.h>
+
+ #ifdef _WIN32
+
+=== modified file 'stardict-plugins/stardict-wordnet-plugin/court_widget.cpp'
+--- stardict-plugins/stardict-wordnet-plugin/court_widget.cpp 2008-04-26 21:05:23 +0000
++++ stardict-plugins/stardict-wordnet-plugin/court_widget.cpp 2008-04-26 21:05:29 +0000
+@@ -1,6 +1,7 @@
+ #include "court_widget.h"
+ #include <math.h>
+ #include <list>
++#include <cstring>
+
+
+ wnobj::wnobj(partic_t & p, unsigned int t) : _p(p), _t(t), highlight(false)
+
+=== modified file 'stardict-plugins/stardict-wordnet-plugin/stardict_wordnet.cpp'
+--- stardict-plugins/stardict-wordnet-plugin/stardict_wordnet.cpp 2008-04-26 21:05:23 +0000
++++ stardict-plugins/stardict-wordnet-plugin/stardict_wordnet.cpp 2008-04-26 21:05:29 +0000
+@@ -1,6 +1,7 @@
+ #include "stardict_wordnet.h"
+ #include "court_widget.h"
+ #include <glib/gi18n.h>
++#include <cstring>
+
+ #ifdef _WIN32
+ #include <windows.h>
+
+=== modified file 'stardict-plugins/stardict-wordnet-plugin/stardict_wordnet_parsedata.cpp'
+--- stardict-plugins/stardict-wordnet-plugin/stardict_wordnet_parsedata.cpp 2008-04-26 21:05:23 +0000
++++ stardict-plugins/stardict-wordnet-plugin/stardict_wordnet_parsedata.cpp 2008-04-26 21:05:29 +0000
+@@ -1,4 +1,5 @@
+ #include "stardict_wordnet_parsedata.h"
++#include <cstring>
+ #include <glib/gi18n.h>
+
+ #ifdef _WIN32
+
+=== modified file 'stardict-plugins/stardict-xdxf-parsedata-plugin/stardict_xdxf_parsedata.cpp'
+--- stardict-plugins/stardict-xdxf-parsedata-plugin/stardict_xdxf_parsedata.cpp 2008-04-26 21:05:23 +0000
++++ stardict-plugins/stardict-xdxf-parsedata-plugin/stardict_xdxf_parsedata.cpp 2008-04-26 21:05:29 +0000
+@@ -1,5 +1,6 @@
+ #include "stardict_xdxf_parsedata.h"
+ #include <glib/gi18n.h>
++#include <cstring>
+
+ #ifdef _WIN32
+ #include <windows.h>
+
+=== modified file 'tests/t_config_file.cpp'
+--- tests/t_config_file.cpp 2008-04-26 21:05:23 +0000
++++ tests/t_config_file.cpp 2008-04-26 21:05:29 +0000
+@@ -2,6 +2,7 @@
+ # include "config.h"
+ #endif
+
++#include <memory>
+ #include <cerrno>
+ #include <cstdio>
+ #include <cstdlib>
+
+=== modified file 'tests/t_xml.cpp'
+--- tests/t_xml.cpp 2008-04-26 21:05:23 +0000
++++ tests/t_xml.cpp 2008-04-26 21:05:29 +0000
+@@ -3,6 +3,7 @@
+ #endif
+
+ #include <glib.h>
++#include <cstring>
+ #include <cstdlib>
+ #include <string>
+
+
diff --git a/app-text/stardict/files/stardict-3.0.1-gcc44.patch b/app-text/stardict/files/stardict-3.0.1-gcc44.patch
new file mode 100644
index 000000000000..084b6b645603
--- /dev/null
+++ b/app-text/stardict/files/stardict-3.0.1-gcc44.patch
@@ -0,0 +1,22 @@
+--- src/lib/data.cpp
++++ src/lib/data.cpp
+@@ -22,6 +22,8 @@
+ # include "config.h"
+ #endif
+
++#include <cstdio>
++
+ #include "kmp.h"
+
+ #include "data.hpp"
+--- src/lib/stardict_client.cpp
++++ src/lib/stardict_client.cpp
+@@ -22,6 +22,8 @@
+ # include "config.h"
+ #endif
+
++#include <cstdio>
++
+ #include <glib.h>
+ #include <glib/gi18n.h>
+
diff --git a/app-text/stardict/files/stardict-3.0.1-gconf-m4.diff b/app-text/stardict/files/stardict-3.0.1-gconf-m4.diff
new file mode 100644
index 000000000000..fc412ecea515
--- /dev/null
+++ b/app-text/stardict/files/stardict-3.0.1-gconf-m4.diff
@@ -0,0 +1,43 @@
+diff -urN stardict-3.0.0.orig/m4/gconf-2.m4 stardict-3.0.0/m4/gconf-2.m4
+--- m4/gconf-2.m4 1970-01-01 08:00:00.000000000 +0800
++++ m4/gconf-2.m4 2007-11-10 14:48:00.000000000 +0800
+@@ -0,0 +1,39 @@
++dnl AM_GCONF_SOURCE_2
++dnl Defines GCONF_SCHEMA_CONFIG_SOURCE which is where you should install schemas
++dnl (i.e. pass to gconftool-2
++dnl Defines GCONF_SCHEMA_FILE_DIR which is a filesystem directory where
++dnl you should install foo.schemas files
++dnl
++
++AC_DEFUN([AM_GCONF_SOURCE_2],
++[
++ if test "x$GCONF_SCHEMA_INSTALL_SOURCE" = "x"; then
++ GCONF_SCHEMA_CONFIG_SOURCE=`gconftool-2 --get-default-source`
++ else
++ GCONF_SCHEMA_CONFIG_SOURCE=$GCONF_SCHEMA_INSTALL_SOURCE
++ fi
++
++ AC_ARG_WITH(gconf-source,
++ [ --with-gconf-source=sourceaddress Config database for installing schema files.],GCONF_SCHEMA_CONFIG_SOURCE="$withval",)
++
++ AC_SUBST(GCONF_SCHEMA_CONFIG_SOURCE)
++ AC_MSG_RESULT([Using config source $GCONF_SCHEMA_CONFIG_SOURCE for schema installation])
++
++ if test "x$GCONF_SCHEMA_FILE_DIR" = "x"; then
++ GCONF_SCHEMA_FILE_DIR='$(sysconfdir)/gconf/schemas'
++ fi
++
++ AC_ARG_WITH(gconf-schema-file-dir,
++ [ --with-gconf-schema-file-dir=dir Directory for installing schema files.],GCONF_SCHEMA_FILE_DIR="$withval",)
++
++ AC_SUBST(GCONF_SCHEMA_FILE_DIR)
++ AC_MSG_RESULT([Using $GCONF_SCHEMA_FILE_DIR as install directory for schema files])
++
++ AC_ARG_ENABLE(schemas-install,
++ [ --disable-schemas-install Disable the schemas installation],
++ [case ${enableval} in
++ yes|no) ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --enable-schemas-install) ;;
++ esac])
++ AM_CONDITIONAL([GCONF_SCHEMAS_INSTALL], [test "$enable_schemas_install" != no])
++])
diff --git a/app-text/stardict/files/stardict-3.0.1-gucharmap2.patch b/app-text/stardict/files/stardict-3.0.1-gucharmap2.patch
new file mode 100644
index 000000000000..dc8f9415e473
--- /dev/null
+++ b/app-text/stardict/files/stardict-3.0.1-gucharmap2.patch
@@ -0,0 +1,46 @@
+Index: configure.in
+===================================================================
+--- configure.in (revision 257)
++++ configure.in (working copy)
+@@ -12,6 +12,7 @@
+
+ AC_PATH_PROG(GCONFTOOL, gconftool-2)
+ AC_PROG_INTLTOOL([0.22])
++PKG_PROG_PKG_CONFIG
+
+ AC_CONFIG_MACRO_DIR(m4)
+ AM_PROG_LIBTOOL
+@@ -72,13 +73,17 @@
+ dnl gucharmap plugin checks.
+ dnl ================================================================
+
++GUCHARMAP_REQUIRED=1.4.0
+ AC_ARG_ENABLE([gucharmap],
+ AS_HELP_STRING([--disable-gucharmap],[Disable gucharmap plugin (default: enabled)]),
+ [enable_gucharmap=$enableval],
+ [enable_gucharmap=yes])
+
+ if test "x$enable_gucharmap" = "xyes" ; then
+- PKG_CHECK_MODULES(GUCHARMAP, [gucharmap >= 1.4.0], have_gucharmap=yes, have_gucharmap=no)
++ PKG_CHECK_MODULES(GUCHARMAP, [gucharmap >= $GUCHARMAP_REQUIRED], have_gucharmap=yes, have_gucharmap=no)
++ if test "x$have_gucharmap" != "xyes"; then
++ PKG_CHECK_MODULES(GUCHARMAP, [gucharmap-2 >= $GUCHARMAP_REQUIRED], have_gucharmap=yes, have_gucharmap=no)
++ fi
+ if test "x$have_gucharmap" = "xyes"; then
+ GUCHARMAP_CFLAGS="${GUCHARMAP_CFLAGS}"
+ GUCHARMAP_LIBS="${GUCHARMAP_LIBS}"
+Index: stardict-plugins/stardict-gucharmap-plugin/stardict_gucharmap.cpp
+===================================================================
+--- stardict-plugins/stardict-gucharmap-plugin/stardict_gucharmap.cpp (revision 257)
++++ stardict-plugins/stardict-gucharmap-plugin/stardict_gucharmap.cpp (working copy)
+@@ -238,7 +238,7 @@
+ /* canonical decomposition */
+ gunichar *decomposition;
+ gsize result_len;
+- decomposition = gucharmap_unicode_canonical_decomposition (uc, &result_len);
++ decomposition = g_unicode_canonical_decomposition (uc, &result_len);
+ if (result_len != 1) {
+ definition += _("Canonical decomposition:");
+ definition += " ";
+
+
diff --git a/app-text/stardict/files/stardict-3.0.1-transparent_trayicon.patch b/app-text/stardict/files/stardict-3.0.1-transparent_trayicon.patch
new file mode 100644
index 000000000000..1522a2a760c3
--- /dev/null
+++ b/app-text/stardict/files/stardict-3.0.1-transparent_trayicon.patch
@@ -0,0 +1,168 @@
+--- stardict-3.0.1/src/docklet.cpp 2007-10-25 10:57:22.000000000 +0400
++++ stardict/src/docklet.cpp 2008-02-25 16:32:08.000000000 +0300
+@@ -25,15 +25,15 @@
+ void DockLet::create_docklet()
+ {
+ docklet_ = egg_tray_icon_new("StarDict");
+- box_ = gtk_event_box_new();
++ gtk_widget_add_events (GTK_WIDGET(docklet_), GDK_BUTTON_PRESS_MASK | GDK_BUTTON_RELEASE_MASK);
+ if (is_hide_state()) {
+- gtk_widget_set_tooltip_text(box_, _("StarDict"));
++ gtk_widget_set_tooltip_text(GTK_WIDGET(docklet_), _("StarDict"));
+ image_ = gtk_image_new_from_pixbuf(normal_icon_);
+ } else if (is_scan_on()) {
+- gtk_widget_set_tooltip_text(box_, _("StarDict - Scanning"));
++ gtk_widget_set_tooltip_text(GTK_WIDGET(docklet_), _("StarDict - Scanning"));
+ image_ = gtk_image_new_from_pixbuf(scan_icon_);
+ } else {
+- gtk_widget_set_tooltip_text(box_, _("StarDict - Stopped"));
++ gtk_widget_set_tooltip_text(GTK_WIDGET(docklet_), _("StarDict - Stopped"));
+ image_ = gtk_image_new_from_pixbuf(stop_icon_);
+ }
+
+@@ -41,11 +41,10 @@
+ G_CALLBACK(on_embedded), this);
+ g_signal_connect(G_OBJECT(docklet_), "destroy",
+ G_CALLBACK(on_destroyed), this);
+- g_signal_connect(G_OBJECT(box_), "button-press-event",
++ g_signal_connect(G_OBJECT(docklet_), "button-press-event",
+ G_CALLBACK(on_btn_press), this);
+
+- gtk_container_add(GTK_CONTAINER(box_), image_);
+- gtk_container_add(GTK_CONTAINER(docklet_), box_);
++ gtk_container_add(GTK_CONTAINER(docklet_), image_);
+ gtk_widget_show_all(GTK_WIDGET(docklet_));
+
+ /* ref the docklet_ before we bandy it about the place */
+@@ -179,13 +178,13 @@
+
+ void DockLet::scan_on()
+ {
+- gtk_widget_set_tooltip_text(box_, _("StarDict - Scanning"));
++ gtk_widget_set_tooltip_text(GTK_WIDGET(docklet_), _("StarDict - Scanning"));
+ gtk_image_set_from_pixbuf(GTK_IMAGE(image_), scan_icon_);
+ }
+
+ void DockLet::scan_off()
+ {
+- gtk_widget_set_tooltip_text(box_, _("StarDict - Stopped"));
++ gtk_widget_set_tooltip_text(GTK_WIDGET(docklet_), _("StarDict - Stopped"));
+ gtk_image_set_from_pixbuf(GTK_IMAGE(image_), stop_icon_);
+ }
+
+@@ -193,7 +192,7 @@
+ {
+ if (!image_)
+ return;
+- gtk_widget_set_tooltip_text(box_, _("StarDict"));
++ gtk_widget_set_tooltip_text(GTK_WIDGET(docklet_), _("StarDict"));
+ gtk_image_set_from_pixbuf(GTK_IMAGE(image_), normal_icon_);
+ }
+
+--- stardict-3.0.1/src/docklet.h 2007-10-25 10:53:06.000000000 +0400
++++ stardict/src/docklet.h 2008-02-25 16:32:08.000000000 +0300
+@@ -16,7 +16,6 @@
+ void set_scan_mode(bool);
+ private:
+ EggTrayIcon *docklet_;
+- GtkWidget *box_;
+ GtkWidget *image_; //icon image.
+ typedef ResourceWrapper<GtkWidget, GtkWidget, gtk_widget_destroy> GMenu;
+ GMenu menu_;
+--- stardict-3.0.1/src/eggtrayicon.c 2007-07-10 11:16:04.000000000 +0400
++++ stardict/src/eggtrayicon.c 2008-02-25 16:32:08.000000000 +0300
+@@ -66,6 +66,8 @@
+
+ static void egg_tray_icon_realize (GtkWidget *widget);
+ static void egg_tray_icon_unrealize (GtkWidget *widget);
++static void egg_tray_icon_add (GtkContainer *container,
++ GtkWidget *widget);
+
+ #ifdef GDK_WINDOWING_X11
+ static void egg_tray_icon_update_manager_window (EggTrayIcon *icon,
+@@ -113,6 +115,7 @@
+ {
+ GObjectClass *gobject_class = (GObjectClass *)klass;
+ GtkWidgetClass *widget_class = (GtkWidgetClass *)klass;
++ GtkContainerClass *container_class = (GtkContainerClass *)klass;
+
+ parent_class = g_type_class_peek_parent (klass);
+
+@@ -121,6 +124,8 @@
+ widget_class->realize = egg_tray_icon_realize;
+ widget_class->unrealize = egg_tray_icon_unrealize;
+
++ container_class->add = egg_tray_icon_add;
++
+ g_object_class_install_property (gobject_class,
+ PROP_ORIENTATION,
+ g_param_spec_enum ("orientation",
+@@ -159,6 +164,35 @@
+ }
+
+ #ifdef GDK_WINDOWING_X11
++static gboolean
++transparent_expose_event (GtkWidget *widget, GdkEventExpose *event, gpointer user_data)
++{
++ gdk_window_clear_area (widget->window, event->area.x, event->area.y,
++ event->area.width, event->area.height);
++ return FALSE;
++}
++
++static void
++make_transparent_again (GtkWidget *widget, GtkStyle *previous_style,
++ gpointer user_data)
++{
++ gdk_window_set_back_pixmap(widget->window, NULL, TRUE);
++}
++
++static void
++make_transparent (GtkWidget *widget, gpointer user_data)
++{
++ if (GTK_WIDGET_NO_WINDOW (widget) || GTK_WIDGET_APP_PAINTABLE (widget))
++ return;
++
++ gtk_widget_set_app_paintable (widget, TRUE);
++ gtk_widget_set_double_buffered (widget, FALSE);
++ gdk_window_set_back_pixmap (widget->window, NULL, TRUE);
++ g_signal_connect (widget, "expose_event",
++ G_CALLBACK (transparent_expose_event), NULL);
++ g_signal_connect_after (widget, "style_set",
++ G_CALLBACK (make_transparent_again), NULL);
++}
+
+ static void
+ egg_tray_icon_get_orientation_property (EggTrayIcon *icon)
+@@ -238,10 +272,22 @@
+ }
+ return GDK_FILTER_CONTINUE;
+ }
+-
++#else
++static void
++make_transparent (GtkWidget *widget, gpointer user_data)
++{
++}
+ #endif
+
+ static void
++egg_tray_icon_add (GtkContainer *container, GtkWidget *widget)
++{
++ g_signal_connect (widget, "realize",
++ G_CALLBACK (make_transparent), NULL);
++ GTK_CONTAINER_CLASS (parent_class)->add (container, widget);
++}
++
++static void
+ egg_tray_icon_unrealize (GtkWidget *widget)
+ {
+ #ifdef GDK_WINDOWING_X11
+@@ -381,6 +427,8 @@
+ if (GTK_WIDGET_CLASS (parent_class)->realize)
+ GTK_WIDGET_CLASS (parent_class)->realize (widget);
+
++ make_transparent (widget, NULL);
++
+ screen = gtk_widget_get_screen (widget);
+ display = gdk_screen_get_display (screen);
+ xdisplay = gdk_x11_display_get_xdisplay (display);