summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-12-30 21:29:30 +0000
committerChristoph Mende <angelos@gentoo.org>2008-12-30 21:29:30 +0000
commitd389d6d7b86343ba7f4ed5c24e214a3e6b9accf9 (patch)
tree3fcf1479d835d6d581f79e51eaba77a350474500 /app-text/reed/reed-5.4.ebuild
parentVersion bump (diff)
downloadgentoo-2-d389d6d7b86343ba7f4ed5c24e214a3e6b9accf9.tar.gz
gentoo-2-d389d6d7b86343ba7f4ed5c24e214a3e6b9accf9.tar.bz2
gentoo-2-d389d6d7b86343ba7f4ed5c24e214a3e6b9accf9.zip
QA: Respect CC (bug 243740), prevent stripping (bug 239875)
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'app-text/reed/reed-5.4.ebuild')
-rw-r--r--app-text/reed/reed-5.4.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/app-text/reed/reed-5.4.ebuild b/app-text/reed/reed-5.4.ebuild
index b98e48d0ab58..52681c1ed760 100644
--- a/app-text/reed/reed-5.4.ebuild
+++ b/app-text/reed/reed-5.4.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/reed/reed-5.4.ebuild,v 1.8 2007/07/12 04:37:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/reed/reed-5.4.ebuild,v 1.9 2008/12/30 21:29:30 angelos Exp $
+
+inherit toolchain-funcs
DESCRIPTION="This is a text pager (text file viewer), used to display etexts."
HOMEPAGE="http://www.sacredchao.net/software/reed/index.shtml"
-SRC_URI=http://www.sacredchao.net/software/reed/${P}.tar.gz
+SRC_URI="http://www.sacredchao.net/software/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -14,17 +16,17 @@ IUSE=""
DEPEND="sys-libs/ncurses"
src_unpack() {
- unpack ${P}.tar.gz
- cd ${S}
- sed -i -e "s:-O2:\$(CFLAGS):" Makefile.in
+ unpack ${A}
+ sed -i -e "s:-O2:${CFLAGS}:" \
+ -e "s:-s::" "${S}"/Makefile.in
}
src_compile() {
- ./configures --prefix=/usr || die
- make || die
+ ./configures --prefix=/usr || die "configures failed"
+ emake CC="$(tc-getCC)" || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die
+ emake DESTDIR=${D} install || die "emake install failed"
dodoc AUTHORS BUGS NEWS README
}