summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2011-09-05 20:03:36 +0000
committerZac Medico <zmedico@gentoo.org>2011-09-05 20:03:36 +0000
commita00cc928e1e8d879f8d2aefc61e464db1e9538d1 (patch)
tree77b4355ecb95b146e293ac2be59fd1d61e8532aa /app-text/podofo
parentRevision bump for new patchset. (diff)
downloadgentoo-2-a00cc928e1e8d879f8d2aefc61e464db1e9538d1.tar.gz
gentoo-2-a00cc928e1e8d879f8d2aefc61e464db1e9538d1.tar.bz2
gentoo-2-a00cc928e1e8d879f8d2aefc61e464db1e9538d1.zip
Bug #381359 - undefined reference to `PoDoFo::PdfVariant::DelayedLoadImpl()' triggered by -fvisibility-inlines-hidden in CXXFLAGS.
(Portage version: 2.2.0_alpha53/cvs/Linux i686)
Diffstat (limited to 'app-text/podofo')
-rw-r--r--app-text/podofo/ChangeLog8
-rw-r--r--app-text/podofo/podofo-0.7.0.ebuild10
-rw-r--r--app-text/podofo/podofo-0.8.1-r1.ebuild8
-rw-r--r--app-text/podofo/podofo-0.8.2.ebuild10
-rw-r--r--app-text/podofo/podofo-0.8.4.ebuild8
-rw-r--r--app-text/podofo/podofo-0.9.1.ebuild8
6 files changed, 39 insertions, 13 deletions
diff --git a/app-text/podofo/ChangeLog b/app-text/podofo/ChangeLog
index 69551f3e60f4..8c45e56661c7 100644
--- a/app-text/podofo/ChangeLog
+++ b/app-text/podofo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/podofo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/ChangeLog,v 1.22 2011/08/12 16:07:56 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/ChangeLog,v 1.23 2011/09/05 20:03:36 zmedico Exp $
+
+ 05 Sep 2011; Zac Medico <zmedico@gentoo.org> podofo-0.7.0.ebuild,
+ podofo-0.8.1-r1.ebuild, podofo-0.8.2.ebuild, podofo-0.8.4.ebuild,
+ podofo-0.9.1.ebuild:
+ Bug #381359 - undefined reference to `PoDoFo::PdfVariant::DelayedLoadImpl()'
+ triggered by -fvisibility-inlines-hidden in CXXFLAGS.
12 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org> podofo-0.8.1-r1.ebuild:
ppc stable wrt #333627
diff --git a/app-text/podofo/podofo-0.7.0.ebuild b/app-text/podofo/podofo-0.7.0.ebuild
index eb7a365b86b9..c89ea35892cc 100644
--- a/app-text/podofo/podofo-0.7.0.ebuild
+++ b/app-text/podofo/podofo-0.7.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/podofo-0.7.0.ebuild,v 1.10 2010/11/07 21:11:46 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/podofo-0.7.0.ebuild,v 1.11 2011/09/05 20:03:36 zmedico Exp $
EAPI=2
-inherit cmake-utils multilib
+inherit cmake-utils flag-o-matic multilib
DESCRIPTION="PoDoFo is a C++ library to work with the PDF file format."
HOMEPAGE="http://sourceforge.net/projects/podofo/"
@@ -35,6 +35,10 @@ src_prepare() {
}
src_configure() {
+
+ # Bug #381359: undefined reference to `PoDoFo::PdfVariant::DelayedLoadImpl()'
+ filter-flags -fvisibility-inlines-hidden
+
mycmakeargs+=(
"-DPODOFO_BUILD_SHARED=1"
"-DPODOFO_HAVE_JPEG_LIB=1"
diff --git a/app-text/podofo/podofo-0.8.1-r1.ebuild b/app-text/podofo/podofo-0.8.1-r1.ebuild
index 7d5a70a8f19e..af06285685e0 100644
--- a/app-text/podofo/podofo-0.8.1-r1.ebuild
+++ b/app-text/podofo/podofo-0.8.1-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/podofo-0.8.1-r1.ebuild,v 1.6 2011/08/12 16:07:56 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/podofo-0.8.1-r1.ebuild,v 1.7 2011/09/05 20:03:36 zmedico Exp $
EAPI=2
-inherit cmake-utils multilib
+inherit cmake-utils flag-o-matic multilib
DESCRIPTION="PoDoFo is a C++ library to work with the PDF file format."
HOMEPAGE="http://sourceforge.net/projects/podofo/"
@@ -39,6 +39,10 @@ src_prepare() {
}
src_configure() {
+
+ # Bug #381359: undefined reference to `PoDoFo::PdfVariant::DelayedLoadImpl()'
+ filter-flags -fvisibility-inlines-hidden
+
mycmakeargs+=(
"-DPODOFO_BUILD_SHARED=1"
"-DPODOFO_HAVE_JPEG_LIB=1"
diff --git a/app-text/podofo/podofo-0.8.2.ebuild b/app-text/podofo/podofo-0.8.2.ebuild
index 5c482b2fb8f0..484e8cbce31e 100644
--- a/app-text/podofo/podofo-0.8.2.ebuild
+++ b/app-text/podofo/podofo-0.8.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/podofo-0.8.2.ebuild,v 1.2 2010/11/07 21:11:46 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/podofo-0.8.2.ebuild,v 1.3 2011/09/05 20:03:36 zmedico Exp $
EAPI=2
-inherit cmake-utils multilib
+inherit cmake-utils flag-o-matic multilib
DESCRIPTION="PoDoFo is a C++ library to work with the PDF file format."
HOMEPAGE="http://sourceforge.net/projects/podofo/"
@@ -35,6 +35,10 @@ src_prepare() {
}
src_configure() {
+
+ # Bug #381359: undefined reference to `PoDoFo::PdfVariant::DelayedLoadImpl()'
+ filter-flags -fvisibility-inlines-hidden
+
mycmakeargs+=(
"-DPODOFO_BUILD_SHARED=1"
"-DPODOFO_HAVE_JPEG_LIB=1"
diff --git a/app-text/podofo/podofo-0.8.4.ebuild b/app-text/podofo/podofo-0.8.4.ebuild
index 40bf64958a2a..e5468b21b565 100644
--- a/app-text/podofo/podofo-0.8.4.ebuild
+++ b/app-text/podofo/podofo-0.8.4.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/podofo-0.8.4.ebuild,v 1.3 2011/02/24 17:31:10 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/podofo-0.8.4.ebuild,v 1.4 2011/09/05 20:03:36 zmedico Exp $
EAPI=2
-inherit cmake-utils eutils multilib
+inherit cmake-utils eutils flag-o-matic multilib
DESCRIPTION="PoDoFo is a C++ library to work with the PDF file format."
HOMEPAGE="http://sourceforge.net/projects/podofo/"
@@ -54,6 +54,10 @@ src_prepare() {
}
src_configure() {
+
+ # Bug #381359: undefined reference to `PoDoFo::PdfVariant::DelayedLoadImpl()'
+ filter-flags -fvisibility-inlines-hidden
+
mycmakeargs+=(
"-DPODOFO_BUILD_SHARED=1"
"-DPODOFO_HAVE_JPEG_LIB=1"
diff --git a/app-text/podofo/podofo-0.9.1.ebuild b/app-text/podofo/podofo-0.9.1.ebuild
index 99db053e8ba2..4f8f2b5d1465 100644
--- a/app-text/podofo/podofo-0.9.1.ebuild
+++ b/app-text/podofo/podofo-0.9.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/podofo-0.9.1.ebuild,v 1.1 2011/05/09 08:06:31 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/podofo-0.9.1.ebuild,v 1.2 2011/09/05 20:03:36 zmedico Exp $
EAPI=2
-inherit cmake-utils eutils multilib
+inherit cmake-utils flag-o-matic multilib
DESCRIPTION="PoDoFo is a C++ library to work with the PDF file format."
HOMEPAGE="http://sourceforge.net/projects/podofo/"
@@ -66,6 +66,10 @@ src_prepare() {
}
src_configure() {
+
+ # Bug #381359: undefined reference to `PoDoFo::PdfVariant::DelayedLoadImpl()'
+ filter-flags -fvisibility-inlines-hidden
+
mycmakeargs+=(
"-DPODOFO_BUILD_SHARED=1"
"-DPODOFO_HAVE_JPEG_LIB=1"