summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-30 15:46:51 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-30 15:46:51 +0000
commitb905a47d614993e2aafc0055bf38d47ca68808b0 (patch)
tree18534586dc0a242b73f606a513855e6341737859 /app-text/pinfo/pinfo-0.6.5_p2-r1.ebuild
parentcorrect SLOT value to '3.1' (diff)
downloadgentoo-2-b905a47d614993e2aafc0055bf38d47ca68808b0.tar.gz
gentoo-2-b905a47d614993e2aafc0055bf38d47ca68808b0.tar.bz2
gentoo-2-b905a47d614993e2aafc0055bf38d47ca68808b0.zip
beautification
Diffstat (limited to 'app-text/pinfo/pinfo-0.6.5_p2-r1.ebuild')
-rw-r--r--app-text/pinfo/pinfo-0.6.5_p2-r1.ebuild29
1 files changed, 16 insertions, 13 deletions
diff --git a/app-text/pinfo/pinfo-0.6.5_p2-r1.ebuild b/app-text/pinfo/pinfo-0.6.5_p2-r1.ebuild
index 641dcf77db9f..f7535ce622f6 100644
--- a/app-text/pinfo/pinfo-0.6.5_p2-r1.ebuild
+++ b/app-text/pinfo/pinfo-0.6.5_p2-r1.ebuild
@@ -1,30 +1,33 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-text/pinfo/pinfo-0.6.5_p2-r1.ebuild,v 1.4 2002/08/16 02:42:01 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pinfo/pinfo-0.6.5_p2-r1.ebuild,v 1.5 2002/08/30 15:46:51 seemant Exp $
MY_P=${PN}-0.6.5p2
S=${WORKDIR}/${MY_P}
DESCRIPTION="Hypertext info and man viewer based on (n)curses"
SRC_URI="http://zeus.polsl.gliwice.pl/~pborys/stable-version/${MY_P}.tar.gz"
HOMEPAGE="http://zeus.polsl.gliwice.pl/~pborys/"
-KEYWORDS="x86 ppc sparc sparc64"
-DEPEND="virtual/glibc
- >=sys-libs/ncurses-5.2
- nls? ( >=sys-devel/gettext-0.10.39 )
- >=sys-devel/bison-1.28"
-RDEPEND="virtual/glibc
- >=sys-libs/ncurses-5.2
- nls? ( >=sys-devel/gettext-0.10.39 )"
+
+DEPEND="sys-libs/ncurses
+ sys-devel/bison
+ nls? ( sys-devel/gettext )"
+
SLOT="0"
LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc sparc64"
src_compile() {
- local myc
+ local myconf
+
+ use readline \
+ && myconf="${myconf} --with-readline" \
+ || myconf="${myconf} --without-readline"
- use readline && myc="${myc} --with-readline" || myc="${myc} --without-readline"
- use nls && myc="${myc} --enable-nls" || myc="${myc} --disable-nls"
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
- econf ${myc} || die
+ econf ${myconf} || die
emake || die
}