summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-07-22 15:42:42 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-07-22 15:42:42 +0000
commit028340ed541535b2db53c51b91ff85aa5f54488f (patch)
treeafae7eb860a1e4f3b57a7777124fcc5f5e3ebe1c /app-text/pinfo/pinfo-0.6.5_p2-r1.ebuild
parentrepoman'd (diff)
downloadgentoo-2-028340ed541535b2db53c51b91ff85aa5f54488f.tar.gz
gentoo-2-028340ed541535b2db53c51b91ff85aa5f54488f.tar.bz2
gentoo-2-028340ed541535b2db53c51b91ff85aa5f54488f.zip
Fixed #5359 for this package; should now be FHS compliant.
Diffstat (limited to 'app-text/pinfo/pinfo-0.6.5_p2-r1.ebuild')
-rw-r--r--app-text/pinfo/pinfo-0.6.5_p2-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-text/pinfo/pinfo-0.6.5_p2-r1.ebuild b/app-text/pinfo/pinfo-0.6.5_p2-r1.ebuild
new file mode 100644
index 000000000000..8981886f4ecd
--- /dev/null
+++ b/app-text/pinfo/pinfo-0.6.5_p2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-text/pinfo/pinfo-0.6.5_p2-r1.ebuild,v 1.1 2002/07/22 15:42:41 karltk Exp $
+
+MY_P=${PN}-0.6.5p2
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Hypertext info and man viewer based on (n)curses"
+SRC_URI="http://zeus.polsl.gliwice.pl/~pborys/stable-version/${MY_P}.tar.gz"
+HOMEPAGE="http://zeus.polsl.gliwice.pl/~pborys/"
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ nls? ( >=sys-devel/gettext-0.10.39 )
+ >=sys-devel/bison-1.28"
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ nls? ( >=sys-devel/gettext-0.10.39 )"
+SLOT="0"
+LICENSE="GPL-2"
+
+src_compile() {
+ local myc
+
+ use readline && myc="${myc} --with-readline" || myc="${myc} --without-readline"
+ use nls && myc="${myc} --enable-nls" || myc="${myc} --disable-nls"
+
+ econf ${myc} || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} sysconfdir=/etc install || die
+}