summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2012-06-22 20:04:23 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2012-06-22 20:04:23 +0000
commit147c21bdca297d08292df6023642aaa81fa17f8f (patch)
treec9e282eac9c3b6667db35a496bbc9e5c3cc1f0eb /app-text/pandoc
parentremove old (diff)
downloadgentoo-2-147c21bdca297d08292df6023642aaa81fa17f8f.tar.gz
gentoo-2-147c21bdca297d08292df6023642aaa81fa17f8f.tar.bz2
gentoo-2-147c21bdca297d08292df6023642aaa81fa17f8f.zip
bump pandoc to 1.9.4.1
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'app-text/pandoc')
-rw-r--r--app-text/pandoc/ChangeLog8
-rw-r--r--app-text/pandoc/files/pandoc-1.9.4.1-ghc-7.5.patch75
-rw-r--r--app-text/pandoc/pandoc-1.9.4.1.ebuild81
3 files changed, 163 insertions, 1 deletions
diff --git a/app-text/pandoc/ChangeLog b/app-text/pandoc/ChangeLog
index 1203d411d25b..6b96975dcc60 100644
--- a/app-text/pandoc/ChangeLog
+++ b/app-text/pandoc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/pandoc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pandoc/ChangeLog,v 1.6 2012/06/02 09:49:45 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pandoc/ChangeLog,v 1.7 2012/06/22 20:04:23 qnikst Exp $
+
+*pandoc-1.9.4.1 (23 Jun 2012)
+
+ 23 Jun 2012; Alexander Vershilov <qnikst@gentoo.org> +pandoc-1.9.4.1.ebuild,
+ +files/pandoc-1.9.4.1-ghc-7.5.patch:
+ Bump pandoc to 1.9.4.1
*pandoc-1.9.3 (02 Jun 2012)
diff --git a/app-text/pandoc/files/pandoc-1.9.4.1-ghc-7.5.patch b/app-text/pandoc/files/pandoc-1.9.4.1-ghc-7.5.patch
new file mode 100644
index 000000000000..96678c623fd9
--- /dev/null
+++ b/app-text/pandoc/files/pandoc-1.9.4.1-ghc-7.5.patch
@@ -0,0 +1,75 @@
+--- pandoc-1.9.4.1-orig/pandoc.cabal 2012-06-09 00:53:31.000000000 +0400
++++ pandoc-1.9.4.1/pandoc.cabal 2012-06-22 10:05:19.423632114 +0400
+@@ -197,7 +197,7 @@
+ -- Note: the following is duplicated in all stanzas.
+ -- It needs to be duplicated because of the library & executable flags.
+ -- BEGIN DUPLICATED SECTION
+- Build-Depends: containers >= 0.1 && < 0.5,
++ Build-Depends: containers >= 0.1 && < 0.6,
+ parsec >= 3.1 && < 3.2,
+ mtl >= 1.1 && < 2.2,
+ network >= 2 && < 2.4,
+@@ -302,7 +302,7 @@
+ -- Note: the following is duplicated in all stanzas.
+ -- It needs to be duplicated because of the library & executable flags.
+ -- BEGIN DUPLICATED SECTION
+- Build-Depends: containers >= 0.1 && < 0.5,
++ Build-Depends: containers >= 0.1 && < 0.6,
+ parsec >= 3.1 && < 3.2,
+ mtl >= 1.1 && < 2.2,
+ network >= 2 && < 2.4,
+@@ -366,7 +366,7 @@
+ -- Note: the following is duplicated in all stanzas.
+ -- It needs to be duplicated because of the library & executable flags.
+ -- BEGIN DUPLICATED SECTION
+- Build-Depends: containers >= 0.1 && < 0.5,
++ Build-Depends: containers >= 0.1 && < 0.6,
+ parsec >= 3.1 && < 3.2,
+ mtl >= 1.1 && < 2.2,
+ network >= 2 && < 2.4,
+--- pandoc-1.9.4.1-orig/Setup.hs 2012-06-09 00:53:31.000000000 +0400
++++ pandoc-1.9.4.1/Setup.hs 2012-06-22 10:09:55.570160482 +0400
+@@ -1,3 +1,5 @@
++{-# LANGUAGE CPP #-}
++
+ import Distribution.Simple
+ import Distribution.Simple.Setup
+ (copyDest, copyVerbosity, fromFlag, installVerbosity, BuildFlags(..))
+@@ -20,6 +22,10 @@
+ import Data.Maybe ( catMaybes )
+ import Data.List ( (\\) )
+
++#if (__GLASGOW_HASKELL__>=705)
++import Data.Time.Clock.POSIX ( utcTimeToPOSIXSeconds )
++#endif
++
+ main :: IO ()
+ main = do
+ defaultMainWithHooks $ simpleUserHooks {
+@@ -89,14 +95,24 @@
+ installOrdinaryFiles verbosity (mandir (absoluteInstallDirs pkg lbi copy))
+ (zip (repeat manDir) manpages)
+
++getModificationTime' :: FilePath -> IO ClockTime
++getModificationTime' file =
++#if (__GLASGOW_HASKELL__>=705)
++ do utcTime <- getModificationTime file
++ let s = (toEnum . fromEnum . utcTimeToPOSIXSeconds) utcTime
++ return (TOD s 0)
++#else
++ getModificationTime file
++#endif
++
+ -- | Returns a list of 'dependencies' that have been modified after 'file'.
+ modifiedDependencies :: FilePath -> [FilePath] -> IO [FilePath]
+ modifiedDependencies file dependencies = do
+- fileModTime <- catch (getModificationTime file) $
++ fileModTime <- catch (getModificationTime' file) $
+ \e -> if isDoesNotExistError e
+ then return (TOD 0 0) -- the minimum ClockTime
+ else ioError e
+- depModTimes <- mapM getModificationTime dependencies
++ depModTimes <- mapM getModificationTime' dependencies
+ let modified = zipWith (\dep time -> if time > fileModTime then Just dep else Nothing) dependencies depModTimes
+ return $ catMaybes modified
+
diff --git a/app-text/pandoc/pandoc-1.9.4.1.ebuild b/app-text/pandoc/pandoc-1.9.4.1.ebuild
new file mode 100644
index 000000000000..d1f22aa5bdb0
--- /dev/null
+++ b/app-text/pandoc/pandoc-1.9.4.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pandoc/pandoc-1.9.4.1.ebuild,v 1.1 2012/06/22 20:04:23 qnikst Exp $
+
+EAPI=4
+
+# ebuild generated by hackport 0.2.18
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Conversion between markup formats"
+HOMEPAGE="http://johnmacfarlane.net/pandoc"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="=dev-haskell/base64-bytestring-0.1*[profile?]
+ =dev-haskell/blaze-html-0.5*[profile?]
+ >=dev-haskell/citeproc-hs-0.3.4[profile?]
+ <dev-haskell/citeproc-hs-0.4[profile?]
+ >=dev-haskell/highlighting-kate-0.5.1[profile?]
+ <dev-haskell/highlighting-kate-0.6[profile?]
+ >=dev-haskell/http-4000.0.5[profile?]
+ <dev-haskell/http-4000.3[profile?]
+ >=dev-haskell/json-0.4[profile?]
+ <dev-haskell/json-0.6[profile?]
+ >=dev-haskell/mtl-1.1[profile?]
+ <dev-haskell/mtl-2.2[profile?]
+ >=dev-haskell/network-2[profile?]
+ <dev-haskell/network-2.4[profile?]
+ >=dev-haskell/pandoc-types-1.9.0.2[profile?]
+ <dev-haskell/pandoc-types-1.10[profile?]
+ =dev-haskell/parsec-3.1*[profile?]
+ >=dev-haskell/random-1[profile?]
+ <dev-haskell/random-1.1[profile?]
+ >=dev-haskell/syb-0.1[profile?]
+ <dev-haskell/syb-0.4[profile?]
+ >=dev-haskell/tagsoup-0.12.5[profile?]
+ <dev-haskell/tagsoup-0.13[profile?]
+ =dev-haskell/temporary-1.1*[profile?]
+ >=dev-haskell/texmath-0.6.0.2[profile?]
+ <dev-haskell/texmath-0.7[profile?]
+ >=dev-haskell/time-1.2[profile?]
+ <dev-haskell/time-1.5[profile?]
+ =dev-haskell/utf8-string-0.3*[profile?]
+ >=dev-haskell/xml-1.3.12[profile?]
+ <dev-haskell/xml-1.4[profile?]
+ >=dev-haskell/zip-archive-0.1.1.7[profile?]
+ <dev-haskell/zip-archive-0.2[profile?]
+ =dev-haskell/zlib-0.5*[profile?]
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/ansi-terminal[profile?]
+ dev-haskell/diff[profile?]
+ dev-haskell/hunit[profile?]
+ dev-haskell/quickcheck:2[profile?]
+ dev-haskell/test-framework-hunit[profile?]
+ dev-haskell/test-framework-quickcheck2[profile?]
+ dev-haskell/test-framework[profile?]
+ )"
+
+PATCHES=("${FILESDIR}/${PN}-1.9.4.1-ghc-7.5.patch")
+
+src_configure() {
+ cabal_src_configure \
+ $(cabal_flag test tests)
+}
+
+src_install() {
+ cabal_src_install
+
+ doman "${S}/man/man1/${PN}.1"
+
+ # COPYING is installed by the Cabal eclass
+ dodoc README COPYRIGHT changelog
+}