summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gardiner <obz@gentoo.org>2003-11-29 03:45:38 +0000
committerMike Gardiner <obz@gentoo.org>2003-11-29 03:45:38 +0000
commitb4d1e438a3128f6dfbb1a2ba84fccdb356e21476 (patch)
treea467b948795478ed01bb8734add2d56432e76ef6 /app-text/noweb/noweb-2.9-r3.ebuild
parentfix bug #32969 and head/tail stuff (diff)
downloadgentoo-2-b4d1e438a3128f6dfbb1a2ba84fccdb356e21476.tar.gz
gentoo-2-b4d1e438a3128f6dfbb1a2ba84fccdb356e21476.tar.bz2
gentoo-2-b4d1e438a3128f6dfbb1a2ba84fccdb356e21476.zip
make touch fix
Diffstat (limited to 'app-text/noweb/noweb-2.9-r3.ebuild')
-rw-r--r--app-text/noweb/noweb-2.9-r3.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/app-text/noweb/noweb-2.9-r3.ebuild b/app-text/noweb/noweb-2.9-r3.ebuild
index 5ece56d8d137..68518c6e82f7 100644
--- a/app-text/noweb/noweb-2.9-r3.ebuild
+++ b/app-text/noweb/noweb-2.9-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/noweb/noweb-2.9-r3.ebuild,v 1.5 2003/10/03 17:28:16 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/noweb/noweb-2.9-r3.ebuild,v 1.6 2003/11/29 03:45:25 obz Exp $
inherit eutils
@@ -20,12 +20,16 @@ DEPEND="sys-devel/gcc
KEYWORDS="x86 ppc sparc alpha"
src_unpack() {
+
unpack ${A} ; cd ${S}
epatch ${FILESDIR}/${P}-security.patch
epatch ${FILESDIR}/${P}-gentoo.diff
- find -type f | xargs touch
+ # make touch only touches the files required, not the whole
+ # tree as with find . -type f | xargs touch <obz@gentoo.org>
+ make touch
+
}
src_compile() {