summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-01-24 20:04:21 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-01-24 20:04:21 +0000
commit710f387c8735dcccdfa2751aa1d30be10f72bb83 (patch)
tree9a03160fb1dfafcd2ed296c958be47d6688a18b5 /app-text/kaspaliste
parentAdd patch to fix the 'Save As...' problem that's not fixed in 3.5.1. (diff)
downloadgentoo-2-710f387c8735dcccdfa2751aa1d30be10f72bb83.tar.gz
gentoo-2-710f387c8735dcccdfa2751aa1d30be10f72bb83.tar.bz2
gentoo-2-710f387c8735dcccdfa2751aa1d30be10f72bb83.zip
Fix building with gcc34 thanks to Erik Ridderby <paddlaren@gmail.com> in bug 119969
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'app-text/kaspaliste')
-rw-r--r--app-text/kaspaliste/ChangeLog11
-rw-r--r--app-text/kaspaliste/Manifest9
-rw-r--r--app-text/kaspaliste/files/digest-kaspaliste-0.96-r11
-rw-r--r--app-text/kaspaliste/files/gcc34.patch28
-rw-r--r--app-text/kaspaliste/kaspaliste-0.96-r1.ebuild30
5 files changed, 74 insertions, 5 deletions
diff --git a/app-text/kaspaliste/ChangeLog b/app-text/kaspaliste/ChangeLog
index 613180bf5930..e759bc6e7240 100644
--- a/app-text/kaspaliste/ChangeLog
+++ b/app-text/kaspaliste/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/kaspaliste
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/kaspaliste/ChangeLog,v 1.8 2005/03/15 21:02:17 lanius Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/kaspaliste/ChangeLog,v 1.9 2006/01/24 20:04:21 genstef Exp $
+
+*kaspaliste-0.96-r1 (24 Jan 2006)
+
+ 24 Jan 2006; Stefan Schweizer <genstef@gentoo.org> +files/gcc34.patch,
+ +kaspaliste-0.96-r1.ebuild:
+ Fix building with gcc34 thanks to Erik Ridderby <paddlaren@gmail.com> in bug
+ 119969
15 Mar 2005; Heinrich Wendel <lanius@gentoo.org> kaspaliste-0.96.ebuild:
stable
diff --git a/app-text/kaspaliste/Manifest b/app-text/kaspaliste/Manifest
index 944e9ea1a667..9e483e9586eb 100644
--- a/app-text/kaspaliste/Manifest
+++ b/app-text/kaspaliste/Manifest
@@ -1,4 +1,7 @@
-MD5 8aa1330b2ef552c8d74708dd84d73d08 metadata.xml 178
-MD5 f4584a1ba5ff9b19e36a8db0e88c98b3 ChangeLog 945
-MD5 ebe80b86bdca9e197cff6653387a8764 kaspaliste-0.96.ebuild 713
+MD5 c0d601540ba4584c28ca5cccc9f1ef06 ChangeLog 1172
MD5 3f0461a89ce9b6c776da694a8c844a4a files/digest-kaspaliste-0.96 68
+MD5 3f0461a89ce9b6c776da694a8c844a4a files/digest-kaspaliste-0.96-r1 68
+MD5 bfd96ad682d601276091e780988778d7 files/gcc34.patch 797
+MD5 da7a64eda28672d48a064764c709775f kaspaliste-0.96-r1.ebuild 793
+MD5 ebe80b86bdca9e197cff6653387a8764 kaspaliste-0.96.ebuild 713
+MD5 8aa1330b2ef552c8d74708dd84d73d08 metadata.xml 178
diff --git a/app-text/kaspaliste/files/digest-kaspaliste-0.96-r1 b/app-text/kaspaliste/files/digest-kaspaliste-0.96-r1
new file mode 100644
index 000000000000..467d07ad3ecb
--- /dev/null
+++ b/app-text/kaspaliste/files/digest-kaspaliste-0.96-r1
@@ -0,0 +1 @@
+MD5 6256575740bb4bc5aa542f10e749bc01 kaspaliste-0.96.tar.gz 1923396
diff --git a/app-text/kaspaliste/files/gcc34.patch b/app-text/kaspaliste/files/gcc34.patch
new file mode 100644
index 000000000000..2241c29944af
--- /dev/null
+++ b/app-text/kaspaliste/files/gcc34.patch
@@ -0,0 +1,28 @@
+GCC 3.4 patch thanks to Erik Ridderby <paddlaren@gmail.com> in http://bugs.gentoo.org/119969
+
+--- kaspaliste-0.96/kaspaliste/klib/kaspabase.cpp.orig 2006-01-24 20:59:41.000000000 +0100
++++ kaspaliste-0.96/kaspaliste/klib/kaspabase.cpp 2006-01-24 21:01:09.000000000 +0100
+@@ -184,7 +184,22 @@
+ LockTableItem *KaspaBase::locktable=0L;
+
+ Oid KaspaBase::getNo(Str tab, Oid o) {
+- exec("select no from "+tab+" where oid="+oid2str(o));
++ // Patched by Erik Ridderby
++ // starting here:
++ //
++ Str command;
++ command = "select no from ";
++ command += tab;
++ command += " where oid=";
++ command += oid2str(o);
++
++ exec(command);
++
++ // exec("select no from "+tab+" where oid="+oid2str(o));
++ //
++ // Patch ends here.
++ //
++
+ if(tuples())
+ return str2oid(getValue(0, "no"));
+ else
diff --git a/app-text/kaspaliste/kaspaliste-0.96-r1.ebuild b/app-text/kaspaliste/kaspaliste-0.96-r1.ebuild
new file mode 100644
index 000000000000..c23d779fe0a9
--- /dev/null
+++ b/app-text/kaspaliste/kaspaliste-0.96-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/kaspaliste/kaspaliste-0.96-r1.ebuild,v 1.1 2006/01/24 20:04:21 genstef Exp $
+
+inherit kde eutils
+
+DESCRIPTION="A literature database"
+HOMEPAGE="http://kaspaliste.sourceforge.net"
+SRC_URI="mirror://sourceforge/kaspaliste/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+IUSE=""
+
+#DEPEND=">=dev-db/postgresql-7.3"
+need-kde 3
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/gcc34.patch
+}
+
+pkg_postinst() {
+ einfo "You have to create a database named kaspaliste: %createdb kaspaliste."
+ einfo "And then import the file kaspaliste/data/create.tables.sql from the kaspaliste directory:"
+ einfo "%psql kaspaliste -f create.tables.sql"
+}
+