summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-09-16 18:37:09 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-09-16 18:37:09 +0000
commit66bca80a1406c60fd9ccccdac65b7cf3670022ec (patch)
tree7287b536bab35ab8a52b0ff59a4625392631c110 /app-text/htmltidy
parentVersion bump for dev channel release. Fixed bug #381289 by Thomas Beinicke (t... (diff)
downloadgentoo-2-66bca80a1406c60fd9ccccdac65b7cf3670022ec.tar.gz
gentoo-2-66bca80a1406c60fd9ccccdac65b7cf3670022ec.tar.bz2
gentoo-2-66bca80a1406c60fd9ccccdac65b7cf3670022ec.zip
Update the ebuild to eapi4, add static-libs useflag, punt libtool archive.
(Portage version: 2.2.0_alpha58/cvs/Linux x86_64)
Diffstat (limited to 'app-text/htmltidy')
-rw-r--r--app-text/htmltidy/ChangeLog8
-rw-r--r--app-text/htmltidy/htmltidy-20090325-r1.ebuild42
-rw-r--r--app-text/htmltidy/htmltidy-20090325.ebuild74
3 files changed, 25 insertions, 99 deletions
diff --git a/app-text/htmltidy/ChangeLog b/app-text/htmltidy/ChangeLog
index b54cf2123acb..306dfa1529ed 100644
--- a/app-text/htmltidy/ChangeLog
+++ b/app-text/htmltidy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/htmltidy
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/htmltidy/ChangeLog,v 1.59 2010/12/01 14:54:15 flameeyes Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/htmltidy/ChangeLog,v 1.60 2011/09/16 18:37:08 scarabeus Exp $
+
+ 16 Sep 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ -htmltidy-20090325.ebuild, htmltidy-20090325-r1.ebuild:
+ Update the ebuild to eapi4, add static-libs useflag, punt libtool archive.
01 Dec 2010; Diego E. Pettenò <flameeyes@gentoo.org>
-files/03-html2db-null.patch, -files/04-htmltidy-docbook.patch,
diff --git a/app-text/htmltidy/htmltidy-20090325-r1.ebuild b/app-text/htmltidy/htmltidy-20090325-r1.ebuild
index adec4283b069..60cacf23f312 100644
--- a/app-text/htmltidy/htmltidy-20090325-r1.ebuild
+++ b/app-text/htmltidy/htmltidy-20090325-r1.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/htmltidy/htmltidy-20090325-r1.ebuild,v 1.1 2010/03/30 08:32:24 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/htmltidy/htmltidy-20090325-r1.ebuild,v 1.2 2011/09/16 18:37:08 scarabeus Exp $
-EAPI=2
-inherit eutils autotools
+EAPI=4
MY_PN="tidy"
-MY_P=${MY_PN}-${PV}
-S="${WORKDIR}"/${MY_P}
+MY_P="${MY_PN}-${PV}"
+
+inherit eutils autotools
DESCRIPTION="Tidy the layout and correct errors in HTML and XML documents"
HOMEPAGE="http://tidy.sourceforge.net/"
@@ -17,11 +17,13 @@ SRC_URI="mirror://gentoo/${MY_P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="debug doc"
+IUSE="debug doc static-libs"
DEPEND="doc? ( app-doc/doxygen )"
RDEPEND=""
+S="${WORKDIR}"/${MY_P}
+
src_prepare() {
# Required to setup the source dist for autotools
einfo "Setting up autotools for source build"
@@ -45,37 +47,31 @@ src_compile() {
}
src_configure() {
- econf $(use_enable debug)
+ econf \
+ $(use_enable debug) \
+ $(use_enable static-libs static)
}
src_install() {
- emake DESTDIR="${D}" install || die "error during make install"
+ default
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
- cd "${S}"/htmldoc
- # It seems the manual page installation in the Makefile's
- # is commented out, so we need to install manually
- # for the moment. Please check this on updates.
- # mv man_page.txt tidy.1
- # doman tidy.1
- #
- # Update:
# Now the man page is provided as an xsl file, which
# we can't use until htmltidy is merged.
# I have generated the man page and quickref which is on
# the mirrors. (bug #132429)
- doman "${WORKDIR}"/"${MY_P}"-doc/tidy.1 || die "doman failed"
+ doman "${WORKDIR}"/"${MY_P}"-doc/tidy.1
# Fix name before installing
mv "${WORKDIR}"/"${MY_P}"-doc/quickref-html \
"${WORKDIR}"/"${MY_P}"-doc/quickref.html
+ cd "${S}"/htmldoc
# Install basic html documentation
- dohtml *.html *.css *.gif "${WORKDIR}"/"${MY_P}"-doc/quickref.html ||
- die "dohtml failed"
+ dohtml *.html *.css *.gif "${WORKDIR}"/"${MY_P}"-doc/quickref.html
# If use 'doc' is set, then we also want to install the
# api documentation
- if use doc; then
- dohtml -r api || die "api dohtml failed"
- fi
+ use doc && dohtml -r api
}
diff --git a/app-text/htmltidy/htmltidy-20090325.ebuild b/app-text/htmltidy/htmltidy-20090325.ebuild
deleted file mode 100644
index 8c6f66bc5b5a..000000000000
--- a/app-text/htmltidy/htmltidy-20090325.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/htmltidy/htmltidy-20090325.ebuild,v 1.10 2010/01/02 12:16:07 fauli Exp $
-
-EAPI=2
-inherit eutils autotools
-
-MY_PN="tidy"
-MY_P=${MY_PN}-${PV}
-S="${WORKDIR}"/${MY_P}
-
-DESCRIPTION="Tidy the layout and correct errors in HTML and XML documents"
-HOMEPAGE="http://tidy.sourceforge.net/"
-SRC_URI="mirror://gentoo/${MY_P}.tar.bz2
- mirror://gentoo/${MY_P}-doc.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="debug doc"
-
-DEPEND="doc? ( app-doc/doxygen )"
-RDEPEND=""
-
-src_prepare() {
- # Required to setup the source dist for autotools
- einfo "Setting up autotools for source build"
- cp -R ./build/gnuauto/* . || die "could not prepare autotools environment"
-
- # Stop tidy from appending -O2 to our CFLAGS
- epatch "${FILESDIR}"/htmltidy-5.10.26-strip-O2-flag.patch
-
- # Define /etc/tidyrc for system wide config, bug 154834
- epatch "${FILESDIR}"/htmltidy-20090325-tidyrc.patch
-
- eautoreconf
-}
-
-src_compile() {
- default
-
- if use doc ; then
- doxygen htmldoc/doxygen.cfg || die "error making apidocs"
- fi
-}
-
-src_configure() {
- econf $(use_enable debug)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "error during make install"
-
- cd "${S}"/htmldoc
- # It seems the manual page installation in the Makefile's
- # is commented out, so we need to install manually
- # for the moment. Please check this on updates.
- # mv man_page.txt tidy.1
- # doman tidy.1
- #
- # Update:
- # Now the man page is provided as an xsl file, which
- # we can't use until htmltidy is merged.
- # I have generated the man page and quickref which is on
- # the mirrors. (bug #132429)
- doman "${WORKDIR}"/${MY_P}-doc/tidy.1
-
- # Install basic html documentation
- dohtml *.html *.css *.gif "${WORKDIR}"/${MY_P}-doc/quickref.html
-
- # If use 'doc' is set, then we also want to install the
- # api documentation
- use doc && dohtml -r api
-}