summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-04 06:41:14 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-04 06:41:14 +0000
commit7bccea6a9acc26c9c0c2c800b7a84094890c9a29 (patch)
tree9b5b36d6b92c1bda2bf2c7bda81abc01c26df605 /app-text/ggv
parent*** empty log message *** (diff)
downloadgentoo-2-7bccea6a9acc26c9c0c2c800b7a84094890c9a29.tar.gz
gentoo-2-7bccea6a9acc26c9c0c2c800b7a84094890c9a29.tar.bz2
gentoo-2-7bccea6a9acc26c9c0c2c800b7a84094890c9a29.zip
*** empty log message ***
Diffstat (limited to 'app-text/ggv')
-rw-r--r--app-text/ggv/files/digest-ggv-1.0.11
-rw-r--r--app-text/ggv/ggv-1.0.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-text/ggv/files/digest-ggv-1.0.1 b/app-text/ggv/files/digest-ggv-1.0.1
new file mode 100644
index 000000000000..f36337a96b22
--- /dev/null
+++ b/app-text/ggv/files/digest-ggv-1.0.1
@@ -0,0 +1 @@
+MD5 c24ee85caf3d522c0d905794f3abd248 ggv-1.0.1.tar.gz
diff --git a/app-text/ggv/ggv-1.0.1.ebuild b/app-text/ggv/ggv-1.0.1.ebuild
new file mode 100644
index 000000000000..2dc388020bf5
--- /dev/null
+++ b/app-text/ggv/ggv-1.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# /home/cvsroot/gentoo-x86/gnome-apps/ggv/ggv-0.95-r1.ebuild,v 1.2 2001/02/01 19:30:33 achim Exp
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Gnome Ghostview"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/"${A}
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND=">=app-text/ghostscript-6.23
+ >=gnome-base/gnome-libs-1.2.4
+ bonobo? ( >=gnome-base/bonobo-1.0 )
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+ if [ "`use bonobo`" ] ; then
+ myconf="$myconf --with-bonobo"
+ else
+ myconf="$myconf --without-bonobo"
+ cp configure configure.orig
+ sed -e "s/BONOBO_TRUE/BONOBO_FALSE/" configure.orig > configure
+ fi
+ try ./configure --host=${CHOST} --prefix=/opt/gnome \
+ $myconf
+ # bonobo support does not work yet
+ try make
+}
+
+src_install() {
+ try make prefix=${D}/opt/gnome install
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}
+
+
+
+