summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-13 22:00:27 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-13 22:00:27 +0000
commit67326df9e2b4fa9e72ec8ffc045cf6e1eb95be53 (patch)
treea52b58b11062316e82c9dfcf5af787e92c2281da /app-text/djvu
parentFixed more zlib issues. The geant3 flag is now only for unit conversion (if g... (diff)
downloadgentoo-2-67326df9e2b4fa9e72ec8ffc045cf6e1eb95be53.tar.gz
gentoo-2-67326df9e2b4fa9e72ec8ffc045cf6e1eb95be53.tar.bz2
gentoo-2-67326df9e2b4fa9e72ec8ffc045cf6e1eb95be53.zip
Revision bump for last change wrt #407989. To stable in purpose since it's trivial.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'app-text/djvu')
-rw-r--r--app-text/djvu/ChangeLog8
-rw-r--r--app-text/djvu/djvu-3.5.24-r1.ebuild93
2 files changed, 100 insertions, 1 deletions
diff --git a/app-text/djvu/ChangeLog b/app-text/djvu/ChangeLog
index c695e99c36d1..a5114eea7ccc 100644
--- a/app-text/djvu/ChangeLog
+++ b/app-text/djvu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/djvu
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/ChangeLog,v 1.126 2012/03/11 16:13:40 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/ChangeLog,v 1.127 2012/03/13 22:00:27 ssuominen Exp $
+
+*djvu-3.5.24-r1 (13 Mar 2012)
+
+ 13 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> +djvu-3.5.24-r1.ebuild:
+ Revision bump for last change wrt #407989. To stable in purpose since it's
+ trivial.
11 Mar 2012; Samuli Suominen <ssuominen@gentoo.org>
files/djvu-3.5.24-gcc46.patch:
diff --git a/app-text/djvu/djvu-3.5.24-r1.ebuild b/app-text/djvu/djvu-3.5.24-r1.ebuild
new file mode 100644
index 000000000000..c35539f69c8f
--- /dev/null
+++ b/app-text/djvu/djvu-3.5.24-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/djvu-3.5.24-r1.ebuild,v 1.1 2012/03/13 22:00:27 ssuominen Exp $
+
+EAPI=4
+inherit eutils fdo-mime autotools flag-o-matic
+
+MY_P="${PN}libre-${PV#*_p}"
+
+DESCRIPTION="DjVu viewers, encoders and utilities"
+HOMEPAGE="http://djvu.sourceforge.net/"
+SRC_URI="mirror://sourceforge/djvu/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE="debug doc jpeg nls tiff xml"
+
+RDEPEND="jpeg? ( virtual/jpeg )
+ tiff? ( media-libs/tiff:0 )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+# No gui, only manual pages left and only on ja...
+LANGS="ja"
+IUSE+=" $(printf "linguas_%s" ${LANGS})"
+
+src_prepare() {
+ sed 's/AC_CXX_OPTIMIZE/OPTS=;AC_SUBST(OPTS)/' -i configure.ac || die #263688
+ rm aclocal.m4 config/{libtool.m4,ltmain.sh,install-sh}
+ epatch "${FILESDIR}/${P}-gcc46.patch"
+ AT_M4DIR="config" eautoreconf
+}
+
+src_configure() {
+ local X I18N
+ if use nls; then
+ for X in ${LANGS}; do
+ if use linguas_${X}; then
+ I18N="${I18N} ${X}"
+ fi
+ done
+ I18N="${I18N# }"
+ if test -n "$I18N"; then
+ I18N="--enable-i18n=${I18N}"
+ else
+ I18N="--enable-i18n"
+ fi
+ else
+ I18N="--disable-i18n"
+ fi
+
+ use debug && append-cppflags "-DRUNTIME_DEBUG_ONLY"
+
+ # We install all desktop files by hand.
+ econf --disable-desktopfiles \
+ --without-qt \
+ $(use_enable xml xmltools) \
+ $(use_with jpeg) \
+ $(use_with tiff) \
+ "${I18N}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc README TODO NEWS
+ use doc && dodoc -r doc
+
+ # Install desktop files.
+ cd desktopfiles
+ for i in {22,32,48,64}; do
+ insinto /usr/share/icons/hicolor/${i}x${i}/mimetypes
+ newins hi${i}-djvu.png image-vnd.djvu.png
+ done
+ insinto /usr/share/mime/packages
+ doins djvulibre-mime.xml
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+ if ! has_version app-text/djview4 || ! has_version app-text/djview; then
+ elog "For djviewer or browser plugin, emerge app-text/djview."
+ fi
+ if has_version app-text/djview4; then
+ ewarn "Note, that app-text/djview4 has changed its name to app-text/djview."
+ fi
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+}