summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-04-29 09:11:06 +0000
committerPeter Volkov <pva@gentoo.org>2011-04-29 09:11:06 +0000
commit9111cb2fab0bb3ded3b4d0a05fcbd2926dd8261a (patch)
treee6fefa78feb69fbb93af4f433d3ac9b37942bff7 /app-text/cuneiform/cuneiform-1.1.0.ebuild
parentStable on amd64 wrt bug #361889 (diff)
downloadgentoo-2-9111cb2fab0bb3ded3b4d0a05fcbd2926dd8261a.tar.gz
gentoo-2-9111cb2fab0bb3ded3b4d0a05fcbd2926dd8261a.tar.bz2
gentoo-2-9111cb2fab0bb3ded3b4d0a05fcbd2926dd8261a.zip
Version bump, thank yaleks for this job.
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'app-text/cuneiform/cuneiform-1.1.0.ebuild')
-rw-r--r--app-text/cuneiform/cuneiform-1.1.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/cuneiform/cuneiform-1.1.0.ebuild b/app-text/cuneiform/cuneiform-1.1.0.ebuild
new file mode 100644
index 000000000000..d14bdbffa57c
--- /dev/null
+++ b/app-text/cuneiform/cuneiform-1.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/cuneiform/cuneiform-1.1.0.ebuild,v 1.1 2011/04/29 09:11:06 pva Exp $
+
+EAPI="4"
+inherit cmake-utils versionator
+
+PV_MAJ=$(get_version_component_range 1-2)
+MY_P=${PN}-linux-${PV}
+
+DESCRIPTION="An enterprise quality optical character recognition (OCR) engine by Cognitive Technologies"
+HOMEPAGE="https://launchpad.net/cuneiform-linux"
+SRC_URI="http://launchpad.net/${PN}-linux/${PV_MAJ}/${PV_MAJ}/+download/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug +imagemagick"
+
+RDEPEND="imagemagick? ( media-gfx/imagemagick )"
+DEPEND=">=dev-util/cmake-2.6.2
+ ${RDEPEND}"
+
+DOCS="readme.txt"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare(){
+ # respect LDFLAGS
+ sed -i 's:\(set[(]CMAKE_SHARED_LINKER_FLAGS "[^"]*\):\1 $ENV{LDFLAGS}:' \
+ "${S}/cuneiform_src/CMakeLists.txt" || die "failed to sed for LDFLAGS"
+ # Fix automagic dependencies / linking
+ if ! use imagemagick; then
+ sed -i "s:find_package(ImageMagick COMPONENTS Magick++):#DONOTFIND:" \
+ "${S}/cuneiform_src/CMakeLists.txt" \
+ || die "Sed for ImageMagick automagic dependency failed."
+ fi
+}