summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-09-06 16:53:59 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-09-06 16:53:59 +0000
commit391e2c62053d59dff71b7ae25a54aae60b019f7d (patch)
tree04ce973215d94f3d44494391dc6a66c1644069b1 /app-text/bibutils
parentEnable XFCE_PLUGINS="menu" by default. (diff)
downloadgentoo-2-391e2c62053d59dff71b7ae25a54aae60b019f7d.tar.gz
gentoo-2-391e2c62053d59dff71b7ae25a54aae60b019f7d.tar.bz2
gentoo-2-391e2c62053d59dff71b7ae25a54aae60b019f7d.zip
Version bump. Fixes bug 336237. Thanks to Diego for the report.
(Portage version: 2.1.9/cvs/Linux x86_64)
Diffstat (limited to 'app-text/bibutils')
-rw-r--r--app-text/bibutils/ChangeLog8
-rw-r--r--app-text/bibutils/bibutils-4.10.ebuild (renamed from app-text/bibutils/bibutils-4.7.ebuild)11
-rw-r--r--app-text/bibutils/bibutils-4.6.ebuild38
3 files changed, 13 insertions, 44 deletions
diff --git a/app-text/bibutils/ChangeLog b/app-text/bibutils/ChangeLog
index 1bcd80eeeec6..c0b749dac8a1 100644
--- a/app-text/bibutils/ChangeLog
+++ b/app-text/bibutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/bibutils
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bibutils/ChangeLog,v 1.8 2010/01/07 02:21:24 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibutils/ChangeLog,v 1.9 2010/09/06 16:53:59 xarthisius Exp $
+
+*bibutils-4.10 (06 Sep 2010)
+
+ 06 Sep 2010; Kacper Kowalik <xarthisius@gentoo.org> -bibutils-4.6.ebuild,
+ -bibutils-4.7.ebuild, +bibutils-4.10.ebuild:
+ Version bump. Fixes bug 336237. Thanks to Diego for the report.
*bibutils-4.7 (07 Jan 2010)
diff --git a/app-text/bibutils/bibutils-4.7.ebuild b/app-text/bibutils/bibutils-4.10.ebuild
index 2441e964f487..4bc6d3562bd3 100644
--- a/app-text/bibutils/bibutils-4.7.ebuild
+++ b/app-text/bibutils/bibutils-4.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bibutils/bibutils-4.7.ebuild,v 1.1 2010/01/07 02:21:24 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibutils/bibutils-4.10.ebuild,v 1.1 2010/09/06 16:53:59 xarthisius Exp $
EAPI=2
inherit toolchain-funcs
@@ -15,7 +15,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-S="${WORKDIR}/${MY_P}"
+S=${WORKDIR}/${MY_P}
src_prepare() {
# The custom configure script sucks, so we'll just do its
@@ -28,11 +28,12 @@ src_prepare() {
-e 's:REPLACE_POSTFIX::g' \
-e 's:make:$(MAKE):g' \
Makefile_start > Makefile \
- || die "Failed to set upt Makefile"
+ || die "Failed to set up Makefile"
+ sed -e '/$(CC) $^ -o $@/d' -i bin/Makefile || die #336237
}
src_install() {
dodir /usr/bin
- emake install || die "emake install failed"
- dodoc ChangeLog
+ emake install || die
+ dodoc ChangeLog || die
}
diff --git a/app-text/bibutils/bibutils-4.6.ebuild b/app-text/bibutils/bibutils-4.6.ebuild
deleted file mode 100644
index 82130efac637..000000000000
--- a/app-text/bibutils/bibutils-4.6.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bibutils/bibutils-4.6.ebuild,v 1.1 2009/11/08 12:59:44 patrick Exp $
-
-EAPI=2
-inherit toolchain-funcs
-
-MY_P="${PN}_${PV}"
-DESCRIPTION="Interconverts between various bibliography formats using a common XML intermediate"
-HOMEPAGE="http://www.scripps.edu/~cdputnam/software/bibutils"
-SRC_URI="http://www.scripps.edu/~cdputnam/software/bibutils/${MY_P}_src.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- # The custom configure script sucks, so we'll just do its
- # job ourselves
- rm -f Makefile configure || die "Failed to purge old Makefile"
- sed \
- -e "s:REPLACE_CC:CC=\"$(tc-getCC) ${CFLAGS}\":g" \
- -e "s:REPLACE_RANLIB:RANLIB=\"$(tc-getRANLIB)\":g" \
- -e "s:REPLACE_INSTALLDIR:\"${D}/usr/bin\":g" \
- -e 's:REPLACE_POSTFIX::g' \
- -e 's:make:$(MAKE):g' \
- Makefile_start > Makefile \
- || die "Failed to set upt Makefile"
-}
-
-src_install() {
- dodir /usr/bin
- emake install || die "emake install failed"
- dodoc ChangeLog
-}