summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2012-10-17 16:54:45 +0000
committerAgostino Sarubbo <ago@gentoo.org>2012-10-17 16:54:45 +0000
commit9a209e3f7eb8c031421083f9ae834c2918c9b598 (patch)
treebf801a0db4282ecdf1f631dcbc8b7483579f9b7c /app-text/bact
parentAdd ~amd64, eapi4 (diff)
downloadgentoo-2-9a209e3f7eb8c031421083f9ae834c2918c9b598.tar.gz
gentoo-2-9a209e3f7eb8c031421083f9ae834c2918c9b598.tar.bz2
gentoo-2-9a209e3f7eb8c031421083f9ae834c2918c9b598.zip
Add ~amd64, EAPI4
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'app-text/bact')
-rw-r--r--app-text/bact/ChangeLog8
-rw-r--r--app-text/bact/bact-0.13.ebuild18
2 files changed, 15 insertions, 11 deletions
diff --git a/app-text/bact/ChangeLog b/app-text/bact/ChangeLog
index a460c63e8ef3..fc8a91c4f7c9 100644
--- a/app-text/bact/ChangeLog
+++ b/app-text/bact/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/bact
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bact/ChangeLog,v 1.6 2009/05/13 03:45:23 darkside Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/bact/ChangeLog,v 1.7 2012/10/17 16:54:45 ago Exp $
+
+ 17 Oct 2012; Agostino Sarubbo <ago@gentoo.org> bact-0.13.ebuild:
+ Add ~amd64, EAPI4
13 May 2009; Jeremy Olexa <darkside@gentoo.org> bact-0.13.ebuild:
(non maintainer commit) QA fixes (user flags) by Espen Hustad in bug 240126
@@ -22,4 +25,3 @@
24 Dec 2005; Mamoru KOMACHI <usata@gentoo.org> +metadata.xml,
+bact-0.13.ebuild:
Initial import.
-
diff --git a/app-text/bact/bact-0.13.ebuild b/app-text/bact/bact-0.13.ebuild
index c92f61620100..db5aa94e9f4b 100644
--- a/app-text/bact/bact-0.13.ebuild
+++ b/app-text/bact/bact-0.13.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bact/bact-0.13.ebuild,v 1.2 2009/05/13 03:45:23 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/bact/bact-0.13.ebuild,v 1.3 2012/10/17 16:54:45 ago Exp $
+
+EAPI=4
inherit toolchain-funcs
@@ -10,23 +12,23 @@ SRC_URI="http://chasen.org/~taku/software/bact/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND=""
RDEPEND="${DEPEND}"
src_compile() {
- emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
+ emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}"
}
src_test() {
- make test || die
+ emake test
}
src_install() {
- dobin bact_learn bact_mkmodel bact_classify || die "dobin failed"
+ dobin bact_learn bact_mkmodel bact_classify
- dohtml index.html bact.css || die "dohtml failed"
- dodoc README AUTHORS || die "dodoc failed"
+ dohtml index.html bact.css
+ dodoc README AUTHORS
}