summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-07-22 21:08:57 +0000
committerPeter Volkov <pva@gentoo.org>2010-07-22 21:08:57 +0000
commit68247cda87a221817c4f3d1d079cc12361e4a9b4 (patch)
tree9b20e2395778ee2f7390f991062db9093a39a477 /app-text/aspell
parentinitial commit. (diff)
downloadgentoo-2-68247cda87a221817c4f3d1d079cc12361e4a9b4.tar.gz
gentoo-2-68247cda87a221817c4f3d1d079cc12361e4a9b4.tar.bz2
gentoo-2-68247cda87a221817c4f3d1d079cc12361e4a9b4.zip
Added patch to fix replace with accented characters, bug 327405, thank Rafael for report.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-text/aspell')
-rw-r--r--app-text/aspell/ChangeLog9
-rw-r--r--app-text/aspell/aspell-0.60.6-r2.ebuild111
-rw-r--r--app-text/aspell/files/aspell-0.60.6-replace-fix.patch46
3 files changed, 165 insertions, 1 deletions
diff --git a/app-text/aspell/ChangeLog b/app-text/aspell/ChangeLog
index 7e438ea65628..4f2e542769ff 100644
--- a/app-text/aspell/ChangeLog
+++ b/app-text/aspell/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/aspell
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.123 2010/06/05 15:45:24 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.124 2010/07/22 21:08:57 pva Exp $
+
+*aspell-0.60.6-r2 (22 Jul 2010)
+
+ 22 Jul 2010; Peter Volkov <pva@gentoo.org> +aspell-0.60.6-r2.ebuild,
+ +files/aspell-0.60.6-replace-fix.patch:
+ Added patch to fix replace with accented characters, bug 327405, thank
+ Rafael for report.
05 Jun 2010; Raúl Porcel <armin76@gentoo.org> aspell-0.60.6-r1.ebuild:
alpha/arm/ia64/s390/sh stable wrt #310015
diff --git a/app-text/aspell/aspell-0.60.6-r2.ebuild b/app-text/aspell/aspell-0.60.6-r2.ebuild
new file mode 100644
index 000000000000..150778ed6f47
--- /dev/null
+++ b/app-text/aspell/aspell-0.60.6-r2.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.60.6-r2.ebuild,v 1.1 2010/07/22 21:08:57 pva Exp $
+
+EAPI="3"
+
+# N.B. This is before inherit of autotools, as autotools.eclass adds the
+# relevant dependencies to DEPEND.
+WANT_AUTOMAKE="1.10"
+
+inherit libtool eutils flag-o-matic autotools
+
+DESCRIPTION="A spell checker replacement for ispell"
+HOMEPAGE="http://aspell.net/"
+SRC_URI="mirror://gnu/aspell/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="nls examples"
+# Note; app-text/aspell-0.6 and app-dicts/aspell-en-0.6 must go stable together
+
+# Build PDEPEND from list of language codes provided in the tree.
+# The PDEPEND string is static - this code just makes it easier to maintain.
+def="app-dicts/aspell-en"
+for l in \
+ "af" "be" "bg" "br" "ca" "cs" "cy" "da" "de" "el" \
+ "en" "eo" "es" "et" "fi" "fo" "fr" "ga" "gl" "he" \
+ "hr" "is" "it" "la" "lt" "nl" "no" "pl" "pt" "pt_BR" \
+ "ro" "ru" "sk" "sl" "sr" "sv" "uk" "vi" ; do
+ dep="linguas_${l}? ( app-dicts/aspell-${l/pt_BR/pt-br} )"
+ [[ ${l} = "de" ]] &&
+ dep="linguas_de? ( || ( app-dicts/aspell-de app-dicts/aspell-de-alt ) )"
+ [[ -z ${PDEPEND} ]] &&
+ PDEPEND="${dep}" ||
+ PDEPEND="${PDEPEND}
+${dep}"
+ def="!linguas_${l}? ( ${def} )"
+ IUSE="${IUSE} linguas_${l}"
+done
+PDEPEND="${PDEPEND}
+${def}"
+
+COMMON_DEPEND=">=sys-libs/ncurses-5.2
+ nls? ( virtual/libintl )"
+
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )"
+
+# English dictionary 0.5 is incompatible with aspell-0.6
+RDEPEND="${COMMON_DEPEND}
+ !=app-dicts/aspell-en-0.5*"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.60.3-templateinstantiations.patch"
+ epatch "${FILESDIR}/${PN}-0.60.5-nls.patch"
+ epatch "${FILESDIR}/${PN}-0.60.5-solaris.patch"
+ epatch "${FILESDIR}/${P}-darwin-bundles.patch"
+ epatch "${FILESDIR}/${P}-replace-fix.patch" #327405
+
+ rm m4/lt* m4/libtool.m4
+ eautoreconf
+ elibtoolize --reverse-deps
+}
+
+src_configure() {
+ filter-flags -fno-rtti
+ filter-flags -fvisibility=hidden #77109
+ filter-flags -maltivec -mabi=altivec
+ use ppc && append-flags -mno-altivec
+
+ # Was bug #46432. Ncurses changed linking with gpm, from NEWS:
+ # "20041009 change GPM initialization, using dl library to load it dynamically
+ # at runtime (Debian #110586)"
+ # and as a side effect it looks like we don't need add gpm library. (20090302)
+ #built_with_use sys-libs/ncurses gpm && mylibs="-lgpm"
+ LIBS="${mylibs}" econf \
+ $(use_enable nls) \
+ --disable-static \
+ --sysconfdir="${EPREFIX}"/etc/aspell \
+ --enable-docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_install() {
+ dodoc README* TODO || die "installing docs failed"
+
+ emake DESTDIR="${D}" install || die "installation failed"
+ mv "${ED}"usr/share/doc/${PF}/man-html "${ED}"usr/share/doc/${PF}/html
+ mv "${ED}"usr/share/doc/${PF}/man-text "${ED}"usr/share/doc/${PF}/text
+
+ # install ispell/aspell compatibility scripts
+ exeinto /usr/bin
+ newexe scripts/ispell ispell-aspell
+ newexe scripts/spell spell-aspell
+
+ if use examples ; then
+ cd examples
+ make clean || die
+ docinto examples
+ dodoc "${S}"/examples/* || die "installing examples failed"
+ fi
+}
+
+pkg_postinst() {
+ elog "In case LINGUAS was not set correctly you may need to install"
+ elog "dictionaries now. Please choose an aspell-<LANG> dictionary or"
+ elog "set LINGUAS correctly and let aspell pull in required packages."
+ elog "After installing an aspell dictionary for your language(s),"
+ elog "You may use the aspell-import utility to import your personal"
+ elog "dictionaries from ispell, pspell and the older aspell"
+}
diff --git a/app-text/aspell/files/aspell-0.60.6-replace-fix.patch b/app-text/aspell/files/aspell-0.60.6-replace-fix.patch
new file mode 100644
index 000000000000..f5c766491338
--- /dev/null
+++ b/app-text/aspell/files/aspell-0.60.6-replace-fix.patch
@@ -0,0 +1,46 @@
+https://bugs.gentoo.org/show_bug.cgi?id=327405
+http://sourceforge.net/tracker/?func=detail&aid=2955373&group_id=245&atid=100245
+
+diff -u -r1.19.2.5 check_funs.cpp
+--- prog/check_funs.cpp 3 Mar 2010 05:16:24 -0000 1.19.2.5
++++ prog/check_funs.cpp 3 Mar 2010 05:34:52 -0000
+@@ -327,7 +327,11 @@
+ wnoutrefresh(choice_w);
+ doupdate();
+ line.resize(0);
++#ifdef HAVE_WIDE_CURSES
++ wint_t c;
++#else
+ int c;
++#endif
+ noecho();
+ int begin_x;
+ {int junk; getyx(choice_w, junk, begin_x);}
+@@ -336,13 +340,12 @@
+ while (true) {
+ handle_last_signal();
+ #ifdef HAVE_WIDE_CURSES
+- wint_t wi = 0;
+- int res = wget_wch(choice_w, &wi);
+- c = wi;
++ int res = wget_wch(choice_w, &c);
++ if (res == ERR) continue;
+ #else
+ c = wgetch(choice_w);
+-#endif
+ if (c == ERR) continue;
++#endif
+ if (c == '\r' || c == '\n' || c == KEY_ENTER)
+ break;
+ if (c == control('c') || c == KEY_BREAK) {
+@@ -373,7 +376,9 @@
+ } else if (x < max_x && 32 <= c && c != '\x7F' && NOT_KEY /*c < 256*/) {
+ #ifdef HAVE_WIDE_CURSES
+ wchar_t wc = c;
+- wins_nwstr(choice_w, &wc, 1);
++ cchar_t cc;
++ setcchar(&cc, &wc, 0, 0, NULL);
++ wins_wch(choice_w, &cc);
+ #else
+ winsch(choice_w, c);
+ #endif