summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-11-06 00:05:52 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-11-06 00:05:52 +0000
commit43ac867b7aa20a8da008f64f157e1a28c8fea6d4 (patch)
treea14ab8d9f5168b88ecf8a0a140eaa44f299505f8 /app-text/asciidoc
parentFixed typo, thanks to Stefan Salewski. (diff)
downloadgentoo-2-43ac867b7aa20a8da008f64f157e1a28c8fea6d4.tar.gz
gentoo-2-43ac867b7aa20a8da008f64f157e1a28c8fea6d4.tar.bz2
gentoo-2-43ac867b7aa20a8da008f64f157e1a28c8fea6d4.zip
Bump to 8.5.0, fixes #290747
(Portage version: 2.2_rc48/cvs/Linux x86_64)
Diffstat (limited to 'app-text/asciidoc')
-rw-r--r--app-text/asciidoc/ChangeLog7
-rw-r--r--app-text/asciidoc/asciidoc-8.5.0.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/app-text/asciidoc/ChangeLog b/app-text/asciidoc/ChangeLog
index f873e0a324cc..a2304c0b6a10 100644
--- a/app-text/asciidoc/ChangeLog
+++ b/app-text/asciidoc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/asciidoc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/asciidoc/ChangeLog,v 1.49 2009/06/27 08:23:15 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/asciidoc/ChangeLog,v 1.50 2009/11/06 00:05:52 patrick Exp $
+
+*asciidoc-8.5.0 (06 Nov 2009)
+
+ 06 Nov 2009; Patrick Lauer <patrick@gentoo.org> +asciidoc-8.5.0.ebuild:
+ Bump to 8.5.0, fixes #290747
27 Jun 2009; Patrick Lauer <patrick@gentoo.org> asciidoc-8.4.5.ebuild:
Adding app-text/docbook-xml-dtd-4.5 to RDEPEND in the hope to fix #272010
diff --git a/app-text/asciidoc/asciidoc-8.5.0.ebuild b/app-text/asciidoc/asciidoc-8.5.0.ebuild
new file mode 100644
index 000000000000..21e0d3b34f9a
--- /dev/null
+++ b/app-text/asciidoc/asciidoc-8.5.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/asciidoc/asciidoc-8.5.0.ebuild,v 1.1 2009/11/06 00:05:52 patrick Exp $
+
+EAPI="2"
+
+DESCRIPTION="A text document format for writing short documents, articles, books and UNIX man pages"
+HOMEPAGE="http://www.methods.co.nz/asciidoc/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="examples vim-syntax doc"
+
+DEPEND=">=virtual/python-2.4
+ ~app-text/docbook-xml-dtd-4.5
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ media-gfx/graphviz"
+RDEPEND="~app-text/docbook-xml-dtd-4.5"
+
+src_prepare(){
+ if ! use vim-syntax; then
+ sed -i -e '/^install/s/install-vim//' Makefile.in
+ else
+ sed -i\
+ -e '/^vimdir/s/@sysconfdir@\/vim/\/usr\/share\/vim\/vimfiles/' \
+ -e 's/\/etc\/vim//' \
+ Makefile.in
+ fi
+
+ sed -i -e 's/fop.sh/fop/' a2x
+}
+
+src_install() {
+ dodir /usr/bin
+
+ use vim-syntax && dodir /usr/share/vim/vimfiles
+
+ emake DESTDIR="${D}" install || die "install failed"
+
+ if use examples; then
+ # This is a symlink to a directory
+ rm -f examples/website/images
+ cp -Rf images examples/website
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+
+ # HTML pages (with their sources)
+ if use doc; then
+ dohtml -r doc/*
+ insinto /usr/share/doc/${PF}/html
+ doins doc/*.txt
+ fi
+
+ # Misc. documentation
+ dodoc BUGS CHANGELOG README
+ dodoc docbook-xsl/asciidoc-docbook-xsl.txt
+}
+
+pkg_preinst() {
+ # Clean any symlinks in /etc possibly installed by previous versions
+ if [ -d "${ROOT}etc/asciidoc" ]; then
+ einfo "Cleaning old symlinks under /etc/asciidoc"
+ for entry in $(find "${ROOT}etc/asciidoc" -type l); do
+ rm -f $entry
+ done
+ fi
+}