summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Gall <tgall@gentoo.org>2004-03-27 19:08:35 +0000
committerTom Gall <tgall@gentoo.org>2004-03-27 19:08:35 +0000
commit92e0d2bf95344c1a982c4a327fb34bad8cc2e59a (patch)
tree8425b8b2356a526e6682a7323dec8e79f5b9a042 /app-shells
parentApplied a patch to install bibtex styles. (diff)
downloadgentoo-2-92e0d2bf95344c1a982c4a327fb34bad8cc2e59a.tar.gz
gentoo-2-92e0d2bf95344c1a982c4a327fb34bad8cc2e59a.tar.bz2
gentoo-2-92e0d2bf95344c1a982c4a327fb34bad8cc2e59a.zip
fixes for ppc64, minor header stuff
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/sash/ChangeLog5
-rw-r--r--app-shells/sash/files/sash-3.6-ppc64-includes.patch12
-rw-r--r--app-shells/sash/sash-3.6.ebuild3
3 files changed, 18 insertions, 2 deletions
diff --git a/app-shells/sash/ChangeLog b/app-shells/sash/ChangeLog
index 7e1f3a81523e..34f5d6a3a6a5 100644
--- a/app-shells/sash/ChangeLog
+++ b/app-shells/sash/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-shells/sash
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/ChangeLog,v 1.19 2004/03/03 20:22:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/ChangeLog,v 1.20 2004/03/27 19:08:35 tgall Exp $
+
+ 27 Mar 2004; Tom Gall <tgall@gentoo.org> sash-3.6.ebuild:
+ fix for ppc64. (header issues)
*sash-3.7 (03 Mar 2004)
diff --git a/app-shells/sash/files/sash-3.6-ppc64-includes.patch b/app-shells/sash/files/sash-3.6-ppc64-includes.patch
new file mode 100644
index 000000000000..12dba4ac019f
--- /dev/null
+++ b/app-shells/sash/files/sash-3.6-ppc64-includes.patch
@@ -0,0 +1,12 @@
+--- cmd_chattr.c.orig 2004-02-28 21:44:15.242130528 -0600
++++ cmd_chattr.c 2004-02-28 21:45:51.734239664 -0600
+@@ -12,6 +12,9 @@
+
+ #include <sys/ioctl.h>
+ #include <sys/types.h>
++#define __KERNEL__
++#include <asm/types.h>
++#undef __KERNEL__
+ #include <linux/ext2_fs.h>
+
+ #include "sash.h"
diff --git a/app-shells/sash/sash-3.6.ebuild b/app-shells/sash/sash-3.6.ebuild
index 043e98d5c975..4ff67af4ed15 100644
--- a/app-shells/sash/sash-3.6.ebuild
+++ b/app-shells/sash/sash-3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.6.ebuild,v 1.9 2004/02/22 07:18:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.6.ebuild,v 1.10 2004/03/27 19:08:35 tgall Exp $
inherit eutils
@@ -24,6 +24,7 @@ src_unpack() {
epatch ${FILESDIR}/sash-3.6-fix-includes.patch
[ `use readline` ] && epatch ${FILESDIR}/sash-3.6-readline.patch
+ [ `use ppc64` ] && epatch ${FILESDIR}/sash-3.6-ppc64-includes.patch
sed -e "s:-O3:${CFLAGS}:" -i Makefile
}